Page 8 of 8 FirstFirst ... 678
Results 106 to 118 of 118

Thread: How To: Install In-Tank Fuel Pump

  1. #106
    beware of perverts... dmention7's Avatar

    '03.5 Blue MSP #2543

    Join Date
    Aug 2005
    Location
    Minneapolis, MN
    Posts
    1,338
    I installed my GSS342 this morning, and this writeup was immensely helpful! One part I was a little unsure of though... When I removed the stock pump from the housing, I could've sworn that the white plastic "bushing" on the pump outlet was snapped into place in the pump housing. But when I was installing the walbro into the housing, I couldn't for the life of me get it to snap into anything. So I just placed it on the new pump outlet in the original orientation and placed the pump back into the housing.

    In this pic (scavenged from another thread), it's the part immediately below the circled rubber seal that I'm talking about.



    Everything went back together just fine otherwise, and the pump works perfectly... does anyone want to reassure me that I did it right, or tell me to go pull the pump and try again? hehe
    2003.5 Laser Blue MSP #2543

  2. #107
    25ish_psi shane02pro5's Avatar


    Join Date
    Jun 2003
    Location
    New Caney, TX
    Posts
    4,995
    Thats normal apparently i did 2 pumps and neither one would allow the retainer clip to stay but the pump cant move anywhere for it to leak so...good to go!
    GT3071R Dual BB 64a/r Steedspeed Mani SpeedCircuit block Arias 8.5:1 Pauter Rods Stage 1 Head AWR oil pan PAR 1-4 Straightcut gearset Haltech F10A J&S Safeguard w Knock Gauge AEM WB Autometer Boost EGT Gauges CS Radiator Walbro GSS342 Fuel Pump Perrin Fuel Rail JoeP FCD Denso Forester 730cc Injectors MSP LSD welded Competition Clutch Stage 5 SS clutchline & brake lines Pope 3" Dp My Custom 3" Boost Activated Cutout Polished Gauge rings Polished Door Sills B&M SS 16oz SS shiftknob Magnacore wires 4awg ground kit Nex Full Coilovers Racing Beat rear sway AWR endlinks DIY Mounts Bronzoil Bushings Redline shiftboot e-brake boot Rota P1 Black 18x8 Yoko S Drives 215/35/18 Sony headunit Sony 1000w 2ch Kenwood 550w 4ch Sony 12" Infinity Reference doors PA 2 farad cap

  3. #108
    beware of perverts... dmention7's Avatar

    '03.5 Blue MSP #2543

    Join Date
    Aug 2005
    Location
    Minneapolis, MN
    Posts
    1,338
    That's what I was hoping to hear, thanks.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #109
    Shfifty-five MSP Kirk's Avatar
    Donated: $20

    2003 Mazdaspeed Protege

    Join Date
    Sep 2005
    Location
    Sylvan Lake, Alberta
    Posts
    305
    Sub

  5. #110
    Registered Member

    2003 Mazdaspeed Protege, 1998 Volvo V70

    Join Date
    Nov 2008
    Location
    Ellicott City, MD
    Posts
    36
    Just did this tonight and on the way home I had the same hesitation problem whichever guy described years ago. I stirred up quite a bit of crap in the tank during the install, and am wondering if the hesitation was from dirty fuel possibly? I'll drive it again tomorrow after everything settles, just wondering if anyone else has experienced this.

    Also, have a new method for getting the GSS342 to fit properly without hacking up the securing clip. Will post that tomorrow as well.

  6. #111
    Registered Member

    mazdaspeed protege

    Join Date
    Feb 2010
    Location
    Guatemala
    Posts
    111
    Quote Originally Posted by stinkycheezmonk View Post
    Just did this tonight and on the way home I had the same hesitation problem whichever guy described years ago. I stirred up quite a bit of crap in the tank during the install, and am wondering if the hesitation was from dirty fuel possibly? I'll drive it again tomorrow after everything settles, just wondering if anyone else has experienced this.

    Also, have a new method for getting the GSS342 to fit properly without hacking up the securing clip. Will post that tomorrow as well.
    some ppl say that de GSS340 is the one that fit without do any mod...

  7. #112
    Banned

    Rust Bucket

    Join Date
    Oct 2007
    Location
    Linden/Charlotte NC
    Posts
    8,502
    ok, so I just installed the deatschwerks fuel pump into my car...and now it will start and idle, but when I blip the throttle it bogs and sounds like its mis-firing.
    Any Ideas? Im going to check the wiring and make sure theres no corrosion, but theres nothing else I can think of

  8. #113
    Registered Member

    P5

    Join Date
    Oct 2011
    Location
    Canada
    Posts
    4
    Thanks for the write-up. I'll be doing this on the weekend to fix a leak.

  9. #114
    Banned

    Rust Bucket

    Join Date
    Oct 2007
    Location
    Linden/Charlotte NC
    Posts
    8,502
    Quote Originally Posted by justanothermp5 View Post
    ok, so I just installed the deatschwerks fuel pump into my car...and now it will start and idle, but when I blip the throttle it bogs and sounds like its mis-firing.
    Any Ideas? Im going to check the wiring and make sure theres no corrosion, but theres nothing else I can think of
    got it figured out, turned out to be a ripped O ring, its the one circled in the diagram at the top of the page..

  10. #115
    Registered Member heckaTIGHTis's Avatar

    2003.5 Mazdaspeed Protege

    Join Date
    Apr 2010
    Location
    San Jose, Ca
    Posts
    123
    Problem: I didn't like the walbro so I decided to put the stock pump back in. The white plastic piece I had to cut and zip-tie to make the walbro fit is pretty much useless when it comes to the stock pump because you can't zip-tie it the same way, and the gap between the two pieces is so wide that the stock fuel pump could just fall straight through it. Suggestions? (other than buying a whole assembly)

    edit: Nevermind, found a 02 protege at the junkyard and got all the stuff i needed including an extra pump
    Last edited by heckaTIGHTis; 11-04-2011 at 02:25 PM.
    Laser Blue 2003.5 MSP #2478

  11. #116
    Registered Member

    2001 Mazda Protege ES

    Join Date
    Dec 2011
    Location
    nyc
    Posts
    3
    crazy late to this post, but this may come in handy for the 01 protege, if i need to do it

  12. #117
    Chief Boot Knocka the_glassman's Avatar


    Join Date
    Jan 2003
    Location
    _
    Posts
    110
    Anyone still have the photos for this?
    FD3S
    FC3S

  13. #118
    Registered Member

    Mazda sp20

    Join Date
    Sep 2016
    Location
    Sydney
    Posts
    7
    Photos please anyone

Page 8 of 8 FirstFirst ... 678

Similar Threads

  1. fuel pump questions
    By ARunto in forum Mazdaspeed Protege
    Replies: 1
    Last Post: 04-06-2003, 07:43 PM
  2. Fuel pump upgrade for use with turbo?
    By biknman in forum Mazda How-To
    Replies: 7
    Last Post: 10-15-2002, 10:47 AM
  3. fuel pump
    By rosendo192000 in forum Mazda MP3
    Replies: 1
    Last Post: 08-09-2002, 11:14 AM
  4. in tank fuel pumps
    By mazdamastertech in forum Mazda Protege
    Replies: 1
    Last Post: 05-20-2002, 11:28 PM
  5. fuel pump and adj reg
    By mazdamastertech in forum Mazda Protege
    Replies: 2
    Last Post: 04-21-2002, 05:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •