Results 1 to 7 of 7

Thread: high mileage and parts breaking

  1. #1
    Registered Member

    mazda cx-9, lux

    Join Date
    Jan 2012
    Location
    fla
    Posts
    7

    high mileage and parts breaking

    hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
    just wondered if anyone has high mileage and lost major components.

    thanks
    tony

  2. #2
    Registered Member

    2014 Ford Explorer Sport, 2009 CX9(Wife's)

    Join Date
    May 2011
    Location
    MN
    Posts
    88
    My wife's 09 CX9 has just over 170k miles.

    2 dealer completed repairs:
    PTU leaked and was replaced @ ~130k miles.
    Forgot one rear wheel bearing went out around shortly before PTU (~120k miles).

    All below was done by me:
    Front brakes replaced a few times, rears replaced once.
    Struts and shocks replaced earlier this year.
    Front passenger window is stripped....mainly due to 3yr old hanging on a partially open window.
    Couple sets of tires.

    Other than the PTU, no other major issues and mostly just normal maintenance.
    Also, original water pump (this does have me worried).
    AC still works.

  3. #3
    Registered Member

    2010 CX-9 GT

    Join Date
    Jan 2011
    Location
    Melbourne, FL
    Posts
    243
    Quote Originally Posted by FlaCX9 View Post
    hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
    just wondered if anyone has high mileage and lost major components.

    thanks
    tony
    List of problems, 2010 GT:
    Both front power window motors went bad
    Front AC blower failed due to drain clog
    Blower relay died
    Pressure sensor for evaporative emissions system failed
    Rear wheel bearing went bad
    Brake rotors/pads developed vibration, had to replace

  4. #4
    Registered Member nguvanh's Avatar

    2010 CX-9 GT AWD

    Join Date
    Jun 2007
    Location
    Lacey, WA
    Posts
    316
    My 2010 GT is at 110K but no problem so far.
    Saw a little leak on engine but haven't figured out where it from.
    I changed myself transfer case oil at 100K but only done 6 pumps and refills, still need more.
    I changed rear differential oil at 100K too, but old one looked as new.
    BT sometimes not connected but it works after a restart.

    Quote Originally Posted by FlaCX9 View Post
    hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
    just wondered if anyone has high mileage and lost major components.

    thanks
    tony
    1996 White Pearl 2.5 Millenia (Traded)
    2007 Liquid Platinum CX-9 Touring DVD & NAV, Remote Engine Start (Traded).
    2010 Crystal White 4dr Mazda3 GT MR/Bose Pkg, Remote Engine Start (Traded).
    2010 Crystal White CX-9 GT MR/Bose Pkg & NAV, PLG, Remote Engine Start
    2019 Machine Gray Metallic Mazda6 GT, MMS
    2019 White Pearl CX-9 SIG, OEM Remote Engine Start

  5. #5
    Registered Member

    mazda cx-9, lux

    Join Date
    Jan 2012
    Location
    fla
    Posts
    7
    anyone done plugs and wires?
    has anyone replaced their remote? i lost one and just down to one now and bought what i thought would work as a replacement but didnt.
    nice to see others with high miles. anyone over 200?
    i plan on keeping it until it dies

    thanks
    tony

  6. #6
    Registered Member

    '11 Mazda CX-9 GT AWD

    Join Date
    Jan 2014
    Location
    Indianapolis
    Posts
    117
    Quote Originally Posted by FlaCX9 View Post
    anyone done plugs and wires?
    i did the plugs at 110k miles or so. they looked fine; i think i posted my experience on here. no need to do "wires" in modern vehicles with coil on plugs. the rears were tough to get to but just takes patience and the right extensions.

    we are at 145k miles now. PTU was replaced under warranty. i also replaced rear shocks around 80-90k miles; that was an experience. tedious. we just had the front struts replaced, took it to a shop; we did KYB all around. other than brakes, tires, filters, and oil changes that has been it!

  7. #7
    Registered Member


    Join Date
    Dec 2019
    Posts
    2
    Hello Tony,

    I was wondering how did you noticed you had to replaced your water pump. I'm aware that this is an internal water pump and it is kind of difficult to noticed if is going bad. My 2010 CX9 just hit 150k miles and I've only replaced front wheel bearings and brakes.

Similar Threads

  1. Any high mileage 18-up cx5s out there?
    By Stickygreen in forum CX-5 General
    Replies: 38
    Last Post: 06-13-2019, 02:18 AM
  2. castrol high mileage=crappy mileage
    By Safe Zone Msp in forum Mazdaspeed Protege
    Replies: 3
    Last Post: 04-26-2010, 08:18 PM
  3. DP install... breaking up at high Rs
    By rynzms3 in forum Mazdaspeed3
    Replies: 16
    Last Post: 03-25-2010, 08:10 PM
  4. high mileage
    By m_V_p651 in forum Mazdaspeed Protege
    Replies: 6
    Last Post: 09-16-2007, 02:05 AM
  5. High Mileage?!?!
    By thaikim in forum Mazdaspeed Protege
    Replies: 8
    Last Post: 09-18-2006, 11:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •