Results 1 to 9 of 9

Thread: Ď13 GT Cold and Low RPM Misfire

  1. #1
    Registered Member


    Join Date
    Sep 2019
    Posts
    3

    Ď13 GT Cold and Low RPM Misfire

    I bought my Ď13GT about 2 years ago and have a long highway commute so itís at about 122k miles now. With about 60k on it, one of the coils failed completely- replaced it and all four plugs and no more issues. At about 115k, I started noticing an inconsistent shake at low RPM under heavy load (which occurs a lot during my commute). Recently, I began noticing that it inconsistently sounded rough during a cold start up as well, and last week it began throwing P0300 and P0303 codes. Knowing the issues I had in the past, I tried to diagnose and ended up replacing the plugs and the coil pack- no dice. Since it only occurs when the engine is cold and warming up or under heavy load at low RPM (aka running rich), my next thought is fuel. My code scanner is a little cheap one that wonít give live info, so itís hard for me to prove injectors vs fuel pump, etc.. The other thing that came to mind is I recently replaced my exhaust mid pipe due to a progressing exhaust leak. I donít hear a leak from the header, but I also canít see it since itís covered in heat shields- anyone have any experience with a failed 2.0 exhaust manifold? How about a fuel pump or injector? I feel like I need more information from the car to truly diagnose- anyone have a code reader that does good freeze frame/live data that theyíd recommend for reasonable money?

    Sorry for the long post, trying to make sure I didnít miss anything. Thanks in advance for any advice.

  2. #2
    2008.5 MGM MS3 rsvinylgraphics's Avatar
    Donated: $5


    Join Date
    Oct 2009
    Location
    Indiana
    Posts
    1,181
    P0303 is misfire on cylinder 3, since you say the plug and coil packs are good it is likely a dirty or faulty fuel injector.

    You could try swapping the cylinder 3 fuel injector to a different cylinder and if the code follows, it will tell you the fuel injector was the issue.

  3. #3
    Banned Chris_Top_Her's Avatar
    Donated: $45
    CX Moderator

    '15 CX-5 Miata GT AWD w/Tech 2.5L

    Join Date
    Sep 2012
    Location
    San Antonio TX
    Posts
    6,255
    Possibly bad plugs.. failing coils at 60k kinda odd, possibly driving habit or cheap gas/plugs. Try a quality fuel cleaner or at least look at the plug condition (bad plugs can mess up coil). P0300 is random misfire. Workshop manual has plug/coil as the big cause, lists specific sensor signals as possible cause. PM me an email address I'll send you a copy and you can see the ecu detection conditions along with factory remedies for your reference

  4. #4
    Registered Member CX-5um's Avatar

    13' CX-5 and 16' Mazda6 both Touring w/Tech/Bose

    Join Date
    Jul 2012
    Location
    Glendale, AZ
    Posts
    3,254
    Had a similar code/s on my Mazda6. I forgot to seat my oil dipstick in all the way and I was low in oil (Error on my part during an oil change). Added oil and seated dipstick correctly. Codes never came back.

    FYI Check if your air filter housing is closed and sealed correctly.

  5. #5
    Registered Member
    Donated: $15

    2016.5 CX 5 Touring AWD, 2015 SCION XB

    Join Date
    Mar 2013
    Location
    ABE area, Pennsylvania, USA
    Posts
    1,446
    Quote Originally Posted by rsvinylgraphics View Post
    P0303 is misfire on cylinder 3, since you say the plug and coil packs are good it is likely a dirty or faulty fuel injector.

    You could try swapping the cylinder 3 fuel injector to a different cylinder and if the code follows, it will tell you the fuel injector was the issue.
    I've had this. A good injector cleaner (Techron) cured it. Cheapest and easiest thing you could try.

  6. #6
    Registered Member

    2014 Mazda CX-5 GT AWD w/Tech

    Join Date
    Aug 2013
    Location
    Bloomington, Minnesota, USA
    Posts
    585
    Try cleaning the mass Airflow Sensor too. Not sure it's the same on the 2.0 as the 2.5, but early 2.5 MAFs had some issues the cleaning didn't help. The part was upgraded to a new part number. Don't know what the changes were but it solved the small driveability issue I was having with my 2014 2.5.

  7. #7
    Registered Member

    2013 Mazda CX-5

    Join Date
    Sep 2016
    Location
    Austin, Texas
    Posts
    9
    Hi, do you have an update? Iím having P0303 issues too and seem to be at a halt for now.

  8. #8
    Registered Member

    Red 2016 CX-5 GT Teck Isense

    Join Date
    Mar 2012
    Location
    GA
    Posts
    993
    If you do not have the ion feedback plugs this can happen - Read this:
    https://www.mazdas247.com/forum/show...linder-3-Issue

  9. #9
    Registered Member


    Join Date
    Sep 2019
    Posts
    3
    Updates thus far- ran a couple bottles of injector cleaner- no dice. Got a better code reader that will output graphs and stuff and thought I saw something in the MAF, so I cleaned it and no change. Have a new MAF coming but I donít think thatís it. The code reader shows how many misfires on each cylinder since start (which I found yesterday). All have 0 except 3, which varies but tends to be about 5 per minute on average. If the MAF doesnít fix it (and Iím thinking it wonít), Iím going to order a full set of injectors, seals, etc. and hit that next... weíll see.
    Nice spot on the plugs- mine are Mazda from the dealership.
    Last edited by Summerisway2hot; 09-15-2019 at 11:49 PM. Reason: Update

Similar Threads

  1. Stuttering at idle when cold, threw misfire code
    By OxnardMontalvo in forum Mazda5 Engine & Transmission
    Replies: 7
    Last Post: 03-04-2016, 10:22 AM
  2. Diesel Cold Start issue misfire and lumpy HELP
    By BROADBEAN9513 in forum CX-5 Engine & Transmission
    Replies: 0
    Last Post: 02-07-2016, 08:00 AM
  3. brakes squeak loud in cold weater cold start up
    By ssl1900 in forum CX-5 Wheels, Tires, Brakes & Suspension
    Replies: 4
    Last Post: 01-04-2016, 11:53 PM
  4. front-end noise when cold weather + cold engine
    By 08_MS3_GT in forum Mazdaspeed3
    Replies: 3
    Last Post: 12-08-2008, 11:08 AM
  5. Replies: 2
    Last Post: 04-22-2005, 12:13 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •