Results 1 to 3 of 3

Thread: AT Light Coming on After 30 Minutes -- Dealership is "Clueless"

  1. #1
    Registered Member


    Join Date
    Aug 2019
    Posts
    1

    AT Light Coming on After 30 Minutes -- Dealership is "Clueless"

    Hello All,

    My wife owns a 2011 CX-9 with approximately 75k miles. Recently, any time we have the car on the road for more than 30 minutes, the AT light comes on. There have not been any other symptoms, with the exception of one time in a parking lot, it felt a bit jerky for a moment but that was not during a gear shift. More recently, the AT light has been accompanied by the CEL. The local dealership had the car for two hours and was able to get the AT light to come on. The code (P2757) referenced an issue with a torque converter -- dealership stated they checked the converter and couldn't find any issue. They stated they "opened the transmission" and checked the solenoids and control module. They applied voltage to the solenoids and everything appeared to be working correctly and the control module seemed functional as well. They flushed and replaced the transmission fluid, hoping their may have been a contaminant in the fluid and a flush would solve the problem. They were apparently unable to get the vehicle to "act up after testing." This was 8/15. Yesterday, 8/23, my wife was driving the car and both lights came back on. The tech stated that if the issue is not resolved (despite them not being able to figure out the issue), their next step would be to replace the control valve assembly and estimated the cost to be $1,600. Does anyone have any thoughts on what could actually be causing this issue? If it is the control valve assembly, is the replacement really a $1,600 job?

    Thank you in advance

  2. #2
    Registered Member

    Mazda CX-9 Grand Touring 2016

    Join Date
    Sep 2016
    Location
    Washington, the state
    Posts
    528
    If you get work done, be sure the work order states the problem as well as stating the repair guessed at by the service writer. If the problem isn't fixed, don't pay. You didn't go in specifically for a new control valve assembly, you went in to get whatever problem repaired that caused the lights.

  3. #3
    Registered Member Bronco Boy's Avatar

    2009 Mazda CX-9 GT

    Join Date
    Aug 2019
    Location
    Coquitlam,BC,Canada
    Posts
    46
    Quote Originally Posted by jnic290 View Post
    If it is the control valve assembly, is the replacement really a $1,600 job?
    Yes, because the valve is inside the transmission, so they will remove the transmission to get at the valve.

Similar Threads

  1. Strange "swooshing" sound coming from the front drivers side?
    By Saskatchewan17 in forum Mazdaspeed3
    Replies: 5
    Last Post: 09-11-2010, 11:49 PM
  2. Dealership claims repeated P0300 is "normal" on "turbo cars" LOL
    By brianguild in forum Mazda6 Engine & Transmission
    Replies: 31
    Last Post: 02-28-2010, 11:31 AM
  3. Flash Animation - "5 more minutes"
    By laracroft in forum Lounge
    Replies: 6
    Last Post: 06-24-2004, 01:02 AM
  4. MP3 "dealership" alarm system
    By Allen in forum Mazda How-To
    Replies: 2
    Last Post: 07-27-2002, 01:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •