Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: cooling fan not working mazda 5 2.0 2006

  1. #1
    Registered Member


    Join Date
    Aug 2019
    Posts
    18

    cooling fan not working mazda 5 2.0 2006

    hi people another post with the same car.
    so went out for the day down the m62 and car went into limp mode no power no dash signals so pulled over on hard shoulder. the cars bonnet was red hot strange because it wasn't a hot day so popped it.
    left car half hour to cool and it started so continued my journey. it happened 2 times on way back waited half hour each time.*
    someone came to house and scanned it came up with ETC so I've replaced coolant temperature sensor and thermostat but its still the same. the radiator fan doesn't kick in only when the air con is on. do think it could be the fan control unit? I've ordered one anyways but second hand because there really pricey to say its a 2006 Mazda. also ordered bluetooth scanner to see what temps go too.
    Also when air con is running car seems fine.*
    if anyone has or had same problem and sorted it I'd be greatfull for help cheers

  2. #2
    Registered Member

    2010 Mazda 5 Sport

    Join Date
    May 2019
    Posts
    36
    https://www.mazdas247.com/forum/show...odule-question

    Similar wonky Fan issue. Sounds like a control module or a sensor to the module.

    Keep us posted.

  3. #3
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    Quote Originally Posted by negusm View Post
    https://www.mazdas247.com/forum/show...odule-question

    Similar wonky Fan issue. Sounds like a control module or a sensor to the module.

    Keep us posted.
    thanks ill have a read and update.

  4. #4
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    I've changed fan and unit over and its still not working. am at a loss. only had the car 2 week. theres white smoke coming out the exhaust too and its been like that since getting it but just thought it was a service it needed. exhaust is dripping liquid so put my finger in it and it smells like coolant do you think this is the reason its braking down.

  5. #5
    Registered Member

    2010 Mazda 5 Sport

    Join Date
    May 2019
    Posts
    36
    Sounds like a blown head gasket. Exhaust getting into the coolant which overheats it. Prior owner screwed you.

  6. #6
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    Quote Originally Posted by negusm View Post
    Sounds like a blown head gasket. Exhaust getting into the coolant which overheats it. Prior owner screwed you.
    coolant not getting low tho so cant understand it.

  7. #7
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    as for my original problem I've taken the fan relay out and connected a wire from one prong to the other and fan kicks in. im just waiting on a new relay to see if the other is not working. ill keep you all posted

  8. #8
    Registered Member

    2010 Mazda 5 Sport

    Join Date
    May 2019
    Posts
    36
    Doesn't have to be too much. It just takes a crack.

  9. #9
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    Quote Originally Posted by negusm View Post
    Doesn't have to be too much. It just takes a crack.
    don't say that lol. I've been looking around and it says that glow plugs can cause smoke also glow relay. if it is coolant wouldn't it smoke all the time?

  10. #10
    Registered Member

    2010 Mazda 5 Sport

    Join Date
    May 2019
    Posts
    36
    Glow Plug? This is a diesel? Didn't know they made such a thing?

    White smoke is a head gasket/cracked head/cracked block. Steam. Big problem.

    Blue/Dark smoke is burning oil/worn engine. Smoke. Not an immediate problem.

    If your exhaust was dripping stuff that smells like coolant...I don't see how you don't have at least a head gasket issue.

    I mean, I have my fingers crossed for you...but I'm not hopeful.

    I have seen cars, with a bad head gasket, that when cold not smoke but when hot get worse.

  11. #11
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    Quote Originally Posted by negusm View Post
    Glow Plug? This is a diesel? Didn't know they made such a thing?

    White smoke is a head gasket/cracked head/cracked block. Steam. Big problem.

    Blue/Dark smoke is burning oil/worn engine. Smoke. Not an immediate problem.

    If your exhaust was dripping stuff that smells like coolant...I don't see how you don't have at least a head gasket issue.

    I mean, I have my fingers crossed for you...but I'm not hopeful.

    I have seen cars, with a bad head gasket, that when cold not smoke but when hot get worse.
    yes mate this is my engine has 4 plugs
    Attached Images Attached Images

  12. #12
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    UPDATE:
    Bought a obd scanner had it plugged in to test the coolant temperature and today temp went to 100c and fan kicked in so thats kind of good but for some reason the revvs was 1000 and back to 750 up and down and out the back white or gray smoke not too sure but it looked like an Indian doing smoke signals. any recommendations to what it might be. I've been reading on mazda site something about when you do any work on mazda like oil change or changing sensors you have to reset the ecu is this true?
    so far I've changed
    oil
    oil filter
    diesel filter
    air filter
    cleaned the sensor on the air filter
    new temp sensor
    new thormastat
    new fan control unit
    I've tried look for the PCV to see if this is the problem also someone on another post said about glow plugs causing smoke and the relay. i know from experience glow plugs heat the car when its cold so it starts.
    my coolant and oil are fine no leaks. air pipes are good no rips. car has good power. its not steam.
    I've ordered a block tester to see if i have head gasket leaks but ill updat on that. thanks for any info.

  13. #13
    Registered Member

    2010 Mazda 5 Sport

    Join Date
    May 2019
    Posts
    36
    Does the white smoke clear up after the engine is up to temp?

  14. #14
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    Quote Originally Posted by negusm View Post
    Does the white smoke clear up after the engine is up to temp?
    it smokes on first start up then when its up to temp it at idle it smokes and the rev goes upto 1000 then back to 750 up and down. driving there's no smoke at all.

  15. #15
    Registered Member


    Join Date
    Aug 2019
    Posts
    18
    https://youtu.be/4zjbCHq12BU
    video to show you guys

Page 1 of 2 12 LastLast

Similar Threads

  1. 2006 Mazda 6 FOB Key Not Working
    By mazdavroom in forum Mazda6 How-To
    Replies: 1
    Last Post: 09-12-2014, 08:55 AM
  2. 2006 Mazda 6 FOB Key Not Working
    By mazdavroom in forum Mazda6 Infotainment
    Replies: 0
    Last Post: 07-28-2014, 01:31 AM
  3. 2006 Mazda 6 FOB Key Not Working
    By mazdavroom in forum Mazda6 How-To
    Replies: 0
    Last Post: 07-28-2014, 01:30 AM
  4. 2006 Mazda 6 FOB Key Not Working
    By mazdavroom in forum Mazda6 Infotainment
    Replies: 0
    Last Post: 07-27-2014, 10:11 PM
  5. Heat/Cooling fan not working
    By velothree in forum Protege5
    Replies: 1
    Last Post: 01-17-2012, 08:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •