VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Results 1 to 3 of 3

Thread: P0134

  1. #1
    Registered Member

    mazda5 GT 2009

    Join Date
    May 2012
    Location
    ca
    Posts
    77

    P0134

    I have a CEL with P0134 code on my M5 2009 GT with 124K+ miles. Most likely O2 sensor needs to be replaced for the first time. I just wanted to hear about experiences/opinions of those who have replaced theirs. Did it clear the code? Dis replacement last? Did you use OEM or aftermarket (denso or ntk or other brand)? Also, does anyone know what company makes the OEM sensors for mazdas, particularly mazda 5s? Thanks.

  2. #2
    Registered Member

    2012 Mazda 5

    Join Date
    Apr 2013
    Location
    Vancouver
    Posts
    724
    This could be a dead O2 or a bad/corroded wire/connector.
    If the wiring is ok, I'd just swap the sensor out. Do it on the warm engine, but not hot, just enough to warm up the sensor but not burn your hands on the exhaust.
    I've not had to do it on a 5 yet, but plenty on others. I usually stick with Denso or Bosch or NTK.
    I found OEM to be way over price and cheap sensor don't last or just garbage out of the box. Make sure to get one with a full harness, not just 3 wires that you need to splice.
    On a mazda it is a little bit of an expensive part, even aftermarket. Check local Napa, see if they get you a good price.

  3. #3
    Registered Member

    mazda5 GT 2009

    Join Date
    May 2012
    Location
    ca
    Posts
    77
    Quote Originally Posted by Vasy View Post
    This could be a dead O2 or a bad/corroded wire/connector.
    If the wiring is ok, I'd just swap the sensor out. Do it on the warm engine, but not hot, just enough to warm up the sensor but not burn your hands on the exhaust.
    I've not had to do it on a 5 yet, but plenty on others. I usually stick with Denso or Bosch or NTK.
    I found OEM to be way over price and cheap sensor don't last or just garbage out of the box. Make sure to get one with a full harness, not just 3 wires that you need to splice.
    On a mazda it is a little bit of an expensive part, even aftermarket. Check local Napa, see if they get you a good price.
    Thanks! I had a shop install a Denso. Code is clear now. Hoping this sensor lasts another 100k miles.

Similar Threads

  1. Just got a P5. Throwing P0134.
    By Yonzy in forum Protege5
    Replies: 4
    Last Post: 06-19-2015, 02:57 PM
  2. P0134 at 56,000 miles
    By Swenny in forum Mazda5 Engine & Transmission
    Replies: 3
    Last Post: 02-04-2014, 12:36 PM
  3. P0134, P0131, P0140 Cels ???
    By zuku26 in forum Mazdaspeed Protege
    Replies: 4
    Last Post: 04-04-2011, 08:38 AM
  4. CEL, P0134, Just installed W/B and DSM-AFC
    By Knox Joe in forum Mazdaspeed Protege
    Replies: 32
    Last Post: 07-21-2009, 09:22 AM
  5. Help Me Ms3 Code P0134 & P0032
    By MSP507 in forum Mazdaspeed3
    Replies: 7
    Last Post: 06-17-2009, 03:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •