Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

Thread: Not starting even with new battery and starter, seems to have lost TCM communication

  1. #16
    Registered Member CX-5um's Avatar

    13' CX-5 and 16' Mazda6 both Touring w/Tech/Bose

    Join Date
    Jul 2012
    Location
    Glendale, AZ
    Posts
    2,939
    This is good news. that said, anyone know where we can get a cheap fuse tester?

  2. #17
    Underutilized Member shadonoz's Avatar
    Donated: $5

    2017 CX-5 GT AWD Tech

    Join Date
    Oct 2017
    Location
    State of Jefferson
    Posts
    1,753
    Quote Originally Posted by CX-5um View Post
    This is good news. that said, anyone know where we can get a cheap fuse tester?
    any multimeter will do it

  3. #18
    Underutilized Member shadonoz's Avatar
    Donated: $5

    2017 CX-5 GT AWD Tech

    Join Date
    Oct 2017
    Location
    State of Jefferson
    Posts
    1,753
    Quote Originally Posted by rickdsac View Post
    Thanks everyone, it was a fuse, I must have missed it when checking last night, it seems to start now. I will find out if the starter was actually bad too when I take it to the auto repair shop so they can test it.
    Occam's razor.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Dead battery, alternator, starter?
    By 90210 in forum Mazda5 Lounge
    Replies: 6
    Last Post: 11-29-2017, 09:09 PM
  2. Starter or battery?
    By 90210 in forum Mazda5 Lounge
    Replies: 3
    Last Post: 04-03-2016, 10:37 AM
  3. Replies: 1
    Last Post: 12-05-2011, 12:42 PM
  4. battery/alternator/starter/wiring wtf?
    By kastleback in forum Protege5
    Replies: 2
    Last Post: 03-15-2010, 11:01 AM
  5. I really need this info! How long is the starter to battery cable?
    By Jason94Cobra in forum Mazdaspeed Protege
    Replies: 3
    Last Post: 04-18-2004, 09:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •