VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Results 1 to 2 of 2

Thread: 10Amp fuse constantly blowing

  1. #1
    Registered Member


    Join Date
    Apr 2019
    Posts
    1

    10Amp fuse constantly blowing

    2002 Mazda Protege
    About a week ago I the 10A fuse inside the car blew and was replaced. Ran fine for a week then blew again. Put 2 more in both blew. Had to get it towed home replaced main 100A fuse under the hood and 10A fuse...let it run for 5 min pulled out of the driveway then it blew again. Where to start???need car for work

  2. #2
    Registered Member Corphish's Avatar

    83 RX-7 Gsl, 2000 Mazda Protege LX, 2011 Mazda3 Sport i

    Join Date
    Aug 2016
    Location
    Baldwin, WI
    Posts
    355
    What’s the 10a fuse go to?

Similar Threads

  1. Amp Fuse/Inline Fuse keep blowing!
    By jerseymods in forum Mazdaspeed Protege
    Replies: 22
    Last Post: 11-05-2014, 05:28 PM
  2. ECU Fuse keeps blowing
    By o0n8 in forum Mazdaspeed Protege
    Replies: 4
    Last Post: 07-01-2011, 06:31 PM
  3. HID kit blowing my fog fuse....
    By LReyes66 in forum Mazda3 Infotainment
    Replies: 11
    Last Post: 07-16-2008, 09:53 AM
  4. fuse f69 keeps blowing
    By riccitelli in forum Mazdaspeed3
    Replies: 9
    Last Post: 04-24-2008, 10:03 PM
  5. Help! Blowing Fi Fuse
    By CBIGGS in forum Protege5
    Replies: 7
    Last Post: 10-12-2006, 09:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •