Results 1 to 5 of 5

Thread: 2018 CX-9's Engine Speed Surge Upon Cold Start

  1. #1
    Registered Member

    2018 mazda cx9

    Join Date
    Oct 2017
    Location
    California
    Posts
    10

    2018 CX-9's Engine Speed Surge Upon Cold Start

    Hi everyone,

    Upon cold start up at 65F, my CX-9's engine speed surges for a second to ~1600RPM from the ~1400RPM warm-up speed. I have been having this problem with my CX-9 from every cold start for a few weeks now as I don't recall it doing this in the past. After the engine is warmed up, the car behaves normally. Please check out the video below. Has anyone had this issue? Should I be concerned? Thank you.
    https://youtu.be/Jm-4y5RmYVc

  2. #2
    Registered Member

    2018 CX9 Sig

    Join Date
    Oct 2018
    Location
    DC Metro
    Posts
    80
    Yes, that is my experience as well. I usually wait until it goes below 1K rpm prior to departure. Hope this helps.

    Peace and blessings,

    Azeke

  3. #3

  4. #4
    Montana/Arizona

    2018.5 CX-9 AWD GT

    Join Date
    Dec 2018
    Location
    Montana
    Posts
    125
    My 2018 rev's a bit higher for about 20 seconds if the motor is cold. Most cars do this. it's normal

  5. #5
    Work in Progress sm1ke's Avatar
    Donated: $25

    2018 Mazda CX-9 Signature

    Join Date
    Dec 2016
    Location
    MB, Canada
    Posts
    1,352
    Does it do the surge consistently in cold weather? Always the exact same short surge to 1600? If so, I'd look further into it. My revs will usually fall slowly upon startup, but will very slightly rise and fall due to all of the other systems engaging (HVAC, defrosters, etc.). It never does a sharp surge like in your video.

    Honestly it may be nothing. If you don't have any check engine lights, I'd just bring it up with the dealer at your own convenience.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Similar Threads

  1. Is your 2017 - 2018 cx-5 running rough on cold days, check your engine mounts
    By Voodooman777 in forum CX-5 Engine & Transmission
    Replies: 4
    Last Post: 02-10-2019, 12:38 AM
  2. 2018 CX-9 - Idle speed / surge
    By brilloAMD in forum CX-9 Engine & Transmission
    Replies: 14
    Last Post: 01-31-2018, 06:14 PM
  3. [2014-2018 BM/BN] Getting rid of the cheap looking Engine Start button
    By TheMAN in forum Mazda3 Accessories & Appearance
    Replies: 0
    Last Post: 11-26-2016, 12:55 AM
  4. Cold Engine Start?
    By erhayes in forum Mazda CX-7
    Replies: 7
    Last Post: 09-25-2007, 04:09 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •