In Memory of Member 1338
In Memory of Member 1338
Results 1 to 8 of 8

Thread: AC issues

  1. #1
    Registered Member Anzi's Avatar

    2002 Protegé5 manual

    Join Date
    Feb 2018
    Location
    SF Bay Area, California
    Posts
    129

    AC issues

    Okay so I know the AC flickering for speeds 2 and 3 is well documented, but my car happens also flicker on speed 4, and I can't seem to find a documented fix for this one. Anyone have experience there?
    Also, how easy would it be to swap the better AC condenser from a 2003 model into my 02?

  2. #2
    Registered Member

    2002 Mazda Protege5

    Join Date
    Dec 2013
    Location
    Bowling Green, KY
    Posts
    77
    I had the same issue and basically all I did was unplug the cable from the switch module that the fan speed switch is connected to and plugged it back in. Speed 4 randomly started working again.. I know that's not the best answer so I am hoping someone else here can provide a better one. I've always had the 2 and 3 issue and wish it was easily fixable.

  3. #3
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    5,104
    Your fan speed switch is probably burned up.

    They are probably only available from the dealer and probably expensive.
    The Diagram Dude

  4. #4
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    5,104
    I found this,..
    They're not ridiculously expensive.

    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  5. #5
    MROD

    mazda protege 5

    Join Date
    Jan 2011
    Location
    Spokane valley
    Posts
    3
    Quote Originally Posted by chevelles240 View Post
    I had the same issue and basically all I did was unplug the cable from the switch module that the fan speed switch is connected to and plugged it back in. Speed 4 randomly started working again.. I know that's not the best answer so I am hoping someone else here can provide a better one. I've always had the 2 and 3 issue and wish it was easily fixable.
    Here is the diy on fixing the AC flicker on 2 and 3.
    https://www.mazdas247.com/forum/show...3-quot-problem

  6. #6
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    5,104
    If her fan switch connector looks like this then she needs to check her fan switch.



    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  7. #7
    Registered Member NaturalFlavored's Avatar

    Mazda P5

    Join Date
    Feb 2015
    Location
    Tucson
    Posts
    582
    Mine almost looked like that, I'm glad I fixed it right before that point. I just soldered wire connectors to the switch the just spliced the wires

  8. #8
    Registered Member Anzi's Avatar

    2002 Protegé5 manual

    Join Date
    Feb 2018
    Location
    SF Bay Area, California
    Posts
    129
    Actually everything looked really good and the resistor fix worked perfectly.

Similar Threads

  1. Belt issues or possible pulley issues
    By Jmalcolm in forum Protege5
    Replies: 13
    Last Post: 10-01-2014, 12:42 AM
  2. Navigation issues & SMS/Email issues
    By Caliche in forum Mazda6 Infotainment
    Replies: 4
    Last Post: 10-03-2013, 11:37 AM
  3. Replies: 12
    Last Post: 08-29-2006, 02:19 PM
  4. serious issues
    By mazda3zoom in forum Mazdaspeed3
    Replies: 11
    Last Post: 06-14-2005, 08:46 AM
  5. You think the MSP has issues?
    By MazdaDryvr in forum Mazdaspeed Protege
    Replies: 18
    Last Post: 01-30-2004, 07:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •