Results 1 to 14 of 14

Thread: 2018 CX-5 Entertainment section stopped working

  1. #1
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20

    2018 CX-5 Entertainment section stopped working

    Yesterday, as i was leaving my hose to drive 400 miles to my parents, my radio on my 5 month cx5 just died. I can no longer select the entertainment option of my CMU. When i go into settings and try to change the bass or treble, or just reverts back to default. The volume knob no longer shows volume level. I have pulled fuse and restored firmware without any luck. Android Auto and Carplay work for gps, but can not play any music as well. I have an appointment w/ my dealer on friday to get it looked at. Has anyone had this same issue happen to them and is there a fix i could possibly do?

    thanks!

  2. #2
    Registered Member

    2018 CX5 SE-L Nav+ 2WD 2.2D 150hp Auto

    Join Date
    Sep 2013
    Location
    Derby UK
    Posts
    376
    I would advise that as it is under warranty, let the dealer fix it. I think you've done what you can.

  3. #3
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    finally got an update on this. My dealer has had my car since Dec 28th. They've swapped CMUs and restored firmware without any luck. Finally on Thursday, after a few days back and forth with Mazda Tech Support, they discovered the FM Modular unit (i think thats what he called it. Its a unit seperate from the CMU, under the dash behind the glovebox) is defective and needs to be replaced. They should have the part either monday or tuesday and i should have my car back then. They were nice enough to give me a loaner, but i miss my car.

  4. #4
    Registered Member

    2018 Mazda CX-5 GT

    Join Date
    Jan 2019
    Location
    Long Island
    Posts
    7
    Quote Originally Posted by Oppie1 View Post
    finally got an update on this. My dealer has had my car since Dec 28th. They've swapped CMUs and restored firmware without any luck. Finally on Thursday, after a few days back and forth with Mazda Tech Support, they discovered the FM Modular unit (i think thats what he called it. Its a unit seperate from the CMU, under the dash behind the glovebox) is defective and needs to be replaced. They should have the part either monday or tuesday and i should have my car back then. They were nice enough to give me a loaner, but i miss my car.
    Hi Oppie1: Did changing the FM Modular Unit solve your problem? I am very curious as I have just experienced the same exact problem and symptoms as you in MY 2018 CX-5. Stopping in at the dealer tomorrow and any information would be helpful.

  5. #5
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    Mikali.....Replied to your pm.

  6. #6
    Registered Member

    2018 Mazda CX-5 GT

    Join Date
    Jan 2019
    Location
    Long Island
    Posts
    7
    Oppie1, I have an update for you. Brought my car to the dealer so he could take a quick look at it. He ended up getting my system audio working again. Here's what he said he did. He said he disconnected the battery for a few minutes, then reconnected it so the firmware would reinstall. He said that then the system started working again. As an extra precaution, he installed the latest version of the software, version 7.0 which also includes the Apple CarPlay/Android Auto updates even though I did not get the updated usb port installed yet (scheduled to have that done next Friday). System works fine now. One question, does your car have a Remote Start installed?

  7. #7
    Registered Member

    18 CX-5

    Join Date
    Apr 2018
    Location
    South Florida
    Posts
    10
    Had a similiar issue today. CarPlay would connect, disconnect, and reconnect constantly. Switched over the FM, and nothing. Just dead. Switched to AM, also nothing, no sound. Meanwhile the Connect system was lagging like a Windows 98 computer. Any clue what causes this?

    For all of the gripes about the CX-5ís engine, the entertainment system has to be the worst, and its not even close. My wifeís 17 Explorerís entertainment system is fantastic.

  8. #8
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    Here is a copy of my work order what they did for me. Swapped the FM tuner

    https://drive.google.com/file/d/1e32...w?usp=drivesdk

  9. #9
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    Quote Originally Posted by Mikali View Post
    Oppie1, I have an update for you. Brought my car to the dealer so he could take a quick look at it. He ended up getting my system audio working again. Here's what he said he did. He said he disconnected the battery for a few minutes, then reconnected it so the firmware would reinstall. He said that then the system started working again. As an extra precaution, he installed the latest version of the software, version 7.0 which also includes the Apple CarPlay/Android Auto updates even though I did not get the updated usb port installed yet (scheduled to have that done next Friday). System works fine now. One question, does your car have a Remote Start installed?

    my car does not have remote start, tho i have been looking into 3rd party options for one

  10. #10
    Registered Member

    2018 Mazda CX-5 GT

    Join Date
    Jan 2019
    Location
    Long Island
    Posts
    7
    Well, I spoke too soon. My audio system worked for 3 days then just crapped out again this morning. I guess disconnecting the battery and updating the software didn't do the trick. When I initially mentioned this thread, the dealer scoffed that "you can't believe what you read on the internet". Oppie1, please keep us apprised if your system continues to work after replacing the FM tuner.

  11. #11
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    Quote Originally Posted by Mikali View Post
    Well, I spoke too soon. My audio system worked for 3 days then just crapped out again this morning. I guess disconnecting the battery and updating the software didn't do the trick. When I initially mentioned this thread, the dealer scoffed that "you can't believe what you read on the internet". Oppie1, please keep us apprised if your system continues to work after replacing the FM tuner.
    as of now, everything is working as expected. zero issues after FM Tuner replacement

  12. #12
    Registered Member

    '17 3 & CX-5

    Join Date
    May 2017
    Location
    Canada
    Posts
    314
    You guys are talking about the Tuner Amplifier Unit (TAU). It's in the right hand kick panel / to the right of the glove box in the dash. It is essentially the whole "radio" / audio amplifier portion of the car's infotainment. The display is just a monitor for the CMU, and the CMU is the "brain" that combines all the car info / systems / NAV / settings with the TAU to complete the infotainment system.

    I haven't heard of many of these failing. It's kind of good to see that if it does it doesn't crash the whole system.

  13. #13
    Registered Member

    2018 Mazda CX-5 GT

    Join Date
    Jan 2019
    Location
    Long Island
    Posts
    7
    Hi Oppie1:

    I hope your system is still working as my system is still down. As I stated, the dealer did a software reload and system worked for 3 days before it crashed again. I called dealer and they said they were going to order a new CMU and that should fix the problem. Brought the car in today and when I picked it up after service hours it still didn't work, though they claimed they had fixed it. I hope they will read this post and maybe consider the tuner module as the problem because I'm getting tired of running back and forth.

  14. #14
    Registered Member

    2018 Mazda cx-5

    Join Date
    Aug 2018
    Location
    Huntsville, Al
    Posts
    20
    Quote Originally Posted by Mikali View Post
    Hi Oppie1:

    I hope your system is still working as my system is still down. As I stated, the dealer did a software reload and system worked for 3 days before it crashed again. I called dealer and they said they were going to order a new CMU and that should fix the problem. Brought the car in today and when I picked it up after service hours it still didn't work, though they claimed they had fixed it. I hope they will read this post and maybe consider the tuner module as the problem because I'm getting tired of running back and forth.
    Yup, after they replaced the TAU under warranty, everything is working as it should. Havenít had issues with my radio since.

Similar Threads

  1. Entertainment section stopped working on 2018 cx5
    By Oppie1 in forum Mazda6 Infotainment
    Replies: 0
    Last Post: 12-22-2018, 09:20 PM
  2. GPS stopped working
    By hallcx5 in forum CX-5 Infotainment
    Replies: 6
    Last Post: 11-07-2018, 12:42 PM
  3. DRL stopped working
    By quant in forum CX-5 Infotainment
    Replies: 4
    Last Post: 11-28-2014, 01:36 PM
  4. A/C stopped working
    By Jay Davidson in forum Mazdaspeed6
    Replies: 3
    Last Post: 09-04-2011, 02:24 PM
  5. Sub Stopped Working!!
    By Mazdaspeed989 in forum Mazda How-To
    Replies: 10
    Last Post: 07-08-2005, 05:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •