Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Results 1 to 7 of 7

Thread: Issue with 2013 Mazda 2 - Rough Idle, Shaking

  1. #1
    Registered Member

    Mazda3

    Join Date
    Jul 2018
    Location
    Australia
    Posts
    5

    Issue with 2013 Mazda 2 - Rough Idle, Shaking

    hey guys.

    have any of you come across this issue.
    my mothers car developed a very rough idle, engine shaking issue. Car is a 2013 Mazda2 DE 1.5L with 50,000km on it. Always serviced and looked after etc.

    Basically after the car warms up but not reach super hot temp (eg 95-100 Celsius coolant temp), when the car is stopped and in D with the brake applied, the engine idles very very rough, shakes, almost if its misfiring. if you put it in N/P the rough idle is still there but not as bad but still noticeable.

    putting air con on, sort of alleviates the problem. however when the car is full hot, where the radiator fans come on and off, then the rough idling seems to be gone. The car idles roughly 650-700rpm in N/P and around 550rpm when in D

    i've checked the spark plugs, ignition coils, and the egr using the resistance values, as specified in the mazda workshop manual and they seem to be ok. I'm thinking of changing the spark plugs, but before i do that i thought i would ask here.
    I've done a fault code scan using a generic scan tool (torque) and no fault codes found either.

    any ideas? anyone else had the same issue?

  2. #2
    Registered Member

    Mazda3

    Join Date
    Jul 2018
    Location
    Australia
    Posts
    5
    doing few more tests, especially when this rough idle/engine shaking happens if i unplug the EGR valve the shaking stops.
    So it looks like it could be the EGR valve.
    anyway has anyone else had to replace theirs or had issues with it before?

  3. #3
    Registered Member

    Mazda3

    Join Date
    Jul 2018
    Location
    Australia
    Posts
    5
    replaced egr valve.... initially through the issue was resolved, but still there...however it does seem not as bad.....but that could be placebo effect.
    i've also been using 98 RON petrol for the past 2 tank fulls.
    anyway have dropped it off at a mazda dealer to see if they can find anything out. however after using the scan tool FORScan I cant see anything thats not working out of place.
    maybe the ECU/PCM needs a update.?.. well wait and see.

  4. #4
    Registered Member

    Mazda3

    Join Date
    Jul 2018
    Location
    Australia
    Posts
    5
    dealers... i really dont have faith in them...just like i assumed they didnt find anything...but wait they said the drivers front side engine mount is no good and causing engine shaking...lol..how pathetic. oh well looks like its time to take mazda to court....

  5. #5
    Registered Member

    Mazda 2 Sport (2008)

    Join Date
    Jan 2019
    Location
    Chile
    Posts
    1
    I recently replaced the left side engine mount and cleaned the MAF sensor on my Mazda 2 2008, The engine was shaking and rattling like hell, and the idle wasn't very stable (Dropped from 700 rpm to 500 a lot of times). After those changes the engine it's running smooth, but sometimes it's idle gets unstable (Fewer times than before). The main problem, at least on the 2008 model was that the engine mount failed early (Mine filed at 80.000km). I don't know if they fixed that problem on the 2013 model.

    So I recommend to check the engine mounts (Especially the passenger side one). Here's a photo of the culprit:

    https://imgur.com/a/sanPSYP

  6. #6
    Registered Member

    Mazda3

    Join Date
    Jul 2018
    Location
    Australia
    Posts
    5
    well good thing is mazda has come to the party and is going to replace the engine mount free of charge.. so well see what happens after that

  7. #7
    Registered Member

    Mazda, Protege5 2002

    Join Date
    Aug 2008
    Location
    Orange County
    Posts
    478
    i had it on mine a bit, cleaned the MAF sensor and is much smoother now. try that first

Similar Threads

  1. Occasional rough idle issue?
    By 72Blazerod in forum Mazda6 Engine & Transmission
    Replies: 1
    Last Post: 03-07-2018, 02:57 AM
  2. timing issue/P0300/rough idle
    By therris in forum Protege5
    Replies: 20
    Last Post: 10-28-2010, 04:09 PM
  3. Yet Another Low/Rough Idle Issue
    By mii-t in forum Protege5
    Replies: 12
    Last Post: 08-26-2008, 07:16 AM
  4. Replies: 3
    Last Post: 02-26-2007, 03:26 PM
  5. 91 mazda has ROUGH idle...
    By jaggerdee in forum Mazda Protege
    Replies: 11
    Last Post: 06-20-2004, 03:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •