Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Results 1 to 4 of 4

Thread: 2003 Mazdaspeed Protege - Delay before it cranks

  1. #1
    Nemo0o skilletrx's Avatar


    Join Date
    Jun 2003
    Location
    Wo0dbr1dge, VA
    Posts
    791

    2003 Mazdaspeed Protege - Delay before it cranks

    Hey guys, just wondering if anyone else has experienced this - when putting in the key, and turning the key, there is a delay before it starts to crank. As long as it cranks, it always starts, but often times there is at least a 2-3 second delay. Any guesses on what this can be/ what the fix it?

    Thanks,
    #1612 SpicyOrange

  2. #2
    2008.5 MGM MS3 rsvinylgraphics's Avatar
    Donated: $5


    Join Date
    Oct 2009
    Location
    Indiana
    Posts
    1,093
    how old is the battery

  3. #3
    Nemo0o skilletrx's Avatar


    Join Date
    Jun 2003
    Location
    Wo0dbr1dge, VA
    Posts
    791
    battery is new. this started happening after the clutch was changed. in a video i saw that there was some relay for the clutch/starter in the fuse box.. wondering if that could be it (?)
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #4
    Swollen Member Natey's Avatar
    Donated: $40

    Mazda

    Join Date
    Jan 2003
    Location
    Pleasure Point, California
    Posts
    6,455
    Will it bump start?

    Clutch switch maybe?

    https://www.mazdas247.com/forum/atta...2&d=1394352528
    Number 11. It keeps the car from turning over unless the clutch in engaged. Mine took a shit and I had similar issues. Cheap and easy to replace.
    NPOT (Norcal Protege Options Team)
    .
    http://www.cardomain.com/ride/335883...photo-gallery/

Similar Threads

  1. 2003 Cranks but no start - What is the noise?
    By damien381 in forum Protege5
    Replies: 16
    Last Post: 01-23-2016, 11:25 AM
  2. Replies: 18
    Last Post: 07-21-2014, 06:37 AM
  3. Replies: 2
    Last Post: 11-24-2013, 08:58 PM
  4. 2003 Protoge - Cranks but won't start
    By Eric1234 in forum Mazda Protege
    Replies: 2
    Last Post: 09-20-2013, 08:42 PM
  5. WTB: 2003 or 2003.5 Mazdaspeed Protege Racing Hart rims
    By FunkyBuddha in forum Want To Buy
    Replies: 3
    Last Post: 04-23-2013, 08:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •