VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Results 1 to 7 of 7

Thread: Cruise control issues

  1. #1
    Registered Member 1stP5's Avatar

    2002 Mazda Protege5

    Join Date
    Mar 2014
    Location
    Seguin, Tx
    Posts
    22

    Cruise control issues

    I have an 02 MP5, when my cruise control is on
    If i turn on my parking lights my cruise control
    Shuts off.....i cant reset it but its just wierd.
    Any ideas?

  2. #2
    Registered Member

    protege5

    Join Date
    May 2016
    Location
    GA
    Posts
    310
    spiral cable (or known as the clock spring) is bad perhaps? Just throwing a dart in the dark. Most likely you're going to have to dig in with a meter and find out exactly what is happening to fix it.

  3. #3
    Registered Member grffn's Avatar

    '02 P5

    Join Date
    Jan 2017
    Location
    Hawaii
    Posts
    200
    again i'd suggest switching back to regular bulbs. since LED's run at a lower voltage, they flash faster (a way of the car telling you a bulb is going out) and it might mess with your cruise control too.
    try going back to regular bulbs to see if that solves it. if that was the problem but you prefer sticking to led's in the parking lights, then i guess you might have to live with that problem...

  4. #4
    Registered Member katapaltes's Avatar

    2003 Protege5

    Join Date
    Mar 2009
    Location
    Dallas, TX
    Posts
    162
    Ha. Just got back from parts store with regular bulbs to replace the aftermarket LEDs in my neighbor's 2009 Civic. (One is dead.) Her ex installed them, along with some HIDs. First sign of trouble with any of his aftermarket choices, I'm replacing them with stock.
    Protect boys (and the men they become) from harm: www.luckystiff.org (my website)

  5. #5
    Registered Member

    2002 Mazda Protege5

    Join Date
    Jan 2019
    Location
    Tilbury, Ontario Canada
    Posts
    2

    Fuse?

    I was wondering if anyone new where the fuse is for the cruise control? Mine wasn't working, but I could hear it engage behind the glove compartment (ended up being a loose connection). However now that the cruise works, the light on my dash doesn't come on. The diagram in the fuse box doesn't say...

    Thanks!

  6. #6
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    4,672
    Check your meter fuse (#15). It powers the cruise control module.

    You would probably have other things out though if that fuse was blown and your cruise control wouldn't work.

    You may have a burned out cruise control light bulb or some other loose connection.

    The Diagram Dude

  7. #7
    Registered Member

    protege5

    Join Date
    May 2016
    Location
    GA
    Posts
    310
    Quote Originally Posted by YoungBuck23 View Post
    I was wondering if anyone new where the fuse is for the cruise control? Mine wasn't working, but I could hear it engage behind the glove compartment (ended up being a loose connection). However now that the cruise works, the light on my dash doesn't come on. The diagram in the fuse box doesn't say...

    Thanks!
    If the cruise control works but the light just doesn't come on, then the fuse and everything are fine. Chances are it is just a burned out bulb. Only other likely possibility would be a wiring issue between the computer and the instrument cluster, but that's a long shot. I'd bet dollars to donuts it's just a bulb.

Similar Threads

  1. WTB: Cruise Control Unit, and 01-03 Cruise Control switch
    By Joost27 in forum Completed Transactions
    Replies: 2
    Last Post: 01-02-2011, 01:21 PM
  2. Overdrive and Cruise Control issues...
    By Protege Patrick in forum Mazda Protege
    Replies: 3
    Last Post: 08-21-2009, 11:47 AM
  3. Cruise Control Issues
    By NickM in forum Protege5
    Replies: 16
    Last Post: 05-21-2009, 04:00 PM
  4. Cruise Control issues?
    By davidjs in forum Protege5
    Replies: 3
    Last Post: 07-27-2008, 09:13 PM
  5. Cruise Control Issues
    By Raverx17 in forum Mazda Protege
    Replies: 2
    Last Post: 10-25-2007, 02:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •