Results 1 to 5 of 5

Thread: 2018 CX-9 Wouldn't Start

  1. #1
    Registered Member

    CX-9

    Join Date
    Mar 2012
    Location
    NJ
    Posts
    16

    2018 CX-9 Wouldn't Start

    Got in my 2018 Grand Touring last weekend and it wouldn't start. I had used it multiple times that day and all was well. I pushed the start button and there was a slight click, all the electric came on fine, but it wouldn't start. Every warning imaginable flashed on the screen. It started with something like "Keyless Start Malfunction" followed by many many others. Tried multiple times, same thing. Got out, locked the car, unlocked the car, tried again, same thing. Switched keys, same thing. Weird thing was that all electric worked, AC came on, lights lit up, windows worked, EXCEPT I couldn't open the trunk.

    I took a different car, went out to dinner, got home 90 minutes later and it started right up and all was well. Later that night I started it again and it started fine except the nav screen never came on. I pulled over, turned it off and turned it back on and it was fine. Been fine all week since.

    Anyone ever have this happen?
    Last edited by grahamb; 10-26-2018 at 02:59 PM.

  2. #2
    Registered Member

    2018 Mazda CX-9 GT

    Join Date
    Jul 2018
    Location
    Boston, MA
    Posts
    62
    on my sister's cx-5 apparently the adapter she was using in her cigarette outlet was holding power and that was causing the fuse to trip and not start the car randomly. are you using something in your cigarette outlets?

  3. #3
    Registered Member

    2018 CX-9 GT

    Join Date
    Dec 2017
    Location
    Ontario
    Posts
    35
    The exact same nav screen issue I had a couple of times randomly.

  4. #4
    Registered Member

    2017 CX9 Sig

    Join Date
    Jan 2018
    Location
    Cda
    Posts
    66
    With almost 2 yrs of ownership it (blank nav screen) has only happened maybe twice or three times...didn't bother bringing it to dealership since it rarely happens. I could get the firmware updated but am too lazy to do it plus the existing firmware so far has held up for almost 2yrs!

  5. #5
    Registered Member

    CX-9

    Join Date
    Mar 2012
    Location
    NJ
    Posts
    16
    I do have something plugged into one of the power ports, but no fuse has tripped. It fixed itself after 90 minutes or so.

    If it threw a code, does anyone know how long they will be stored in the computer?

Similar Threads

  1. CX9 2017 wouldn't start
    By ZzRicezZ in forum CX-9 Lounge
    Replies: 13
    Last Post: 02-14-2018, 02:57 PM
  2. 2016 cx-5 randomly wouldn't start and had 3 different icons pop up on dash
    By meghanconn in forum CX-5 Engine & Transmission
    Replies: 3
    Last Post: 07-05-2017, 11:43 PM
  3. P5 wouldn't start unless door was opened and closed
    By seatown.P5 in forum Protege5
    Replies: 6
    Last Post: 08-18-2009, 11:24 PM
  4. Replies: 12
    Last Post: 11-15-2005, 06:09 PM
  5. Car wouldn't start.
    By RenzoMSP in forum Mazdaspeed Protege
    Replies: 7
    Last Post: 06-19-2004, 03:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •