CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Results 1 to 3 of 3

Thread: Left Headlight Won't Turn On (2011 Mazda3)

  1. #1
    Registered Member

    Mazda3

    Join Date
    Oct 2018
    Location
    Ontario
    Posts
    2

    Left Headlight Won't Turn On (2011 Mazda3)

    Hi I'm new to this forum and need some help. I have a 2011 Mazda3 and the driver's side low beam headlamp (halogen) stopped working; it won't turn on.
    The bulb is OK, I checked the fuses and the relay; they are all OK. I checked for voltage at the fuse with a multi-meter and its there on both sides of the fuse, but not at the bulb.
    Is there another module or component between the fuse and the actual bulb. I read about a discharge control module, but I believe this is used only on Xenon lamps.
    I'm stumped, any help would be appreciated.
    Thanks

  2. #2
    2008.5 MGM MS3 rsvinylgraphics's Avatar
    Donated: $5


    Join Date
    Oct 2009
    Location
    Indiana
    Posts
    1,080
    is there corrosion in the socket perhaps

  3. #3
    Registered Member

    Mazda3

    Join Date
    Oct 2018
    Location
    Ontario
    Posts
    2
    No there is no corrosion. There is no voltage at the female plug when the lights are turned on.
    What has me stumped is that the left light works but if I take bulb out and turn the lights on, it also has no measurable DC voltage either.
    I did this test hoping to compare the one that works, but I cannot explain this.
    Does the circuit need some resistance, a bulb, before the circuit actually energizes?

Similar Threads

  1. Left turn problems
    By TPG in forum CX-9 Lounge
    Replies: 2
    Last Post: 05-20-2018, 08:31 AM
  2. this left turn car almost hurt my msp !!
    By callphy in forum Mazdaspeed Protege
    Replies: 1
    Last Post: 11-12-2013, 02:51 AM
  3. Left turn signal doesn't always work
    By khara in forum Mazda Protege
    Replies: 1
    Last Post: 05-25-2010, 09:59 PM
  4. Left Turn Noise
    By RenzoMSP in forum Mazdaspeed Protege
    Replies: 6
    Last Post: 03-17-2005, 08:30 PM
  5. Scratching sound from MSP CAI when I turn left..
    By Yellospeed in forum Mazdaspeed Protege
    Replies: 6
    Last Post: 09-01-2003, 08:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •