Results 1 to 2 of 2

Thread: My First Issue Looking Fir Guidance

  1. #1
    Registered Member

    2007 CX9 Touring

    Join Date
    Jul 2018
    Location
    Hamilton
    Posts
    7

    My First Issue Looking Fir Guidance

    Hi

    I have just experienced the first issue with my 2007 Mazda CX-8.

    I just noticed that while the radio works fine when I put on the rear defroster it switches to almost 100% static.

    Iíve played around with the rear defrost button and anytime I pressed it the radio immediately becomes staticy.

    Is this a known issue?

    Not sure if this is also a problem but anytime I turn the car off the interior fans go on for about 30 seconds.

    Appreciate any suggestions.

    Alex

  2. #2
    Registered Member

    CX-9 2013 AWD

    Join Date
    Jul 2015
    Location
    NY
    Posts
    344
    I believe the radio antenna on the 2007 CX9 is embedded into the rear windows and is part of the rear defroster wires.. There may be a break in the antenna So when you turn on the defroster. It's causing the static.
    See link.... Seems like a common issue

    https://www.reddit.com/r/explainlike..._rear_defrost/

Similar Threads

  1. NB1 Lane Guidance
    By Kedis82ZE8 in forum CX-5 Infotainment
    Replies: 2
    Last Post: 03-09-2015, 11:46 PM
  2. I need Tint guidance..
    By JITB in forum Pics & Builds
    Replies: 16
    Last Post: 07-07-2009, 03:10 AM
  3. muffler guidance
    By JITB in forum Pics & Builds
    Replies: 5
    Last Post: 06-27-2009, 08:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •