CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Results 1 to 4 of 4

Thread: Cam shaft position sensor fault

  1. #1
    Registered Member

    200

    Join Date
    May 2018
    Location
    Texas
    Posts
    5

    Cam shaft position sensor fault

    Changed sensor, cleared code via scanner and the car would not start and code came back.
    Any advice?

    2002 Mazda Protege

  2. #2
    Registered Member Corphish's Avatar

    83 RX-7 Gsl, 2000 Mazda Protege LX, 2011 Mazda3 Sport i

    Join Date
    Aug 2016
    Location
    Baldwin, WI
    Posts
    283
    Try replacing the crank sensor? Maybe cycle the key a couple times.

  3. #3
    Registered Member

    200

    Join Date
    May 2018
    Location
    Texas
    Posts
    5
    Nope, changed crankshaft sensor didn't fix it.
    Checking if plugs are fuel soaked.
    Still no code came back.

  4. #4
    Registered Member

    200

    Join Date
    May 2018
    Location
    Texas
    Posts
    5
    Checked spark plugs and the looked weird.
    From left to right
    1. Blackened and fuel soaked.
    2. Brand new looking, white and fuel soaked.
    3. Brand new looking, white and fuel soaked.
    4. Grayish and fuel soaked.

Similar Threads

  1. CX-7 parking sensor fault
    By Wycleff in forum Mazda CX-7
    Replies: 0
    Last Post: 04-01-2018, 10:08 AM
  2. New Throttle Position Sensor??
    By TxusMSP in forum Mazdaspeed Protege
    Replies: 8
    Last Post: 05-05-2014, 05:34 PM
  3. Position of o2 sensor
    By ogsp5 in forum Mazdaspeed Protege
    Replies: 5
    Last Post: 08-27-2009, 09:06 PM
  4. Crank Position Sensor (new guy btw!)
    By ChukiDori in forum Mazdaspeed Protege
    Replies: 7
    Last Post: 10-28-2008, 12:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •