Results 1 to 1 of 1

Thread: Fault code p0016

  1. #1
    Registered Member

    Cx-9

    Join Date
    May 2018
    Location
    Richmond
    Posts
    3

    Fault code p0016

    Hey guys I have a dilemma with my
    2013 cx-9, I just recently had a water pump fail which dumped coolant in my oil, I replace the water pump also the timing chain guides. The timing chain was installed correctly all three timing marks where aligned now I'm getting a fault code P0016, so I'm thinking could the contaminated oil have damaged the cam phaser? which might be throwing the cam out of timing with the cam sensor ... the engine oil has been clean and 520w has been added so I'm not sure why I'm getting the fault code any help would be appreciated thank you
    Last edited by Aguilar510; 05-02-2018 at 08:00 PM.

Similar Threads

  1. Fault code P0300 and P0131
    By Mr.T in forum Mazda5 Engine & Transmission
    Replies: 4
    Last Post: 02-24-2016, 03:01 PM
  2. P0606 PCM/ECM Processor Fault code
    By thomasarie in forum Mazda CX-7
    Replies: 0
    Last Post: 05-25-2015, 08:25 AM
  3. Fault code help
    By 3.5speedprotege in forum Mazdaspeed Protege
    Replies: 3
    Last Post: 07-15-2014, 02:32 AM
  4. Fault Code P0126
    By parnet in forum Mazda CX-7
    Replies: 1
    Last Post: 01-01-2014, 03:21 AM
  5. Fault Code 41 Z5 Engine
    By Bazzuk in forum Other Mazdas
    Replies: 0
    Last Post: 07-26-2013, 06:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •