CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Results 1 to 7 of 7

Thread: Still stuttering

  1. #1
    Registered Member

    03 MSP Blue

    Join Date
    Apr 2014
    Location
    San Antonio
    Posts
    9

    Still stuttering

    I still have an issue with hesitation under acceleration. After 3k it cuts power. Around 4500, the engine is pulsing kind of like a miss. I've replaced the wastgate diaphragm, and got corksport intercooler pipes. I thought the bypass valve might be leaking (I know this sounds weird) I put super glue around the seam. The only other "mod" was replacing the air box with a k&n cone filter. No vacuum leaks that I can find and I don't know if it's been reflashed and don't know how to tell. My next step was to see if the intercooler is leaking. Outside of that or the fuel cut, I'm at a loss. Any suggestions?

  2. #2
    Registered Member Bigjakey's Avatar

    MazdaSpeed protege (yellow)

    Join Date
    Jul 2012
    Location
    Youngsville
    Posts
    144
    The only thing I can think of if it doesn't have a check engine light on is the Tuning. The intake being changed could be throwing off the Air/Fuel just enough. these cars have a kinda crappy tune. split second sells a programmer that's got a base map downloaded onto it out the box thats suppose to make these cars run alot better.

  3. #3
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    59
    When I've had issues with fuel cut in the past, it was usually either MAF or ignition coils.
    2003.5 Mazdaspeed Protege - 251k on chassis
    1991 BMW 318is - 283k and M52 swapped

  4. #4
    Registered Member

    03 MSP Blue

    Join Date
    Apr 2014
    Location
    San Antonio
    Posts
    9
    I'll check the maf and post the results. I've replaced the coils a couple of years ago. Maybe time to test those too.

  5. #5
    Registered Member 323's Avatar

    msp

    Join Date
    Mar 2007
    Location
    757
    Posts
    4,896
    check your vtcs and vics solenoids on top of your intake manifold. they're the two with the green and white plugs. if you hook up the terminals of the solenoid to a 9v battery, it should click. if it doesn't, replace it. my vics solenoid was dead and it every time i got up to about 4k rpm, it would stutter but never threw a code.
    03 MSP, 03 P5

  6. #6
    Registered Member

    03 MSP Blue

    Join Date
    Apr 2014
    Location
    San Antonio
    Posts
    9
    Maf 1.49V@ON, 2.2V@idle and increases with engine speed

  7. #7
    Registered Member

    03 MSP Blue

    Join Date
    Apr 2014
    Location
    San Antonio
    Posts
    9
    Bypassed vics by removing circlip that holds shaft of diaphragm to shaft that turns valves and turned to open. Bypassed vtcs by replacing vacuum line to diaphragm with cap. Car absolutely hates full throttle.

Similar Threads

  1. Stuttering
    By drgnzadiel101 in forum Protege5
    Replies: 16
    Last Post: 04-01-2009, 01:05 PM
  2. Stuttering, Anyone else?
    By tluaertetl in forum Mazdaspeed3
    Replies: 11
    Last Post: 07-20-2007, 11:13 AM
  3. stuttering?
    By nluoma in forum Mazdaspeed Protege
    Replies: 0
    Last Post: 06-15-2007, 11:52 PM
  4. Stuttering CX
    By Mamas Ride in forum Mazda CX-7
    Replies: 9
    Last Post: 05-24-2007, 01:29 PM
  5. Stuttering
    By vipergtsxz in forum Mazda Protege
    Replies: 3
    Last Post: 02-04-2006, 01:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •