Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Page 32 of 33 FirstFirst ... 2230313233 LastLast
Results 466 to 480 of 484

Thread: College Student First Car Build

  1. #466
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    haven't attended cars and coffee for over a year. maybe even two. reason we're going is because the weather has cooled down and my wife picked up a new toy 3 weeks ago and wants to take it out. i also wouldn't mind cruising in the msp either because all it does it go on my sad work commute being surrounded by distracted idiots.


  2. #467
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Quote Originally Posted by 323 View Post
    haven't attended cars and coffee for over a year. maybe even two. reason we're going is because the weather has cooled down and my wife picked up a new toy 3 weeks ago and wants to take it out. i also wouldn't mind cruising in the msp either because all it does it go on my sad work commute being surrounded by distracted idiots.

    Bring subie and MSP. Duh
    2003 Sunburst Yellow Mazda Protege5
    Follow my instagram @another_yellowp5

    Mods List
    Interior
    - JVC head unit
    -Sound Ordinance Sub woofer
    Exterior
    -WeatherTech Rain Guards
    Performance
    -HKS axle back
    -MP3 Flashed ECU (removed)
    -MazdaSpeed Protege Turbo kit
    -Tein S tech springs
    -KYB Struts
    -MSP Rear Sway Bar
    -CR3 Relocation Brackets
    -FMIC kit

  3. #468
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Well, after many painful hours I got the car back together and running properly. The rag was jammed in the intercooler somewhat deep, so there was no way it was coming out without taking the piping off. However on first startup I . heard what I thought was a massive vacuum leak, ignored it cause I just wanted to bleed the coolant and call it a night. Drove the car maybe 2 miles and it was in boost and started breaking up real bad. Felt like rapid fuel cut and a horrible misfire at the same time. Backed off of it and stopped, put it in first and floored it and it maybe went up to 4500rpm and would go no further and when I let off the gas no stutututu. So a coupler fell off unfortunately*
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #469
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    Quote Originally Posted by Gabe710 View Post
    Bring subie and MSP. Duh
    that's the plan
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  5. #470
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    what is the plug you are running and what gap? i dont remember if you kept my old plugs.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  6. #471
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    this guy





    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  7. #472
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Quote Originally Posted by 323 View Post
    this guy





    Parked where it belongs. Next to the dumpster
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #473
    Damian Dpwhitehead1's Avatar
    Donated: $25

    LX, MSP 1145

    Join Date
    Jan 2005
    Location
    Owings Mills, Maryland
    Posts
    9,371
    it's really not that bad. at least you have a lip!

    need hydra bumper brackets
    Be happy!

  9. #474
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Quote Originally Posted by Dpwhitehead1 View Post
    it's really not that bad. at least you have a lip!

    need hydra bumper brackets
    Lip is actually the wrong color lol I didn't know the MSP and the P5 had 2 different shades of yellow... and guess which one I gave the guy lol It needs a respray bad cause of the raccoon anyway.

    As for the bumper, I don't have sag issues! The intercooler is actually rubbing against the bumper cause it had bolt holes on the top and bottom of the IC. I cut out a few slits but not enough and have been too lazy to remove the bumper to cut some more out. Maybe one day
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  10. #475
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Well, nothing really to update. I had a few medical emergencies the Friday before cars and coffee (Fiance needed to be picked up from work and then one of my closest friends had to go to a hospital an hour and a half away for some tests so I offered to ride down there with her). I had to stop working on the car at 4 pm and got back home around 12 am. I took a break and decided to fuck with the car some more. Got done around 3 am. I'm having issues with my U pipe staying connected to the pipe going down on the hot side. Tightened the fuck outta it decided to do one quick test pull on the road next to my apartment. Started the car, accelerated towards the gate, heard the blowoff sounding kinda weak but figured I wasn't in boost too much. Pulled out onto the road and 5 feet later I hear a loud pop and have NA power and the car dropped to like 100rpm when I pushed the clutch in. So I turned back around and literally said the car is being driven NA. Turn around and try to figure out if it was that pipe, but everything was tight so I was at a loss. All the piping felt tight. So I start digging around and I blew my BOV clean off the piping lol it was still being held on by the vacuum line. Which explains the thud I heard but assumed it was just my usual suspension clunks. Propped it on the engine, took a shower and finally fell asleep at like 4. I had to leave at 6 to get to cars and coffee on time, but I ended up leaving at like 8 lol Tried to do some field surgery on the car at CNC but the u pipe coupler popped off as soon as we left. I've tried everything, hairspray, cleaning the piping and couplers, nothing works. I got a longer coupler which should work but we shall see. No issues driving to and from Williamsburg. Got home, took a nap and then drove the car back to Richmond for the race that night. Although having issues it felt good to drive the car again! And I got the most miles outta a tank lol about 330 (with some questionable amounts of driving with the low fuel light on) but I didn't get back home until 5 am and figured the car would be parked.

    I went to teach the fiance how to drive manual again a few days ago, and somehow she forgot every last bit of information from a few months ago when she had pretty much gotten it down. My car has never been treated so poorly lol We are gonna have to make it a weekly thing or something so she can get comfortable with it or something.

    And lastly, thanks to 323 for cleaning out his garage. Managed to get some filled motor mounts, his original clutch, and flywheel (hopefully I won't need the clutch and will be upgrading/replacing when the new motor goes in) and a coupler which should help my issue. Will update when motivated to work on the car lol
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  11. #476
    Damian Dpwhitehead1's Avatar
    Donated: $25

    LX, MSP 1145

    Join Date
    Jan 2005
    Location
    Owings Mills, Maryland
    Posts
    9,371
    crimp the ends of the pipe all the way around the lip to give the coupler something to sit on. or have someone weld a bead around it...but that costs money.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  12. #477
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    yeah i dont know why his couplers keep popping off. all of my cut ends on my piping aren't bead rolled.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  13. #478
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Well after neglecting the car for a while, I finally got the car to boost reliably (: not I just gotta hook up the boost gauge cause it feels like it falls off in 3rd gear and up. Will update soon
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  14. #479
    Registered Member

    lolmsp lolms3

    Join Date
    Mar 2007
    Location
    757
    Posts
    5,356
    Probably need a new turbo.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  15. #480
    Registered Member

    2003 Mazda Protege5

    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    427
    Quote Originally Posted by 323 View Post
    Probably need a new turbo.
    Man you provide new turbo ill come down my next day off and install. You gotta surprise everyone and lemme buy your old one
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Page 32 of 33 FirstFirst ... 2230313233 LastLast

Similar Threads

  1. Start of another student build 2003 P5
    By Levis95 in forum Protege5 Builds
    Replies: 17
    Last Post: 12-05-2014, 01:56 PM
  2. CiviCity Student Budget Build
    By CiviCity in forum Mazda Protege
    Replies: 408
    Last Post: 05-22-2014, 02:49 PM
  3. Start of another student build 2003 P5
    By Levis95 in forum Protege5
    Replies: 6
    Last Post: 02-13-2014, 11:09 PM
  4. Poor College student needs to sell P5
    By toywgn in forum Protege5
    Replies: 23
    Last Post: 06-16-2005, 02:07 PM
  5. Replies: 5
    Last Post: 09-18-2003, 03:54 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •