VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Results 1 to 9 of 9

Thread: Idle problems/transmission,engine,motormount?

  1. #1
    Registered Member

    2006 mazda mazda5

    Join Date
    Mar 2018
    Location
    WY
    Posts
    5

    Idle problems/transmission,engine,motormount?

    2006 Mazda mazda5
    Idles hard when in reverse or drive but goes away after sitting in gear for a minute,
    Shift fine except when going 50 and passing 4th to 3rd is fine but it shift down to second and jumps, signs im seeing is torque converter but before i get to anything like that any ideas of what this could be idles fine in park or neutral, and when in gear driving its smooth shifting could this be done with solenoids, there is no dtcs current my last 1 was for thermostat hasnt come on since i changed it.

  2. #2
    Banned GJ-Molestor's Avatar

    2011 BMW 528i, 2015 Mazda 6, 1995 Nissan Maxima Manual

    Join Date
    Apr 2017
    Location
    Toronto
    Posts
    1,806
    Quote Originally Posted by Steersa View Post
    2006 Mazda mazda5
    Idles hard when in reverse or drive but goes away after sitting in gear for a minute,
    Shift fine except when going 50 and passing 4th to 3rd is fine but it shift down to second and jumps, signs im seeing is torque converter but before i get to anything like that any ideas of what this could be idles fine in park or neutral, and when in gear driving its smooth shifting could this be done with solenoids, there is no dtcs current my last 1 was for thermostat hasnt come on since i changed it.
    what is your mileage? sounds like solenoids. probably needs new fluid too.

  3. #3
    Registered Member

    2006 mazda mazda5

    Join Date
    Mar 2018
    Location
    WY
    Posts
    5
    147000 it had bad tranny fluid brown and smell of burnt oil changed it looks good now smells fine too but still rumble when going to reverse or drive i was thinking solenoids myself but at the same time solenoids would throw a cel light wouldnt it, im not sure ill change a torque converter if i have too but i want to.make sure its that and want it to.be fixed before it destroys tranny it self

  4. #4
    Banned GJ-Molestor's Avatar

    2011 BMW 528i, 2015 Mazda 6, 1995 Nissan Maxima Manual

    Join Date
    Apr 2017
    Location
    Toronto
    Posts
    1,806
    Quote Originally Posted by Steersa View Post
    147000 it had bad tranny fluid brown and smell of burnt oil changed it looks good now smells fine too but still rumble when going to reverse or drive i was thinking solenoids myself but at the same time solenoids would throw a cel light wouldnt it, im not sure ill change a torque converter if i have too but i want to.make sure its that and want it to.be fixed before it destroys tranny it self
    Burnt fluid is not a good sign. Transmission issues will not necessarily throw a CEL if there are some shifting issues. I doubt itís your torque converter.

  5. #5
    Registered Member

    2006 mazda mazda5

    Join Date
    Mar 2018
    Location
    WY
    Posts
    5
    Im saying the cel or AT light would come on if it was the solenoids all signs are pointing towards a tcc solenoid or tcc itself just because the rough idle only in drive and reverse and the slight whine it gives when driving in lower gears i just wanted someone elses thought

  6. #6
    Banned GJ-Molestor's Avatar

    2011 BMW 528i, 2015 Mazda 6, 1995 Nissan Maxima Manual

    Join Date
    Apr 2017
    Location
    Toronto
    Posts
    1,806
    Quote Originally Posted by Steersa View Post
    Im saying the cel or AT light would come on if it was the solenoids all signs are pointing towards a tcc solenoid or tcc itself just because the rough idle only in drive and reverse and the slight whine it gives when driving in lower gears i just wanted someone elses thought
    whining = failing transmission unit. the AT or CEL light will not necessarily turn on in every single given situation.

    the idle always gets a little rougher in drive or reverse because the transmission is under load in those two gears. another sign that your transmission is failing. I attribute this to the delayed oil change (burnt fluid = no bueno)

    you may want to take the car to a good transmission shop and see what they have to say. but transmission whine is not a good sign.

  7. #7
    Registered Member

    2006 mazda mazda5

    Join Date
    Mar 2018
    Location
    WY
    Posts
    5

    Starting to rule out torque convertor

    When its cold out side it shakes worse in drive or reverse no shaking in park or nuetral. But theres a whine like its got a supercharger and it dont and vibrates a little taking off and vibrates when decelerating only on higher speed almost anything over 45mph. No grinding noises and metal sounds when i reverse soon as i start backing up i hear 1 pop then fine no popping in drive though. Could tgis be differentials?

  8. #8
    Registered Member

    2006 mazda mazda5

    Join Date
    Mar 2018
    Location
    WY
    Posts
    5
    Im not sure if its coming from transmission though it sounds like its right in the engine bay

  9. #9
    Banned GJ-Molestor's Avatar

    2011 BMW 528i, 2015 Mazda 6, 1995 Nissan Maxima Manual

    Join Date
    Apr 2017
    Location
    Toronto
    Posts
    1,806
    Quote Originally Posted by Steersa View Post
    Im not sure if its coming from transmission though it sounds like its right in the engine bay
    the transmission is basically in the engine bay. if it is worse when cold thats another sign of transmission trouble. could be differential but I doubt it. you can always try to listen while a friend slowly drives the car forward.

Similar Threads

  1. Replies: 3
    Last Post: 05-25-2017, 12:04 AM
  2. Replies: 10
    Last Post: 09-18-2013, 12:48 AM
  3. Idle problems and throttle problems
    By dcdirtrider in forum Mazdaspeed Protege
    Replies: 10
    Last Post: 01-02-2012, 09:54 PM
  4. Mazda b2300 engine idle problems
    By ilper in forum Mazda How-To
    Replies: 1
    Last Post: 09-05-2008, 11:19 PM
  5. Engine knocking and Idle problems
    By mavreix in forum Mazda Protege
    Replies: 6
    Last Post: 09-02-2008, 12:07 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •