Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Results 1 to 2 of 2

Thread: Problems Accelerating

  1. #1
    Registered Member

    2003 Mazda Protege5

    Join Date
    Feb 2018
    Location
    Idaho
    Posts
    4

    Problems Accelerating

    I bought a 2003 Mazda Protege5 from my friend. When i got it there was a rough idle. The RPMs would flutter between 1000 and 0. I got the codes read at O'Riellys and got Random Misfire, Misfire in cylinder 3 and one i can't remember but it's only offered solution was to replace the Idle Air Control Valve so I ordered the part for 250 bucks. I used Sea Foam in the gas tank, break booster line, and used the Sea Foam Spray as directed. It helped but the RPMs fluttered less frequently but were still there. I replaced the coil packs and spark plugs. The idle stays consistent now and the check engine light has turned off. I noticed after I used the Sea Foam Spray my car isn't accelerating properly. When i took it to drive after leaving it for 15 minutes I had to press really hard on the gas pedal to drive. I can get up to highway speed but it's gradual and i basically have to push the pedal to the floor to reach 60mph. From stop to go is slow. I press the gas and the car doesn't move for at least 2-3 seconds. 0-20 in 20 seconds. The RPMs seem normal after 20mph but i still have to press the gas pedal down hard to maintain speed.

    My questions are: should I get a refund on the Idle Air Control Valve since the check engine light has turned off. and some friends told me it seems like a vacuum leak or the transmission is slipping. What can I do to fix the acceleration?

  2. #2
    long time mazda owner d0sitmatr's Avatar

    2003 Protege5

    Join Date
    Jun 2011
    Location
    Sebring, Florida, United States
    Posts
    213
    Quote Originally Posted by Syd729 View Post
    I bought a 2003 Mazda Protege5 from my friend. When i got it there was a rough idle. The RPMs would flutter between 1000 and 0. I got the codes read at O'Riellys and got Random Misfire, Misfire in cylinder 3 and one i can't remember but it's only offered solution was to replace the Idle Air Control Valve so I ordered the part for 250 bucks. I used Sea Foam in the gas tank, break booster line, and used the Sea Foam Spray as directed. It helped but the RPMs fluttered less frequently but were still there. I replaced the coil packs and spark plugs. The idle stays consistent now and the check engine light has turned off. I noticed after I used the Sea Foam Spray my car isn't accelerating properly. When i took it to drive after leaving it for 15 minutes I had to press really hard on the gas pedal to drive. I can get up to highway speed but it's gradual and i basically have to push the pedal to the floor to reach 60mph. From stop to go is slow. I press the gas and the car doesn't move for at least 2-3 seconds. 0-20 in 20 seconds. The RPMs seem normal after 20mph but i still have to press the gas pedal down hard to maintain speed.

    My questions are: should I get a refund on the Idle Air Control Valve since the check engine light has turned off. and some friends told me it seems like a vacuum leak or the transmission is slipping. What can I do to fix the acceleration?
    you can easily tell if the trans is slipping as the RPM will go sky high even while your barely moving, if you havent noticed that, then I highly doubt its a slipping trans.
    sounds like a massive power loss. I dont know what to tell you there, but Im sure there are some on here who should be able to help.

Similar Threads

  1. Problems accelerating.
    By Syd729 in forum Mazda5 Engine & Transmission
    Replies: 2
    Last Post: 02-28-2018, 10:30 AM
  2. Hesitation on accelerating
    By gino in forum Mazda3 Lounge
    Replies: 10
    Last Post: 09-04-2014, 02:21 PM
  3. Car not Accelerating correcty
    By gerlitzkib6 in forum Mazdaspeed Protege
    Replies: 18
    Last Post: 06-23-2011, 09:52 AM
  4. Noise while accelerating
    By planefreak in forum Protege5
    Replies: 4
    Last Post: 06-18-2011, 05:03 AM
  5. Noise when accelerating
    By Nhz in forum Mazdaspeed Protege
    Replies: 1
    Last Post: 05-08-2011, 10:29 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •