CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: HELP! Loss of Power!!!

  1. #16
    Registered Member

    protege5

    Join Date
    May 2016
    Location
    GA
    Posts
    252
    I hate cats. I used to like them then that wore off... I'll stick with my Pyrenees

    If I had to guess the OEM coils are PROBABLY nippon-Denso. Most jap cars use denso for most of the important electronics... Look closely at the OEM ignition coil. It should say nissin or denso or hitachi or something on there. that's the OEM supplier that makes it. Mazda doesn't make ignition coils they buy them from someone else. When it comes to a lot of things... belts, bearings, motor mounts, etc. I live by the "cheapest I can get" philosophy. It may wear faster but if I can buy 3 or 4 aftermarket motor mounts for the price of 1 OEM one, and they only take 20 minutes to change, no big deal when they tear. However, when it comes to electronics like ignition coils, sensors, and engine controls stuff I will only buy OEM parts. Most jap cars don't play nicely with aftermarket sensors and coils. Lessons learned over the years of working at a dealership. A cheap part can have you chasing your tail with driveability problems especially if you replace a bunch of stuff at the same time.


    Also I would highly recommend some iridium plugs, they just work better in these cars. And personally the only spark plugs I will ever buy are NGK but Denso are good too. The copper plugs (even new) are probably not helping your misfire issue, and will wear out a lot faster.

    And definitely check your timing belt anyways before it leaves you stranded. Most people never look at them because you have to pull the valve cover off to see it. Mine broke for the 2nd time on Tuesday. First time was about 2 years ago; around 190k miles on what i presume to be the original belt. stripped the cogs off around the crank pulley. this time the tensioner spring was completely stretched out, twisted and "sprung". I'd imagine the belt skipped and snapped because of it. I used a Gates belt the first time, lasted 2 years and about 65k miles. Trying a Dayco this time see how that goes.

  2. #17
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    4,180
    Quote Originally Posted by pb4ugotobed View Post
    Also I would highly recommend some iridium plugs, they just work better in these cars. And personally the only spark plugs I will ever buy are NGK but Denso are good too. The copper plugs (even new) are probably not helping your misfire issue, and will wear out a lot faster.
    I'm gonna disagree with that...
    Apparently, the best plugs to use on our car is NGK V-power copper sparkplugs.
    They give the strongest most reliable spark.
    The only drawback is that they do wear out faster and need to be gapped but at a Buck or two a piece you can just replace them.

    The Diagram Dude

  3. #18
    Registered Member

    protege5

    Join Date
    May 2016
    Location
    GA
    Posts
    252
    I can agree copper does give stronger spark, but i've had iridium at 70k miles now and zero issues. They're due to be replaced at this point but i'll get around to it eventually lol. I don't particularly "enjoy" working on my car, i just want to get in it and drive. The less maintenance i have to remember the better!

    pretty much anything NGK you can't go wrong with

  4. #19
    Registered Member

    Mazda Protege5

    Join Date
    Feb 2017
    Location
    Kansas City
    Posts
    6
    I wont get a chance to work on the car until tomorrow it looks like but I will check back in with what I find.. hopefully just getting new ignition coils solves the issue and I can get back to driving and enjoying my protege5

Page 2 of 2 FirstFirst 12

Similar Threads

  1. CAI loss in power
    By YouDontGnomeMe in forum Mazdaspeed Protege
    Replies: 1
    Last Post: 08-29-2012, 04:55 PM
  2. Loss of Power TSB
    By ZoomFive in forum CX-9 Engine & Transmission
    Replies: 16
    Last Post: 10-06-2008, 11:25 PM
  3. CAI power loss
    By coyfish in forum Mazda6 Engine & Transmission
    Replies: 1
    Last Post: 08-10-2008, 09:38 AM
  4. loss of power,y?
    By fasaba in forum Mazda Protege
    Replies: 3
    Last Post: 01-26-2007, 12:07 AM
  5. loss of power
    By Jswillmon in forum Mazda How-To
    Replies: 9
    Last Post: 09-10-2003, 06:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •