CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Results 1 to 9 of 9

Thread: 2008 Mazda3 Automatic, goes max to 3rd gear

  1. #1
    Registered Member


    Join Date
    Sep 2008
    Posts
    7

    Exclamation 2008 Mazda3 Automatic, goes max to 3rd gear

    Three days ago I got engine light, but didn't have time to check. Yesterday, while accelerating rapidly there was a sound and felt it too. It was like something snapped. And then the car started maxing out on the 3rd gear. It was fine otherwise. Just won't go past 3rd. From what I read it sounds like an engine mount, which would be kind of inline with the sound and impact I've heard. Like something snapped.

    Any other ideas? Would a bad engine mount show on engine light, I wouldn't think so... Is it just a coincidence?

    I brought it to the stealership already, but just wanna be ready if they call and sound like I know a thing or two

  2. #2
    Registered Member


    Join Date
    Sep 2008
    Posts
    7
    Holy crap!

    The stealership told me this:

    • Transmission pan is rusty and leaking
    • Oil is only half (though never leaked on the driveway)
    • Traction control system for transmission is defective, computer (code P0841, P0139)
    • Rear oxygen sensor is defective needs replaced


    I kinda don't believe them, as that specific dealership has some bad reviews with overcharging. Will get a second opinion.

    What do you think about "traction control system" though? I have no idea what that is and why it needs replacing... Why would a computer just go "bad"?

  3. #3
    Registered Member concept's Avatar

    2014 Mazda3 S GT auto, 2008 MX5 6-speed

    Join Date
    Mar 2009
    Location
    San Diego
    Posts
    1,499
    Could it be a bad traction control module? What was the dealership quote for all repairs?

    By the way, the next time a check engine light turns on, avoid rapid acceleration until the code s checked and the issue, resolved.
    2014 3S GT, Deep Crystal Blue, Eibach Pro-Kit, Enkei PF01s, Koni Sports, Pirelli P ZERO ALL SEASON PLUS tires, 225/45/18
    2008 MX-5 Touring (Mazdaspeed CAI, HIDs, Progress/Koni Sports/Racing Beat sways, SST Magnaflow muffler and tips)

  4. #4
    Registered Member


    Join Date
    Sep 2008
    Posts
    7
    Yep, from further research and corroborating symptoms it's the TCM. Stealership wants CAD$883+tax for that. Obviously I am not paying that. Found someone on classifieds selling rebuilt TCMs with 1y warranty with install for CAD$400. I know I can order on eBay for $300 and do the install myself, but then I need to wait a few days to get it here and spend time figuring it out. Better just pay someone local and the warranty is nice.

    Oxygen sensor seems unimportant at the moment, and could be false alarm anyways.

    Checked the tranny oil, it is indeed pretty dirty. Don't even remember when I replaced it last time, but it was a while ago. But it's definitely not low, if anything it was even a bit high (above second notch). So the stealership lied.

    As for the pan, I didn't check it as I don't have a stand.

  5. #5
    Registered Member Ilikebikes's Avatar

    06 Mazda 3 Hatchback GT

    Join Date
    Jul 2015
    Location
    Northern California
    Posts
    164
    Did you look up the instructions on how to check it? Is it supposed to be checked cold or warm, run it through all gears etc? Depending on the instructions before you check it, your fluid could read high or low.
    Last edited by Ilikebikes; 08-18-2017 at 06:49 PM.

  6. #6
    Registered Member


    Join Date
    Sep 2008
    Posts
    7
    Quote Originally Posted by Ilikebikes View Post
    Did you look up the instructions on how to check it? Is it supposed to be checked cold or warm, run it through all gears etc? Depending on the instructions before you check it, your fluid could read high or low.
    Good point! Didn't think of that.

    I'll be changing the oil regardless as it is pretty dirty. It's almost black!

  7. #7
    Registered Member concept's Avatar

    2014 Mazda3 S GT auto, 2008 MX5 6-speed

    Join Date
    Mar 2009
    Location
    San Diego
    Posts
    1,499
    The trans fluid should be translucent red. Change it, ASAP!
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #8
    Registered Member


    Join Date
    Sep 2008
    Posts
    7
    Changed it today!

  9. #9
    Registered Member

    Mazda 3

    Join Date
    Dec 2018
    Location
    Colorado
    Posts
    1
    Did you ever get it resolved?
    Iím having very similar issues with my 2010 Mazda 3

Similar Threads

  1. Replies: 5
    Last Post: 01-02-2013, 11:14 PM
  2. automatic gearbox shutter when going to 4th gear
    By NoLogic in forum Mazda6 Engine & Transmission
    Replies: 0
    Last Post: 01-04-2012, 03:44 AM
  3. Replies: 11
    Last Post: 09-07-2009, 05:51 PM
  4. automatic gear box console light
    By sp535 in forum CX-9 Lounge
    Replies: 13
    Last Post: 02-18-2008, 04:18 AM
  5. Mazda automatic with manual gear
    By tml in forum Mazda Protege
    Replies: 4
    Last Post: 09-23-2004, 04:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •