Your Best Source for Genuine Mazda Parts!
Your Best Source for Genuine Mazda Parts!
Results 1 to 14 of 14

Thread: Latest Infotainment System Update

  1. #1
    Registered Member

    Mazda CX-5 Grand Touring FWD

    Join Date
    Aug 2014
    Location
    California
    Posts
    8

    Latest Infotainment System Update

    Hey Guys!

    I drive a 2016 Mazda CX-9 GT. I love everything about the car, but there was one issue that was making me nuts, which was the constant infotainment reboots. I was averaging 2 to 3 reboots a week at very inopportune times. Definitely annoying! The version prior to the update was:

    OS Version 59.00.441 NA N
    Music Database Version 00.70.000
    Fail-Safe Version is 59.00.441

    When I last brought my car into Mazda for service I asked them to update the system to the latest version:

    OS Version 59.00.502 NA N
    Music Database Version 00.70.000
    Fail-Safe Version is 59.00.502

    I have been driving the car for at least 3 weeks and I haven't had a single reboot. I'm confident had I not updated, my system would've rebooted 6 times minimum by now.

    So in conclusion, if your infotainment system is compatible with this version (502) I would highly recommend updating if you also have been dealing with constant reboots. This latest version definitely seems to be the most stable.

    Good luck!

  2. #2
    Registered Member

    2017 Mazda CX-9 GT

    Join Date
    Aug 2017
    Location
    Boston, MA
    Posts
    50
    I also got the latest update - only because after my 5K service, my backup camera stopped working. I restarted multiple times to no avail. I drove back to the dealer and the tech suggested I upgrade the version. All is fine now, tech says it fixed bugs, enhanced stability and boots faster (not sure if I agree with the latter)...

  3. #3
    Registered Member

    Mazda CX-5 Grand Touring FWD

    Join Date
    Aug 2014
    Location
    California
    Posts
    8
    Just a quick update! It's been a month and a half since installing to the latest version. In that time I've experienced zero reboots!

    Quite pleased.

  4. #4
    Registered Member

    2017 CX-9 Signature

    Join Date
    Feb 2015
    Location
    Canada
    Posts
    338
    Quote Originally Posted by stu788 View Post
    Just a quick update! It's been a month and a half since installing to the latest version. In that time I've experienced zero reboots!

    Quite pleased.
    Good to know...thanks for the update!

  5. #5
    Registered Member

    2017 CX-9 GT AWD

    Join Date
    Apr 2016
    Location
    Syracuse, NY
    Posts
    20
    I just updated mine myself yesterday from 441 to 502 due to a few issues/quirks and reboot issues. It does seem a bit quicker to boot up and all of the prior issues seem to be gone but a new issue arose: blind spot monitoring is no longer working. I tried resetting individual settings, default all settings, and rebooted several times with no change. Anyone else having this issue and know if a fix? I've only had the car a week so I would hate to have to schedule service already.

  6. #6
    Registered Member

    2017 CX-9 GT AWD

    Join Date
    Apr 2016
    Location
    Syracuse, NY
    Posts
    20
    Quote Originally Posted by greggmischenko View Post
    I just updated mine myself yesterday from 441 to 502 due to a few issues/quirks and reboot issues. It does seem a bit quicker to boot up and all of the prior issues seem to be gone but a new issue arose: blind spot monitoring is no longer working. I tried resetting individual settings, default all settings, and rebooted several times with no change. Anyone else having this issue and know if a fix? I've only had the car a week so I would hate to have to schedule service already.
    Update: blind spot monitoring is working, but it works differently now. It only alerts me (lights up) if someone is approaching from behind and moves into my blind spot. It no longer lights up if I pass a vehicle and then it moves into my blind spot.

  7. #7
    Registered Member

    2016 CX-9 Touring

    Join Date
    Feb 2008
    Location
    Spring, TX
    Posts
    52
    Quote Originally Posted by greggmischenko View Post
    Update: blind spot monitoring is working, but it works differently now. It only alerts me (lights up) if someone is approaching from behind and moves into my blind spot. It no longer lights up if I pass a vehicle and then it moves into my blind spot.
    Isn't that always how it worked? When I was taking a test drive, the salesman told me it lit up only when someone was approaching from behind.

  8. #8
    Registered Member

    2017 CX-9 GT Soul Red

    Join Date
    Mar 2013
    Location
    Fort Wayne, IN
    Posts
    127
    Isn't that always how it worked? When I was taking a test drive, the salesman told me it lit up only when someone was approaching from behind.
    That's how the new Advanced BSM works. It detects vehicles coming from behind on both sides, and will only indicate vehicles you are passing if the speed difference is only a couple MPH between the 2 vehicles. Takes some getting used to... I prefer the old method myself.

  9. #9
    Registered Member

    2017 Mazda CX-9 GT

    Join Date
    Aug 2017
    Location
    Boston, MA
    Posts
    50
    Yes, that how it's supposed to work. A bit weird...

  10. #10
    Registered Member

    2017 CX-9 GT AWD

    Join Date
    Apr 2016
    Location
    Syracuse, NY
    Posts
    20
    Another glitch that was present in 441 that I thought was gone with 502 but it happened for the first time today after having upgraded last week: sometimes when disabling/turning off traction control (using TCS swtich) it actually turns off the Lane-Keep Assist (LAS). When I press the TCS button again the LAS is reactivated.

  11. #11
    Registered Member

    2018 CX-9 SIGNATURE

    Join Date
    Sep 2017
    Location
    TN
    Posts
    71
    Quote Originally Posted by Bob2525 View Post
    That's how the new Advanced BSM works. It detects vehicles coming from behind on both sides, and will only indicate vehicles you are passing if the speed difference is only a couple MPH between the 2 vehicles. Takes some getting used to... I prefer the old method myself.
    I'm with you. I like to know when something is in the blind spot at all times.

  12. #12
    Registered Member


    Join Date
    Feb 2011
    Location
    FL
    Posts
    85
    Can some one confirm that in the newest version they brought back or not the tachometer setting for HUD?

  13. #13
    Registered Member Srad600's Avatar

    2016 CX-5AWD GT+Tech/ 2018 CX-9AWD GT

    Join Date
    Jun 2015
    Location
    Chino hills, California
    Posts
    473
    Version ...502 does not have the tachometer shown in the HUD. At least I haven't seen that setting available.

  14. #14
    Registered Member

    2016 CX-9 Grand Touring AWD

    Join Date
    Jan 2018
    Location
    Ohio
    Posts
    1
    Quote Originally Posted by jbedoya View Post
    Can some one confirm that in the newest version they brought back or not the tachometer setting for HUD?

    I don't think they will bring back the tachometer as Mazda considers in a distraction and safety issue. Look at the release notes at the bottom of this post.

    The HUD is tied in with the seat memory. So, if you saved a seat position prior to the CMU upgrade with the tachometer feature enabled, the tachometer should reappear on the HUD (but not within the menus) when you select that seat position. I know because this happened to me when I selected a seat position after the CMU upgrade. I couldn't get the tachometer to go away because both seat positions had it enabled and there was no options in the menu. The dealership was completely clueless, but someone in this forum told me it was tied to the seat memory. Unplugging my battery for a few minutes cleared the seat memory which removed the tachometer from the HUD. So try both of your key fobs and seat memory settings.

    Firmware CHANGELOG for NA_59.00.441A

    • DTC U0100:00 [CONNECTIVITY MASTER UNIT] (communication error with PCM) is stored in memory.
    • Warning guidance's are displayed both for LDWS and HBC (CX-3 with LDWS and without HBC only).
    • Improper OFF selection in the Setting Interval menu under Oil Change (TC CX-9 only).
    • Resetting with “Fixed” data will not reset “Flexible” data. (TC CX-9 only).
    • Tachometer function has been removed from the Active Driving Display (TC CX-9).*
    • Navigation or other screens freeze or reboot.
    • Issues with Pandora Radio.
    • USB device fails to start playing, resume or display music information.
    • BT audio device fails when starting to play, resume or connect.
    • Paired BT device will not connect. Removing the paired BT device from the vehicle (but not the vehicle from the phone) results in an endless “Deleting” message.

    *To improve safety and reduce driver distraction.

Similar Threads

  1. Replies: 94
    Last Post: 12-30-2017, 01:09 PM
  2. Replies: 3
    Last Post: 05-30-2017, 08:18 AM
  3. Latest Infotainment - Where is the XM Category View?
    By KevinCX5 in forum CX-5 Infotainment
    Replies: 0
    Last Post: 01-18-2016, 08:02 PM
  4. Infotainment update
    By ozymandius100 in forum CX-5 Infotainment
    Replies: 36
    Last Post: 03-30-2015, 01:28 PM
  5. Latest TomTom NB1 Update (European Map update)
    By Mountkeen in forum CX-5 Infotainment
    Replies: 0
    Last Post: 03-20-2015, 08:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •