Compare auto reliability with reliable results at TrueDelta.com!

Compare auto reliability with reliable results at TrueDelta.com!
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: No air coming out of vents.

  1. #1
    Registered Member

    Mazda Protege5

    Join Date
    Sep 2016
    Location
    CA
    Posts
    74

    No air coming out of vents.

    Have a trip soon and I don't have any circulation of air coming out my dash. I changed the ac fuse just in case. I do remember it blowing at one point I believe when my radiator was flushed. I recharged the freon a while back and the piping was cold but again no wind whatsoever. Any way to diagnose maybe get the ball rolling?

  2. #2
    Registered Member NaturalFlavored's Avatar

    Mazda P5

    Join Date
    Feb 2015
    Location
    Tucson
    Posts
    374
    Yeah, is it hooked up under the dash? Make sure it's clipped down too or else it won't have enough tension to turn the core knobs.
    There is two of them. One for ac and one for the heater. Make sure they are hooked up and clipped down.
    One is under the dash above the pedals the other is kind of behind the glove box(more so behind the CD player).

  3. #3
    Registered Member

    Mazda Protege5

    Join Date
    Sep 2016
    Location
    CA
    Posts
    74
    the metal wire on the metal clips that move when you turn the knobs? Those are still there surprisingly.

  4. #4
    Registered Member

    Mazda, Protege5

    Join Date
    Dec 2016
    Location
    Brooklyn
    Posts
    18
    Quote Originally Posted by stormkyori View Post
    the metal wire on the metal clips that move when you turn the knobs? Those are still there surprisingly.
    for a temp fix try moving the plastic air diverter thingies with your hand while gently pulling the wires... they can get sticky/stuck

  5. #5
    ......................... i12drivemyMP5's Avatar
    Donated: $5

    323F

    Join Date
    Apr 2005
    Location
    <---------------->
    Posts
    7,378
    Quote Originally Posted by stormkyori View Post
    the metal wire on the metal clips that move when you turn the knobs? Those are still there surprisingly.
    The metal clips should not be on the metal wire. They are usually a 1/2 inch or so up on the black housing the wires are in. If they have been messed with before make sure they aren't slackin out on ya and not moving like they should be. Also IIRC, one of them moves the diverter from fresh to recirculate and the other one moves between vent/def/floor and combo settings. There is a sweet spot for travel when clipping the wires into place.
    Last edited by i12drivemyMP5; 06-13-2017 at 03:49 PM.

  6. #6
    Registered Member

    Mazda Protege5

    Join Date
    Sep 2016
    Location
    CA
    Posts
    74
    So I had someone look it over and he said I have pinhole leaks on the high pressure hose. I've tried to look online and found nothing on rockauto sadly the cheapest was dealer. Any suggestions and is this something I can do myself or should I pay to get this done?

  7. #7
    ......................... i12drivemyMP5's Avatar
    Donated: $5

    323F

    Join Date
    Apr 2005
    Location
    <---------------->
    Posts
    7,378
    I can see compressor not running if low on refrigerant but that should not stop air from blowing from vents or defrost or floor when the fan switch is in any position other than off. You said you added refrigerant and piping was cold and that indicates to me that the compressor was running to get any piping cold. The wind not blowing is separate issue from the pin hole on hi side. The other issue in this area would be the fan speed resistor thing............

    https://www.mazdas247.com/forum/show...3-quot-problem

  8. #8
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    Or his fan switch and connector are completely fried.



    Last edited by pcb; 06-21-2017 at 12:01 PM.

  9. #9
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    Quote Originally Posted by stormkyori View Post
    Have a trip soon and I don't have any circulation of air coming out my dash...
    Are you saying you've got air blowing on your feet and the windshield just not from the dash toward you ?
    Or do you have no wind at all like it's turned off ??

  10. #10
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    They do have this stuff which can seal a small leak..


  11. #11
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    Quote Originally Posted by i12drivemyMP5 View Post
    ... The other issue in this area would be the fan speed resistor thing............
    Usually a burned out resistor still allows fan speed 4..
    The resistor is for fan speeds 1,2 & 3 and is bypassed for fan speed 4.

    But all the speeds and power need to get through our flimsy melty burned up fanswitch.

    It's not too hard to check the connector at the back of the fan switch... The resistor is easy to replace too, and a bunch of guys ran into that problem.
    (But it seems like every one of us has run into the flicking AC light thing)

  12. #12
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    This,.. By the way, is the most effective and reliable fix.

    It's redneck approved.


  13. #13
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    3,138
    You may have a bad blower relay...

    For you to have no wind at all at any fan speed or flickering of the AC light, suggests that relay...

    You could test to see if power is getting through the relay... See if you here it clicking...
    (I don't know if it would click with the ignition or turning the fan on... probably ignition)



    Last edited by pcb; 06-21-2017 at 01:05 PM.

  14. #14
    Registered Member

    Mazda Protege5

    Join Date
    Sep 2016
    Location
    CA
    Posts
    74
    Quote Originally Posted by pcb View Post
    Are you saying you've got air blowing on your feet and the windshield just not from the dash toward you ?
    Or do you have no wind at all like it's turned off ??
    No air whatsoever with the switch turned. Only ambient air coming in from outside.

  15. #15
    Registered Member

    Mazda Protege5

    Join Date
    Sep 2016
    Location
    CA
    Posts
    74
    Quote Originally Posted by pcb View Post
    Usually a burned out resistor still allows fan speed 4..
    The resistor is for fan speeds 1,2 & 3 and is bypassed for fan speed 4.

    But all the speeds and power need to get through our flimsy melty burned up fanswitch.

    It's not too hard to check the connector at the back of the fan switch... The resistor is easy to replace too, and a bunch of guys ran into that problem.
    (But it seems like every one of us has run into the flicking AC light thing)
    I've never seen it flicker before but have heard of that problem on here.

Page 1 of 2 12 LastLast

Similar Threads

  1. Dusty smell coming from vents?
    By buyingconstant7 in forum CX-5 Lounge
    Replies: 3
    Last Post: 03-08-2016, 02:58 PM
  2. Smoke coming out of my vents, burnt up fan?
    By Finaldo in forum Protege5
    Replies: 7
    Last Post: 11-24-2009, 06:53 PM
  3. Smoke/exhaust coming through vents/hood from CP-E downpipe at idle
    By steefnap in forum Mazda6 Engine & Transmission
    Replies: 27
    Last Post: 08-23-2007, 03:59 PM
  4. Strange smell coming through vents?!?!!?
    By zzMSP03.5 in forum MSP Performance
    Replies: 6
    Last Post: 08-25-2005, 07:50 PM
  5. smoke coming from a/c vents!!!!!!!
    By MP3Architect in forum Mazda How-To
    Replies: 19
    Last Post: 06-10-2005, 02:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •