I have a 2014 Mazda3 i Sport. I mounted an external cooler, as I didn't like my transmission fluid running at engine coolant temperatures. I bought it certified pre-owned with 27,000 miles. Even at this young age the fluid was becoming burned and also smelled that way. It shifts great and I have had no problems and a=only thing I could do was remove the heat situation.

So. I bought a Scanguage 2 and finally found a code that works...except it reads in degrees C. I found it on a random post and the code was taken from an Australian Ford/Mazda site. I alsi found another set of codes for the same function,except one read in degrees C and the other in degrees F. The only difference was in the MTH portion of the code. However, it was so different there was no way to start making changes to see the result. I am posting the C code to see if anyone recognizes it and just maybe has the F string for MTH. I went ahead and made a cheat sheet just to know where my temps are, so it is still nice to know. Here is code: TXD = 07E1221E1C
RXF = 0462451E061C
RXD = 3010
MTH = 003F000A0000 This is the culprit

Now, my transmission temps are down to the 155 to 170 range in 90 degree ambient conditions. To me, a lot better than 200 minimum to 230. Ideal is 175. Any higher and things slowly start changing for the worse..from what O have read by technicians with nothing to gain from the comment.

Thank you for looking at my situation and I hope there is someone who just might have a clue to change this code. I am hoping the folks I contacted at Scanguage will help as well.