VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Page 1 of 5 123 ... LastLast
Results 1 to 15 of 66

Thread: Engine Harness and Starter Issues

  1. #1
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47

    Engine Harness and Starter Issues

    Hit at wall in my journey to bringing a 2002 Automatic Protege5 from the dead. Mentioned it in another post about it being the Side Airbags and ABS package.

    So my mechanic and I swapped the engine today, but ran into some wiring issues. Car had a burned engine and starter harness when it threw rod. Using a replacement harnesses from an 03 tiptronic.

    We are having electrical issues starting the car. Car does not crank from what we believe are the incompatible connectors by the dash (2) and the shifter.

    Mechanic power probed the starter wires using wiring diagram and did some bypassing and found that starter is getting power but no signal. He bypassed it using the fuse box but engine still doesn't crank.

    What opinion do you guys have? Do you guys think it's from the difference in harnesses or another electrical issues. Any insight or advice is greatly appreciated.






    Sent from my iPhone using Tapatalk
    Last edited by naguilar; 04-27-2017 at 05:38 PM.

  2. #2
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    This is all I've got for you...



    It mentions twice "except sport AT" but doesn't show how the sport AT is wired ???

    If you feed 12 V directly to the B/Y terminal of your starter motor connector and it doesn't crank then there is something wrong with your starter motor.

  3. #3
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    Picture was blurry...


  4. #4
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47

    Engine Harness and Starter Issues

    Starter is new. It doesn't start the engine. The mechanic did not put in the accessory belts. We have some water to remove from the combustion chamber.


    Sent from my iPhone using Tapatalk

  5. #5
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    So it cranks but won't start ??

  6. #6
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47

    Engine Harness and Starter Issues

    Yes. Just cranks and cranks. Could it be the crankshaft sensor? Saw that issue in another forum. Left the old one on the used block.

    We also heard a "pop" at the injectors and left it at that.


    Sent from my iPhone using Tapatalk
    Last edited by naguilar; 04-27-2017 at 05:32 PM.

  7. #7
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    Yea.. That's possible... If you have no crank signal then your ECU won't allow the car to run.

    But the "Sport AT" is weird and wired different and your ECU maybe shutting you down for some unknown reason ???

    I'd try to get the proper harness first.

    Here's the list of "crank no start" possibilities...


  8. #8
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47
    Getting the appropriate harness may be a maze of its own. None of the junk yards in my area have an ABS Protege. The only place I found in the whole country was Michigan.


    Sent from my iPhone using Tapatalk

  9. #9
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47
    I appreciate that information pcb! I will look at the service manual.


    Sent from my iPhone using Tapatalk

  10. #10
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    You can test your crank sensor....


  11. #11
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47
    I will have to ask someone with more electrical knowledge. This endeavor has sure taken an unexpected turn.


    Sent from my iPhone using Tapatalk

  12. #12
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    2,935
    You probably need somebody with specific Protégé knowledge... As far as the harness goes.
    I'm just going by the wiring diagrams I have and they're missing a bunch of pages.

  13. #13
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47
    I'm going to give it one more try. It's been exhausting finding someone to trust with this work. You know?

    I looked at the wiring diagrams. I hope other systems are not damaged for the starter bypass.

    If things don't work out I am moving on...


    Sent from my iPhone using Tapatalk

  14. #14
    Certified Mazda Tech hornsfan10609's Avatar

    2003.5 Mazdaspeed Protege x2

    Join Date
    Jun 2009
    Location
    Austin, Tx
    Posts
    7,894
    There is some info about the tiptronic harness in the manual-swap thread. I don't know much about the auto models, but pcb is right, you will probably need a regular auto engine harness. Unless you want to swap a tiptronic trans and ECU in the car.
    Mod List. "Jinba Ittai"

    2003.5 Titanium Mazdaspeed Protege #1345 Purchased 7/20/10
    2003.5 Titanium Mazdaspeed Protege #1574 Purchased 10/25/14

    2009 Highland Green Mustang Bullitt #5998 12.9@110
    2002 Red Protege5 RIP:4/25/10

  15. #15
    Registered Member naguilar's Avatar

    2003 Sunlight Silver Mazda Protegé5

    Join Date
    Oct 2016
    Location
    NC
    Posts
    47
    I saw in the thread that the trans has to be disassembled to add the speedo gear. I would rather use the right harness to avoid any CELs.

    I'm hoping it's just that...and not any type of engine/electrical issue.


    Sent from my iPhone using Tapatalk

Page 1 of 5 123 ... LastLast

Similar Threads

  1. Replies: 7
    Last Post: 08-23-2016, 11:53 AM
  2. Difference between engine harness and emission harness?
    By marshallj25 in forum Mazda Protege
    Replies: 0
    Last Post: 04-04-2015, 04:52 PM
  3. Engine and starter issues
    By JelloMan in forum Mazda6 Engine & Transmission
    Replies: 0
    Last Post: 12-06-2009, 05:02 PM
  4. Alternator Harness issues
    By Lil Freek in forum Mazda Protege
    Replies: 33
    Last Post: 05-20-2008, 08:20 AM
  5. Cold Air Intake ABS Harness Issues!!!
    By crossbow in forum Mazda6 Engine & Transmission
    Replies: 4
    Last Post: 12-03-2004, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •