Your Best Source for Genuine Mazda Parts!
Your Best Source for Genuine Mazda Parts!
Results 1 to 2 of 2

Thread: No Instrument cluster diagnostic lights

  1. #1
    Registered Member

    2003 Mazda 6 3.0L V6

    Join Date
    Apr 2017
    Location
    Ohio, USA
    Posts
    2

    No Instrument cluster diagnostic lights

    When I turn the key to start the car I don't get any of the diagnostic lights.
    I didn't realize it until after I bought the car.
    Everything seems to run alright. I checked all the fuses under the steering wheel and under the hood, nothing blown there...

    Sent from my SM-G930P using Tapatalk

  2. #2
    Registered Member

    2004 Mazda 6 Sport Wagon

    Join Date
    Dec 2017
    Location
    Green Bay, Wisconsin
    Posts
    1
    This is an old yes, I get it, bit I had this problem when I bought mine. Turned out that the previous owner put a piece of electrical tape behind the cluster, blocking. The LED's from showing.
    There is a little red dot under your tachometer, which should be the seat belt light, which makes me think that you have the same problem I did.

    I ended up pulling the gauge cluster out (not hard, disconnect the rubber piece in the top rear of the steering colum, 2 Phillips screws in the plastic trim piece surrounding it, 4 screws holding the cluster in, and disconnect the wire harness)

    Once removed, take the cluster apart (I'm sure there are instructions on this forum, or Google).

    Check to see if there is anything behold the gauges.

    When I removed the tape, I had all the lights back (engine, battery, oil pressure, seat belt).

Similar Threads

  1. Instrument Cluster lights
    By Jo-E in forum Mazda How-To
    Replies: 11
    Last Post: 03-08-2015, 09:26 AM
  2. Replies: 2
    Last Post: 11-19-2013, 11:34 PM
  3. Instrument Cluster Lights Flickering
    By JASK0 in forum Mazda3 Lounge
    Replies: 2
    Last Post: 05-07-2010, 12:51 PM
  4. Instrument Cluster Missing Lights
    By thepeel in forum Protege5
    Replies: 17
    Last Post: 04-04-2008, 12:26 AM
  5. Red Instrument Cluster
    By PRO 5 in forum Mazda Protege
    Replies: 0
    Last Post: 08-26-2002, 07:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •