Your Best Source for Genuine Mazda Parts!
Your Best Source for Genuine Mazda Parts!
Results 1 to 11 of 11

Thread: Ridiculously slow, barely functional infotainment system.

  1. #1
    Registered Member

    2009 Mazdaspeed3

    Join Date
    Jun 2016
    Location
    Colorado
    Posts
    3

    Ridiculously slow, barely functional infotainment system.

    Looks like I've opened Pandoras box now with my 2016 CX-5. I've had mine since May 2016, and overall I've been very happy. Only a few minor complaints. The biggest issue has been the very sluggish performance of the infotainment and everything it includes - navigation, settings, etc. I really only use the navigation and the radio, I haven't done any loading libraries or contacts or using my phone with bluetooth.

    The whole system has always been annoyingly slow, but I've just kind of tolerated it. It is on the sophistication level of a Texas Instruments calculator from 1983, or any primitive 1980's computer. Like, no processing power. Upon starting the car, it takes 30 seconds or more for the infotainment screen to become responsive, and my most common task is to immediately turn on the radio and switch to my Favorites. This takes forever. Extremely tedious.

    But in the winter, with subfreezing temps, I have now discovered - it's WORSE. These issues are now compounded terribly. The system takes minutes to respond to anything, and it keeps restarting itself and requiring me to hit that annoying big red "Accept" button about using the system safely. Over and over. I finally get to radio favorites, then it reboots again. And again. It's nearly nonfunctional. This is a disgrace! I'm driving in my car and can't even operate the radio, or the navigation. This is in the realm of inexcusable and incompetent. Can't work the RADIO. My god.

    So I guess I can rant all I want, but what I really want to know is this system upgradable? Repairable? Is there any resolution to this? Thoughts or anyone else experience this? I have found some other websites with people complaining, so it's not just my car. Cheers-

  2. #2
    Registered Member

    16 CX-5 GT AWD w/ Tech

    Join Date
    Feb 2015
    Location
    Baltimore, Maryland
    Posts
    740
    What software version are you running? First, make sure that is updated to the latest. Then reassess. After that if it continues and if you can replicate the issue with the dealer, I bet they'll replace your whole unit.

    Mine system is overall pretty good. Load times when starting up, can be a little slow, especially navigation. Once it's up an running everything is quick. But try those things I mentioned above.

  3. #3
    Registered Member

    CX-5 Touring 2016.5

    Join Date
    Aug 2016
    Location
    Lewisville North Dallas Suburb
    Posts
    616
    Loads under 15 secs, if i am backing out camera comes on fast. Plays ipod and phone Bluetooth, maps are non glitchy. Has restarted 2 times in 5k miles.

  4. #4
    Registered Member

    2016.5 CX-5 GT

    Join Date
    Sep 2016
    Location
    NJ
    Posts
    134
    You don't need to press the accept button every time, it goes away if you do nothing. My system has been very stable, it is sensitive and gets confused though if you press any buttons while it's loading so I do make sure I don't press any buttons for like the first 15 seconds also I ignore the warning screen. I just let it load until I hear radio. I don't press any of the command buttons by the shifter or try to use phone dial until I'm sure the system is running usually takes 10 seconds.

    15 seconds if I shut down the car last with Pandora radio as the last music source because the car needs to link to my phone and my phone needs to open the Pandora app and stream the content via Bluetooth.

    Also, very important. I turned off email and text syncing, I have no use to read emails or texts while I'm driving. That slows down the system a lot and takes up a lot of the infotainment internal memory. It also has a lot do with how fast or how good your phone is in transferring the data to the car.

    I do sync my contacts from my phone and I can see the percentage downloading each time but the data download is not bad because phone contacts is not much data. But emails and text will really bog down the system, try unchecking download emails and text from the communications screen. I've also read from online that texts with emojis or symbols will also mess up the system and cause reboots. I guess the system gets confused and has no idea what the special characters are and probably Mazda's supplier for the infotainment I believe is Johnson Controls never tested the downloading of emojis.
    Last edited by blackcx5; 01-07-2017 at 07:37 AM.

  5. #5
    Registered Member

    Mazda 2016 CX-5

    Join Date
    Nov 2015
    Location
    Charlotte, nc
    Posts
    270
    Its working pretty well now in my 2016 CX-5 GT. Even Pandoras working now (for some odd reason it started working after Apple replaced the battery recently as part of a recall, Iphone 6S). I always switch back to fm before shutting down, seems to make system startup quicker.

  6. #6
    Registered Member

    2016.5 CX-5 GT

    Join Date
    Sep 2016
    Location
    NJ
    Posts
    134
    Quote Originally Posted by Tccox View Post
    ..... I always switch back to fm before shutting down, seems to make system startup quicker.
    Agreed, whenever I have Pandora or Navigation or USB mode as the last shut down screen, it does take longer to boot up, I try to have it on FM radio also as last music source prior to shut down.

  7. #7
    Registered Member

    2009 Mazdaspeed3

    Join Date
    Jun 2016
    Location
    Colorado
    Posts
    3
    Ok thanks for the replies. How do I check the software version? I took ownership May 2016, so gosh I would assume it is the latest version. Definitely taking it into the shop. Would be great if they replaced it.

    I don't even use syncing, Pandora, anything like that. Just saved radio stations and navigation. Very slow overall, but in very cold weather, intolerable, almost nonfunctional as I mentioned. Keeps rebooting, etc. Sluggish. Sounds like it's generally a slow computer but seems to be tolerable for you folks. I have tolerated it for 6 months but I need to see if anything can be done.

  8. #8
    Registered Member

    2016 CX5 Touring AWD

    Join Date
    May 2015
    Location
    Delaware
    Posts
    236
    Quote Originally Posted by Seeeker View Post
    Ok thanks for the replies. How do I check the software version? I took ownership May 2016, so gosh I would assume it is the latest version. Definitely taking it into the shop. Would be great if they replaced it.

    I don't even use syncing, Pandora, anything like that. Just saved radio stations and navigation. Very slow overall, but in very cold weather, intolerable, almost nonfunctional as I mentioned. Keeps rebooting, etc. Sluggish. Sounds like it's generally a slow computer but seems to be tolerable for you folks. I have tolerated it for 6 months but I need to see if anything can be done.
    don't asume anything. Go into system, it's either in the vehicle or the music menu. I think it's the last selection on one of those menus, it will display the current software version. There's not that many selections on each menu so if you have to keep drilling down you will eventually find it.

    Mine is pretty responsive except for the initial bootup that takes about 15 sec. It was annoying at first but I've gotten used to it.

  9. #9
    Registered Member

    2009 Mazdaspeed3

    Join Date
    Jun 2016
    Location
    Colorado
    Posts
    3
    Quote Originally Posted by wlong01 View Post
    Mine is pretty responsive except for the initial bootup that takes about 15 sec. It was annoying at first but I've gotten used to it.
    Any experience with cold weather?

  10. #10
    Registered Member

    2016.5 CX-5 GT AWD

    Join Date
    Jul 2016
    Location
    Atlanta, GA
    Posts
    68
    Current version in North America is v59. v55 and v56 have been reported by others anecdotally to be the most stable, as there have been Bluetooth issues on v59 for some users. Anything lower than v55, you should probably get the dealer to upgrade, however make note that they'll likely get you up to v59. There are instructions on other forums and YouTube for how to flash the firmware yourself, but it's ill-advised to do so as if something goes wrong, it likely won't be covered under warranty to fix.

    All of that being said, try doing a reboot of the system. There's a button combination that you'll have to look up, but it reboots the infotainment system on a deeper level than when shutting the car down alone. If that doesn't work, you can try completely resetting the system and returning it to stock, there's an option to do that in the menu. It will erase your data/contacts/favorite stations though.

    I'm on v55 (Got mine from the dealer at the beginning of December that way) and I've had none of the issues you're describing.

  11. #11
    Registered Member

    2016.5 Mazda CX-5 Grand Touring

    Join Date
    Dec 2016
    Location
    Redmond, WA
    Posts
    21
    I've been using the Mazda Connect with both an iPhone 6s Plus iOS 10.2 and an android phone (Galaxy Note Edge), and I find that the infotainment system is very buggy when using the iPhone, with Pandora, aHa, and stitcher being very unreliable and when it does work, it disconnects usually after 10-15 minutes and is only able to reconnect by putting the iPhone into and out of airplane mode. When I use my android phone, it works perfectly, all functions, all features, and never disconnects. I have v55 in my radio. I'm thinking mine might be related to my iPhone, since I have difficulty using the iPhone with my Prius Entune suite, yet, my android phone works perfect in that car too. As for boot up time, I seem to average about 15-20 seconds or so with the Mazda Connect system, which is a little slower than my Prius Entune system, but once the Mazda Connect system is up and running, it seems to work fine (aside from my iPhone issues)

Similar Threads

  1. Infotainment System Bugs
    By PJSkittles in forum Mazda3 Audio
    Replies: 449
    Last Post: 09-14-2016, 05:21 PM
  2. Infotainment system reset
    By beb08 in forum CX-5 Lounge
    Replies: 7
    Last Post: 01-08-2016, 07:29 PM
  3. CX-5 Infotainment System is Garbage
    By ed_carroll in forum CX-5 Audio
    Replies: 22
    Last Post: 09-26-2014, 02:04 PM
  4. Infotainment system blows!
    By joe427 in forum CX-5 Audio
    Replies: 9
    Last Post: 08-12-2014, 12:56 PM
  5. Infotainment System
    By taylorwmj in forum Mazda3 Audio
    Replies: 8
    Last Post: 10-16-2013, 08:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •