Your Best Source for Genuine Mazda Parts!
Your Best Source for Genuine Mazda Parts!
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 35

Thread: Cargo Light not working

  1. #16
    Registered Member

    Silver CX5

    Join Date
    Jun 2016
    Location
    USA
    Posts
    67
    Have you tried a different bulb? Is there voltage at all at the contacts?

  2. #17
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9
    I damaged my RBCM in the process of installation of additional LEDs. I didn't unplug the battery... and the mosfet Q15 was burned. There are two variants of such MOSFETs: SOT23-6 (replacement ZXMN6A08E6) and SC-62(replacement 2sk3065).

  3. #18
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,686
    Blog Entries
    8
    Quote Originally Posted by Silv3rCX5 View Post
    Have you tried a different bulb? Is there voltage at all at the contacts?
    Yeah stock and tested good incandescent bulb doesn't work either. I didn't test voltages further at that time as wife needed to use car. If vehicle wasn't under warranty I would dig into it deeper. I'll update thread on repairs. If this wasn't under warranty I would probably just tap into the 12V plug in the rear and use as a manual light. No other function of the RBCM was affected.
    '15 CX-5 GT 2.5L w/tech package & i-ACTIV AWD - Liquid Silver Metallic (04/2014 build-07/2014 delivery) - 33K Miles

    ==================
    NB1 Navigation Updates (980 NEW-11/2016) / Why Mazda moly oil? - Mazda TSBs / My Misc add-ons / Mazda owners manuals / SkyActiv Oil Analysis Thread

  4. #19
    Registered Member tibimakai's Avatar

    2014 Mazda CX-5 Touring

    Join Date
    May 2013
    Location
    Los Angeles-San Dimas, USA
    Posts
    2,074
    Did you mange to replace the mosfet?

  5. #20
    Registered Member yrwei52's Avatar
    Donated: $8

    2016 Mazda CX-5 GT AWD w/Tech

    Join Date
    Mar 2015
    Location
    Plano, Texas, USA
    Posts
    3,362

    Arrow Cargo Light not working

    Quote Originally Posted by Felix_65 View Post
    I damaged my RBCM in the process of installation of additional LEDs. I didn't unplug the battery... and the mosfet Q15 was burned. There are two variants of such MOSFETs: SOT23-6 (replacement ZXMN6A08E6) and SC-62(replacement 2sk3065).
    Thanks for detailed info on what you'd found when you damaged the RBCM. If you could pinpoint the burned component, you can fix your damaged RBCM at component level by yourself with easy. I guess from my old knowledge a MOSFET power transistor loooks like this:


    And this has dual MOSFET power transistors packaged together as one chip like you mentioned - type SOT23-6 which is on our RBCM board:

  6. #21
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9
    In my RBCM board was established ZXMN6A08E6. This mono MOSFET in SOT23-6.


    But I had to replace it with a 2sk3065 (SC-62). Unfortunately no photos.

  7. #22
    Registered Member yrwei52's Avatar
    Donated: $8

    2016 Mazda CX-5 GT AWD w/Tech

    Join Date
    Mar 2015
    Location
    Plano, Texas, USA
    Posts
    3,362

    Arrow Cargo Light not working

    Quote Originally Posted by Felix_65 View Post
    In my RBCM board was established ZXMN6A08E6. This mono MOSFET in SOT23-6.


    But I had to replace it with a 2sk3065 (SC-62). Unfortunately no photos.
    OK, got it! Thanks for making correction. In the future one can use this info to fix damaged RBCM without paying a hefty price for a whole new module!

  8. #23
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9
    OK! Good luck!

  9. #24
    Registered Member tibimakai's Avatar

    2014 Mazda CX-5 Touring

    Join Date
    May 2013
    Location
    Los Angeles-San Dimas, USA
    Posts
    2,074
    Good info, if I need it. I have hot air station as well, so easy peasy for me. Thank you.

  10. #25
    Registered Member

    2013 Mazda CX-5 sport

    Join Date
    Aug 2007
    Location
    Indiana
    Posts
    3
    I have a 2013 CX-5 and replacing interior lights with leds was the first thing I did to it. I also did not disconnect the battery or light, must have shorted it while installing the led in the cargo area. Now it does not work. I bought a new (used) rbcm and planned on swapping it in. However, I read that some info is stored on the rbcm and needs to be temporarily copied off of it, then loaded onto the new one upon install. Does anyone know if this is true!? I was attempting to avoid dealer/repair fees. Will it hurt anything to just swap in the new one without doing anything else? Anyone know?

    Or...for those of you who took apart their rbcm and repaired it. Did you just reinstall it after repair and everything worked? Thanks in advance.

  11. #26
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9
    Yes! I "reinstall it after repair and everything worked"!
    The default should work. But there really are registered your vehicle options. Read more here: http://mazda3revolution.com/forums/2...s-asbuilt.html

  12. #27
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9

  13. #28
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,686
    Blog Entries
    8
    Felix_65: Thanks for posting links and info... all good stuff!! I'd fix myself if not under warranty.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  14. #29
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,686
    Blog Entries
    8
    Dealer says bad RBCM. Not providing ground on cargo light circuit. They are searching for parts availability.

    Nearest module is in California so I'll get replacement next week.
    Last edited by Kedis82ZE8; 01-18-2017 at 04:09 PM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  15. #30
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,686
    Blog Entries
    8
    Getting this changed out tomorrow.

    I assume most of the left trim in cargo area is going to need to be removed or can the unit be swapped out through the tail light access panel? I am told a couple hours work so probably somewhat invasive.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. CX-5 Cargo Light: The Thread.
    By mercaptan in forum CX-5 Accessories & Appearance
    Replies: 6
    Last Post: 11-04-2016, 04:33 PM
  2. Cargo light - always on
    By gova in forum CX-5 Lounge
    Replies: 6
    Last Post: 09-21-2014, 07:29 PM
  3. CX-5 Cargo Light
    By Mysterio in forum CX-5 Accessories & Appearance
    Replies: 7
    Last Post: 03-19-2013, 12:58 PM
  4. parking light/dim brake light not working
    By THExDRIZZLE in forum Mazda3 Lounge
    Replies: 1
    Last Post: 04-07-2010, 07:23 AM
  5. Cargo light not working with hatch
    By cx9er in forum CX-9 Audio
    Replies: 16
    Last Post: 04-11-2008, 08:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •