Your Best Source for Genuine Mazda Parts!
Your Best Source for Genuine Mazda Parts!
Page 1 of 3 123 LastLast
Results 1 to 15 of 35

Thread: Cargo Light not working

Hybrid View

  1. #1
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8

    Cargo Light not working

    So many misc thread so wasn't sure about resurrecting an old one.

    Anyway.... notice the cargo light was working. I put in a VLED a year or so back and it has worked fine. I can't remember when it stopped working.

    I put in stock good bulb and no go. It seems there is a ground or voltage issue.

    Can the RBCM be damaged? and if so would it only affect the cargo light? I tested every light and function in back and the cargo light is the only thing that doesn't work.

    I still have a few thousand left on 3/36 so will let dealer deal with it. I left stock bulb in there in case I need to take to dealer.
    '15 CX-5 GT 2.5L w/tech package & i-ACTIV AWD - Liquid Silver Metallic (04/2014 build-07/2014 delivery) - 33K Miles

    ==================
    NB1 Navigation Updates (980 NEW-11/2016) / Why Mazda moly oil? - Mazda TSBs / My Misc add-ons / Mazda owners manuals / SkyActiv Oil Analysis Thread

  2. #2
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    Lift Gate Latch Switch works.... or I assume that is the exterior button and not some microswitch in the actual latch assembly?

    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  3. #3
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    Looks like there is a microswitch in there.



    If this wasn't under warranty I would change that myself.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #4
    Registered Member yrwei52's Avatar
    Donated: $8

    2016 Mazda CX-5 GT AWD w/Tech

    Join Date
    Mar 2015
    Location
    Plano, Texas, USA
    Posts
    3,675

    Arrow Cargo Light not working

    Quote Originally Posted by Kedis82ZE8 View Post
    .... notice the cargo light was working. I put in a VLED a year or so back and it has worked fine. I can't remember when it stopped working.

    I put in stock good bulb and no go. It seems there is a ground or voltage issue.

    Can the RBCM be damaged? and if so would it only affect the cargo light? I tested every light and function in back and the cargo light is the only thing that doesn't work.
    I believe you forgot to turn on the switch which is located next to the cargo light.

    Seriously, RBCM can get damaged for pre '15 CX-5 as the cargo light somehow isn't fused. The worse case scenario is your VLED had shorted it out by itself, hence burned the RBCM. Have you physically measured the voltage of bulb sockets and can you see 12V when the cargo light is supposed to be on? Can you verify the VLED you used for cargo light is working by testing it on the map/dome light (measure the ohms first and make sure it's not totally shorted, i.e. 0Ω)? I guess the best is to let dealer handle it as the module is expensive. if indeed your RBCM got damaged, you may consider add an inline fuse if you plan to use an LED again.

  5. #5
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    I'll do a voltage test this week. It's not totally shorted... not sure what expected Ω rating of LED bulb is. I'll have to look at that. Not shorted.... if this did cause issues gonna stick purely with incandescent in that area. I've got another fused LED bulb in the 12V adapter in rear that puts out enough light. I did the little screwdriver trick in diagram above but still could get door lock to release. Had a brief panic and then popped off that inside cover. The white plastic piece below is a release for the mechanism.




    Of course in the grand scheme of things I can think of far worse things to be out that the cargo light.


    EDIT: LED bulb is coming in at 300Ω
    Last edited by Kedis82ZE8; 01-03-2017 at 08:23 PM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  6. #6
    Registered Member
    Donated: $15

    2014 CX 5 Touring FWD

    Join Date
    Mar 2013
    Location
    ABE area, Pennsylvania, USA
    Posts
    607
    Did you disconnect the battery before changing? There are specific warnings in the service manual to do this otherwise the RBCM could very well be damaged.

  7. #7
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    No, I just disconnected light assembly & swapped bulb two years ago and haven't touched it since. If damaged it certainly took its time to fail.. probably a cold solder joint or bad ground. I think now it seemed to happen after sitting out in the near zero cold for a week or so.

    From what I have read it seems most who damaged RBCM tried changing the bulb in the assembly while still connected. In FSM that just looks like standard warning of working with electrical & disconnect to be safe. I suppose if someone got sloppy with a screwdriver extracting light assembly they could short something out.

    Bulb was also perfectly seated in socket when I extracted so no short happened there. Might just be a red herring that I put in the LED years back and module failed or it isn't the module either. It was under a lot of snow and ice... maybe there was some intrusion somewhere in the lock mechanism? I'll probably take it in a few weeks from now.

    I don't mind them messing with those panels... I don't like dealer touching passenger doors though.

    ===========================

    It's not the separate latch microswitch as dashboard door indicator shows hatch open & closed. Looking closer at how this thing is wired it does appear to go directly to the RBCM. Lots of troubleshooting data in manual but of course need a M-MDS to interface with it. Even if one got the module it appears you need Mazda dealer to program it according to FSM.

    Looking at the TSB it mentions that disconnecting the cargo light connector is acceptable as well when swapping bulbs.

    EDIT: Looking around part number appears to be KD45675Y0G and can be obtained for around $120-$135
    Last edited by Kedis82ZE8; 01-04-2017 at 05:44 PM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #8
    Registered Member gova's Avatar

    '14.5 CX-5 Touring AWD, Soul Red | '14 CX-5 Touring AWD White

    Join Date
    Jul 2012
    Location
    IL
    Posts
    407
    Burnt module due to short because battery was not disconnected.

  9. #9
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    Quote Originally Posted by gova View Post
    Burnt module due to short because battery was not disconnected.
    I don't disagree module is now impaired...maybe a bad solder joint but as you can see from TSB battery disconnect is "not required". I did the latter and has been fine for over 2 years.

    EDIT: I should say... not the only method as it is a viable option as well.

    http://am.mazdaserviceinfo.com/mazda...let&id=TSB1347

    "TO AVOID DAMAGING THE RBCM DURING CARGO COMPARTMENT LIGHT BULB REPLACEMENT, ALWAYS DISCONNECT THE NEGATIVE BATTERY CABLE OR THE CARGO LIGHT CONNECTOR."

    It is easy to see this switch and how it is wired isn't the greatest work of engineering. If one did leave connected it would be relatively easy to create a short.
    Last edited by Kedis82ZE8; 01-08-2017 at 11:00 AM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  10. #10
    Registered Member yrwei52's Avatar
    Donated: $8

    2016 Mazda CX-5 GT AWD w/Tech

    Join Date
    Mar 2015
    Location
    Plano, Texas, USA
    Posts
    3,675

    Arrow Cargo Light not working

    Quote Originally Posted by gova View Post
    Burnt module due to short because battery was not disconnected.
    No you don't need to disconnect negative on battery while replacing the cargo light if you know what you're doing like Kedis82ZE8 did. He disconnected a connector to the cargo light, which has the same effect as disconnecting the battery. Kedis82ZE8's RBCM may be bad right now but definitely is not caused by improper installation of an LED. And Kedis82ZE8 also checked the resistance of the cargo LED and it isn't shorted out with 300Ω which means the LED itself didn't damage the RBCM. I simply think it was a bad design to leave cargo light unfused, and it got changed after 2016 MY.

  11. #11
    Registered Member

    2014 Mazda CX-5 GT AWD w/Tech

    Join Date
    Aug 2013
    Location
    Bloomington, Minnesota, USA
    Posts
    435
    When I swapped my bulb for an LED, I just disconnected the switch first. Never had any problems.

  12. #12
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    I plan to take in within the next couple weeks... winding down on bumper-to-bumper so need to get in within the next couple months. Unrelated to this thread but I'm also going to ask about the following as I hear both at times.

    2013-16 CX-5, 2014-16 MAZDA3 AND MAZDA6 – CREAKING NOISE FROM FRONT LOWER ARM BUSHING


    Thumping Noise From Under Front – 2013-2015 Mazda
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  13. #13
    Registered Member

    CX-5

    Join Date
    Jan 2015
    Location
    Russia
    Posts
    9
    Hi! Had the same problem. Was damaged transistor in the block RBCM.

  14. #14
    Registered Member yrwei52's Avatar
    Donated: $8

    2016 Mazda CX-5 GT AWD w/Tech

    Join Date
    Mar 2015
    Location
    Plano, Texas, USA
    Posts
    3,675

    Arrow Cargo Light not working

    Quote Originally Posted by Felix_65 View Post
    Hi! Had the same problem. Was damaged transistor in the block RBCM.
    Would you mind to give us more detail about your experience on this? Did you use an LED as cargo light? Did your RBCM get damaged during installation of LED or like Kedis82ZE8 a couple of years after the use the LED?

    BTW, if the component you circled is the culprit of your damaged RBCM, it's an IC, not a transistor just to the right. Hope someone like you can do component level fix as you had identified the bad IC on this damaged module.

  15. #15
    i-ACTIV AWD Aficionado Kedis82ZE8's Avatar
    Donated: $25

    '15 CX-5 GT AWD w/tech

    Join Date
    Jul 2014
    Location
    WA State
    Posts
    3,716
    Blog Entries
    8
    Yeah... really interested if my VLED somehow caused this or just a flawed RBCM. Since there are some unknowns here I'll probably just leave the incandescent back there after repair.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Page 1 of 3 123 LastLast

Similar Threads

  1. CX-5 Cargo Light: The Thread.
    By mercaptan in forum CX-5 Accessories & Appearance
    Replies: 6
    Last Post: 11-04-2016, 03:33 PM
  2. Cargo light - always on
    By gova in forum CX-5 Lounge
    Replies: 6
    Last Post: 09-21-2014, 06:29 PM
  3. CX-5 Cargo Light
    By Mysterio in forum CX-5 Accessories & Appearance
    Replies: 7
    Last Post: 03-19-2013, 11:58 AM
  4. parking light/dim brake light not working
    By THExDRIZZLE in forum Mazda3 Lounge
    Replies: 1
    Last Post: 04-07-2010, 06:23 AM
  5. Cargo light not working with hatch
    By cx9er in forum CX-9 Audio
    Replies: 16
    Last Post: 04-11-2008, 07:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •