VersaTuner - tuning software for Mazdas
VersaTuner - tuning software for Mazdas
Results 1 to 3 of 3

Thread: Mazdaspeed Protege cutting out at high rpms

  1. #1
    Registered Member

    2003 Mazdaspeed Protege

    Join Date
    Dec 2016
    Location
    Kansas
    Posts
    3

    Mazdaspeed Protege cutting out at high rpms

    Alright so I got a 2003 Mazdaspeed Protege and at high rpms it will cut out then pick right back up. I cant seem to figure out what it would be. MAP sensor? Idk. Its not throwing the CEL.

  2. #2
    Registered Member


    Join Date
    Jul 2008
    Location
    Gulfport, Mississippi
    Posts
    2,031
    You posted in the wrong forum. This is for Mazdaspeed 3 cars (2007-2013). Not likely to get your issue resolved here, as our engines are much different. Sorry. For our cars, that symptom would point to replacing or regapping spark plugs. We get that condition if the plug gap is too wide. High turbo boost literally blows out the spark. Might be something completely different on your car.
    Last edited by MSMS3; 12-24-2016 at 03:43 PM.
    Sunlight Silver '08 MS3 GT

    Mods:

    TurboXS DP/RP "Stealthback" package into stock CBE; Vibrant 3 inch Ultra Quiet Resonator in RP section, Magnaflow 3 1/2 unrolled exhaust tip; Mazdaspeed CAI w/air straightener and K&N filter; NGK Iridium IX LTR7IX-11 one step colder plugs; Hypertech tune; Autotech CDFP internals; stock BPV; Yokohama Advan Neova AD08R's stock size on stock rims; Grimmspeed EBCS in two port mode; Hawk HPS pads; Bilstein HD (B6) struts and shocks; SPC rear camber arms.

  3. #3
    Registered Member

    2003 Mazdaspeed Protege

    Join Date
    Dec 2016
    Location
    Kansas
    Posts
    3
    Thank you.

Similar Threads

  1. High RPMs
    By YouDontGnomeMe in forum Mazdaspeed Protege
    Replies: 10
    Last Post: 05-21-2011, 03:53 PM
  2. Dealer and the high pitched noise at high rpms and idle
    By muhundy21 in forum Mazdaspeed Protege
    Replies: 2
    Last Post: 02-24-2010, 11:09 AM
  3. Replies: 8
    Last Post: 06-02-2009, 06:34 PM
  4. Unusually High RPMs On Protege 5?
    By Ksychic in forum Protege5
    Replies: 36
    Last Post: 06-01-2009, 09:26 AM
  5. LAST ISSUE: Not building boost, cutting out at 4K rpms.
    By Metallic36 in forum Mazdaspeed Protege
    Replies: 56
    Last Post: 03-14-2009, 03:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •