CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Page 6 of 6 FirstFirst ... 456
Results 76 to 85 of 85

Thread: Cody's Blazing Yellow MSP

  1. #76
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    Lately I've been trying to knock out some little things on the car that have been bothering me. The main thing has been the idle. It has a rough idle on warm starts that I can't figure out. The idle will dip down to about 500 rpm and won't rev for a few seconds. After maybe 15-20 seconds it will correct itself and everything is normal. I bought another MAF from the junkyard as well as 2 extra IACs plus I already tried a spare IAC that we had. I also cleaned the throttle body. Hopefully IAC number 4 will work. I haven't driven the car since swapping it out yesterday.

    This weekend I also adjusted my parking brake, and bled/flushed the brakes. The old fluid looked like syrup or Coke. Lastly, I sealed the surface rust that was forming on the back of the driver front and passenger front doors as well as the inside part of the trunklid. The rust converter is actually really nice. It dries clear. I went overboard with the tape. You definitely don't want to get it on the exterior paint but when it dries it kind of looks like hot glue but not as thick.

    Random pics below... My dad bought a trailer for his p5 too.

















    Last edited by e30addict; 07-04-2017 at 04:05 PM.
    2003.5 Mazdaspeed Protege - 251k on chassis
    1991 BMW 318is - 283k and M52 swapped

  2. #77
    Damian boostdprotegelx's Avatar
    Ren lookalike

    LX & MSP 935

    Join Date
    Jan 2005
    Location
    Owings Mills, Maryland
    Posts
    9,104
    Egr valve is the rough ifle
    Be happy!

  3. #78
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    Quote Originally Posted by boostdprotegelx View Post
    Egr valve is the rough ifle
    I forgot to mention that I cleaned the EGR valve as well. I may try to swap that out with a spare.

    Sent from my MotoG3 using Tapatalk
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #79
    Certified Mazda Tech hornsfan10609's Avatar

    2003.5 Mazdaspeed Protege x2

    Join Date
    Jul 2009
    Location
    Austin, Tx
    Posts
    8,114
    Check this out:
    https://www.mazdas247.com/forum/show...e5-need-advice!

    Looks like the previous owner of your dad's P5 was a member
    Mod List. "Jinba Ittai"

    2003.5 Titanium Mazdaspeed Protege #1345 Purchased 7/20/10
    2003.5 Titanium Mazdaspeed Protege #1574 Purchased 10/25/14

    2009 Highland Green Mustang Bullitt #5998 12.9@110
    2002 Red Protege5 RIP:4/25/10

  5. #80
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    Quote Originally Posted by hornsfan10609 View Post
    Check this out:
    https://www.mazdas247.com/forum/show...e5-need-advice!

    Looks like the previous owner of your dad's P5 was a member
    That's cool! I knew he had to have been a member on here. Thanks for sharing!
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  6. #81
    Certified Mazda Tech hornsfan10609's Avatar

    2003.5 Mazdaspeed Protege x2

    Join Date
    Jul 2009
    Location
    Austin, Tx
    Posts
    8,114
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  7. #82
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    The MSP has been running great these past few months. All idle issues went away. Last night it finally hit 250,000 miles.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #83
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    Well, as soon as I think the car is reliable, something happens... I was on my was home from work last Wednesday and the clutch starts slipping really bad. By the time I got close to home, I almost wasn't sure if I would make it. The strange thing is that when I took out the transmission over the summer, the clutch disk had plenty of material on it. In fact, the previous owner told me it was put in with the new engine right before I bought the car. That means the clutch has a total of 17k miles on it. It's a Spec Stage 2+. After doing some reading online, it seems as if their quality is hit or miss. I won't know what happened until I take the old one out but I'm guessing the pressure plate is somehow not doing it's job. I just received my Exedy Stage 1 clutch kit from Cr3 Motorsports. It may be a while before I swap it out. I'm doing an M52 engine swap on my e30 soon.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  9. #84
    Resident Asshole Maxx Mazda's Avatar
    Donated: $10

    Completely Stock P5

    Join Date
    Aug 2003
    Location
    Calgary, AB
    Posts
    7,341
    I had a SPEC back in the day. Supposed to hold 500lb-ft and ended up slipping if I launched in second gear at only 22psi. Swapped it out for a clutchmasters and all was well.


    Completely stock...

  10. #85
    Registered Member

    2003.5 Mazdaspeed Protege

    Join Date
    Sep 2015
    Location
    GA
    Posts
    48
    I finished the clutch job on January 2nd. Here's a photo dump of the Spec. When I took it off last summer, I noticed the bolts on the pressure plate were not torqued down evenly. That still doesn't explain why it started slipping so bad in November. Oh well.... The Exedy Stage 1 is installed now and the car feels better than ever. I also had the flywheel resurfaced at the same time.

    MSP slipping clutch 006 by cdygrubbs, on Flickr
    MSP slipping clutch 002 by cdygrubbs, on Flickr
    MSP slipping clutch 003 by cdygrubbs, on Flickr
    MSP slipping clutch 004 by cdygrubbs, on Flickr
    MSP slipping clutch 009 by cdygrubbs, on Flickr
    MSP slipping clutch 008 by cdygrubbs, on Flickr

    Also got the engine pulled on the e30 and swapped in my M52 2.8L
    M52 Project 060 by cdygrubbs, on Flickr
    M52 Project 109 by cdygrubbs, on Flickr

    Looking pretty good with fresh paint!! I had it painted back in August.

    IMG_20171105_140407172 by cdygrubbs, on Flickr
    E30 restore 034 by cdygrubbs, on Flickr

    The MSP is now running great and the E30 is in the shop for a custom exhaust. Things are looking up.
    Last edited by e30addict; 01-20-2018 at 11:58 AM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Page 6 of 6 FirstFirst ... 456

Similar Threads

  1. 03.5 Blazing Yellow MSP - WI
    By axisboldaslove in forum Completed Transactions
    Replies: 120
    Last Post: 10-06-2008, 12:24 AM
  2. 3.5 blazing yellow msp
    By tracknfield423 in forum Global
    Replies: 9
    Last Post: 04-20-2006, 04:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •