Compare auto reliability with reliable results at TrueDelta.com!

Compare auto reliability with reliable results at TrueDelta.com!
Page 3 of 26 FirstFirst 1234513 ... LastLast
Results 31 to 45 of 388

Thread: My 2002.5 P5 AwesomeSauce build thread

  1. #31
    Registered Member Taco Cat's Avatar

    '02.5 Mazda Protege5

    Join Date
    Mar 2014
    Location
    757
    Posts
    170
    Wow, good updates man! Love the molded gauge holders, looks super clean . Nice job on the engine bay clean up too. A little goes a long way, so it still looks much better than stock

  2. #32
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by Taco Cat View Post
    Wow, good updates man! Love the molded gauge holders, looks super clean . Nice job on the engine bay clean up too. A little goes a long way, so it still looks much better than stock
    Thanks! Wish I could do more but I still need a car to drive lol. A little does go a long way. Have some awesome plans to clean up the bay after the car gets painted

    Sent from my XT1060 using Tapatalk

  3. #33
    Registered Member

    mazda protege5

    Join Date
    Jun 2015
    Location
    Bay Area
    Posts
    32
    Clean p5 man. How did you mold the gauge pods in there? Looks super good.
    02 P5: Eibach Pro-Kit, Megan Lateral arms, hitch, leather, 5 speed

  4. #34
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by moparmansfield View Post
    Clean p5 man. How did you mold the gauge pods in there? Looks super good.
    Thanks! Lots of patience and glazing putty.... And sanding lol. Still need to do another one cause the design on this one is no good.

    Sent from my XT1060 using Tapatalk

  5. #35
    Registered Member ZealoustheEnder's Avatar
    Donated: $10

    2003 MazdaSpeed Protege

    Join Date
    Oct 2012
    Location
    Oviedo, Florida
    Posts
    780
    I soaked buddy's turbo in marvel for an hour.

    Sent from my HTC Desire 626s using Tapatalk
    Last edited by ZealoustheEnder; 12-14-2015 at 10:08 PM.

  6. #36
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by ZealoustheEnder View Post
    I soaked buddy's turbo in marvel for an hour.

    Sent from my HTC Desire 626s using Tapatalk
    Hopefully letting it soak will do the trick. Gonna be trying to fix my oil leak tomorrow while the snap ring soaks. Hopefully I can do that as well without taking the intake manifold off. Might be kinda hard to work on the oil cooler but we'll see

    Sent from my XT1060 using Tapatalk

  7. #37
    Registered Member ZealoustheEnder's Avatar
    Donated: $10

    2003 MazdaSpeed Protege

    Join Date
    Oct 2012
    Location
    Oviedo, Florida
    Posts
    780
    I had the car on Jack stands easy access to the oil cooler from underneath

    Sent from my HTC Desire 626s using Tapatalk

  8. #38
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by ZealoustheEnder View Post
    I had the car on Jack stands easy access to the oil cooler from underneath

    Sent from my HTC Desire 626s using Tapatalk
    Have mine on jack stands right now. Havent looked yet to see if there is anything that will get in the way. Gonna tackle that job first thing tomorrow

  9. #39
    Registered Member

    Protege5

    Join Date
    Jan 2015
    Location
    Springfield, MO Area
    Posts
    977
    You don't still have the wiper arm do you?
    2002 Protege5 5 Speed, Pure White, FSZE Swap, Konig Incident 17's
    2006 Chevy Silverado 1500 4x4 5.3

  10. #40
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by MrGiggles View Post
    You don't still have the wiper arm do you?
    I still have the wiper arm and wiper motor

    Sent from my XT1060 using Tapatalk

  11. #41
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Some good progress today! Bought a new timing belt upper and lower cover and a canadian egr valve. I was also able to change the oil cooler gasket. Was a real pain in the ass but I got it done. Torqued that down and put a new oil filter on it.

    How i'm going to route my piping. Going to get a slim fan and put it in front on the condenser as a push fan. Eventually going to have SS braided water lines so I can route the piping better and have space for a mishimoto fan shroud which is coming in the future.







    Going to be tapping some holes for the wastegate bracket tomorrow but I have it mocked up so I can try and measure where to drill.





    That's it for today, a lot of progress was made and i'm super happy! Will have a running car soon again

    To Do List:
    - Tap new holes for wategate bracket
    - Fix stripped exhaust manifold bolt hole on head
    - Torque down turbo water hard pipes
    - Torque down exhaust manifold
    - Clamp water lines
    - New coolant/oil

    Then should be start up time
    Last edited by MeAndMyPenguin; 01-04-2016 at 08:06 PM.

  12. #42
    Registered Member ZealoustheEnder's Avatar
    Donated: $10

    2003 MazdaSpeed Protege

    Join Date
    Oct 2012
    Location
    Oviedo, Florida
    Posts
    780
    Quote Originally Posted by MeAndMyPenguin View Post
    Some good progress today! Bought a new timing belt upper and lower cover and a canadian egr valve. I was also able to change the oil cooler gasket. Was a real pain in the ass but I got it done. Torqued that down and put a new oil filter on it.

    Finally got that dam snap ring off



    I also found that something is leaking really bad all over the left side of the block. Pretty sure its oil but I'm just going to clean it off and see check up on it again later. Also, I might a have a stripped bolt hole on the head. If it is, then i'm going to repair it with a helicoil.



    How i'm going to route my piping. Going to get a slim fan and put it in front on the condenser as a push fan. Eventually going to have SS braided water lines so I can route the piping better and have space for a mishimoto fan shroud which is coming in the future.







    Going to be tapping some holes for the wastegate bracket tomorrow but I have it mocked up so I can try and measure where to drill.





    That's it for today, a lot of progress was made and i'm super happy! Will have a running car soon again

    To Do List:
    - Tap new holes for wategate bracket
    - Fix stripped exhaust manifold bolt hole on head
    - Torque down turbo water hard pipes
    - Torque down exhaust manifold
    - Clamp water lines
    - New coolant/oil

    Then should be start up time
    I would tap the turbo for wastegate actuator signal.

    Sent from my HTC Desire 626s using Tapatalk

  13. #43
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    Quote Originally Posted by ZealoustheEnder View Post
    I would tap the turbo for wastegate actuator signal.

    Sent from my HTC Desire 626s using Tapatalk
    Thanks for reminding me! I also plan on doing that aswell

    Sent from my XT1060 using Tapatalk

  14. #44
    Registered Member MeAndMyPenguin's Avatar

    2002.5 Mazdaspeed Protege5

    Join Date
    Apr 2013
    Location
    Miami, FL
    Posts
    363
    A few days late but I got the car up and running nicely! Just need to fix a P0401 and a P0090. Still waiting on my canadian EGR valve. Hopefully that fixes the P0401. Gonna try and change the FPR solenoid and see if that fixes the P0090.

    Got a ATP quick tap fitting for my wastegate source. Didnt want to get a fitting and drill a hole in the housing.

    Last edited by MeAndMyPenguin; 01-04-2016 at 08:07 PM.

  15. #45
    Registered Member Taco Cat's Avatar

    '02.5 Mazda Protege5

    Join Date
    Mar 2014
    Location
    757
    Posts
    170
    Sounds good man!

Page 3 of 26 FirstFirst 1234513 ... LastLast

Similar Threads

  1. Aw_MP5 - Build Thread - Slow Build
    By Aw_MP5 in forum Protege5 Builds
    Replies: 12
    Last Post: 05-13-2014, 12:45 AM
  2. My Build Build Thread
    By Boosted_Speed in forum Mazdaspeed Protege
    Replies: 3
    Last Post: 05-26-2013, 11:45 AM
  3. Lewis7789 2002 Protege5 build thread (tons of pics)
    By Lewis7789 in forum Protege5 Builds
    Replies: 2854
    Last Post: 04-11-2013, 09:37 AM
  4. My build thread.
    By Twinrotor in forum Mazdaspeed Protege
    Replies: 8
    Last Post: 05-20-2012, 09:13 PM
  5. STX Build Thread
    By 122 Vega in forum Pics & Builds
    Replies: 261
    Last Post: 04-29-2007, 01:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •