Compare auto reliability with reliable results at TrueDelta.com!

Compare auto reliability with reliable results at TrueDelta.com!
Results 1 to 6 of 6

Thread: Rx8 Loss of power

  1. #1
    Registered Member

    Mazda Rx8

    Join Date
    Dec 2014
    Location
    United States
    Posts
    5

    Rx8 Loss of power

    I have a 2007 mazda rx8 automatic 6spd and recently ive been experiencing a loss in power. also i got my spark plugs, ignition coils, and wires replaced recently aswell. there is no cel whatsoever. although i should include that there was a p0420 about 4-5 months ago it came on for a week and my friend erased it when he was looking at what it was and it never came back on. i do i have a cold air intake(k&n) and i also got a muffler delete about 1 month ago. i notice my intake gets louder when it hits around 4,000-4,500. now i drove around and got live feed for my cat because thats what i thought was wrong and apparently the cat is fine. i was looking at the temperature and temperature goes around 1,700degrees when accelerating but drops down around 1,500 at normal cruise. if the cat was clogged i believe the temp would exceed these numbers, but i still havent ruled it out yet. Only thing else i can think of is compression loss. let me know your thoughts about this and if u need any info

  2. #2
    Crusty Sailor solidtrance's Avatar

    HIS: 2005 RX-8 WWP GT 6MT* HERS: 2006 Speed6 BCM 6MT**

    Join Date
    Feb 2009
    Location
    California's Central Valley
    Posts
    1,532
    K&N intake is not good and could be causing problems if it was not installed properly.

    We're the plugs/coils/wires done before or after the power loss started?

    *05 RX-8 WWP, GT, MT, AFE STS, COBB AP MM Custom Tune, BHR Ignition, AEM CAI, Agency Power CBE + Dual Resonated Midpipe, Racing Beat Sway Bar Endlinks, Progress Technology Sport Springs and FSB, Koni Sport Struts, MS Strut Bar, HPS Brake pads F/R, ATE Super Blue Fluid, HK Drive+Play, Racing Beat Gauge pod, Prosport Oil Pres, Water & Oil Temp, SS Strakes
    **06 Mazdaspeed 6 Black Cherry, MT, HPS, PG SRI, COBB TIP, DENSO ITV22, Corksport IC, Cobb AP

  3. #3
    Registered Member

    Mazda Rx8

    Join Date
    Dec 2014
    Location
    United States
    Posts
    5
    Quote Originally Posted by solidtrance View Post
    K&N intake is not good and could be causing problems if it was not installed properly.

    We're the plugs/coils/wires done before or after the power loss started?
    I got 2 engine codes today p0411 secondary air injection incorrect flow detected and p0113 intake air temperature circuit high input. there was definently power loss before the sparks/coils/wires but it only got worse. let me know what you think

  4. #4
    I break stuff. Preferio's Avatar
    Donated: $1.67

    2003 Mazdaspeed Protege 1660, 2004 Winning Blue RX8, 2005 Mazda6

    Join Date
    Mar 2011
    Location
    Knoxville, Tn
    Posts
    3,822
    The secondary air DTC will not cause any drivability concerns.

    The IAT DTC is your red flag. It's integrated into the MAF. A MAF concern would, obviously, cause power concerns, but you're not having a DTC for a MAF circuit, only the IAT circuit.

    With the clip of the MAF sensor plug facing up, the terminals are as fololows:
    [e|d|c|b|a]

    Measure voltage between terminal d and ground- it should be battery voltage (b+)

    BTW, your cat tempers are okay, though it's best to take a thermal gun and take an external pre-cat reading and an external post-cat temp to get an idea of variance. If you see 800 pre-cat, but 600 post-cat, you know you have a restriction. However, if you recorded a pre-cat temp of 800 and a post-cat temp of 750, you're okay, that's normal.

    EDIT: If you can view live data on your O2 to get the operating temperature of the cat, you can view live data to view your actual intake air temperatures. Obviously, if it's -80F or 250F, your ECM is going to see that and adjust the fuel trims to an appropriate level to match the intake air temperatures.
    Last edited by Preferio; 12-23-2014 at 06:25 PM.
    ASE Certifications: A1, A4, A5, A8, C1, P2
    Mitsubishi-Fuso: Electr. Cert. 1, 2, 3 and 4

    2016 Mazda CX5 Touring AWD
    2013 Mazda CX5 Touring AWD
    2013 Mazda CX5 Touring Gone.
    2008 Mazda CX7 Touring AWD
    2007 Mazdaspeed 3:
    2005 Mazda 6 S: Gone.
    2004 Mazda RX8: Gone.
    2003 Mazdaspeed Protege #1660: Gone and missed.
    2003 Mazda Protege5: Gone.
    2002 Mazda Protege5: Gone.
    1995 Mazda Miata Best $50 I've ever spent.

  5. #5
    Registered Member

    Mazda Rx8

    Join Date
    Dec 2014
    Location
    United States
    Posts
    5
    Ive already ordered full exhaust system with a high flow cat. I dont believe the air pump affects performance, its just there to pump exhaust air back to combustion to warm the cat up faster so if there is restriction in the cat itll be harder to pump the air and i believe thats what triggered the code, for the p0113 i put back my stock intake i believe the connection harness on my k&n was bad i didnt want to mix the 2 harness even though its really easy to swap them so i just replaced my intake for now. so once i get my cat replaced ill let u guys know if it fixed it or not

  6. #6
    Registered Member

    Mazda Rx8

    Join Date
    Dec 2014
    Location
    United States
    Posts
    5
    Ok so i fixed the problem and just because i hate when i have a problem and someone starts a thread with a problem similar to mine and doesnt finish the thread or states the problem ima go ahead and help out some people in the future in case this happens to you. so if u feel a loss of power, hesitation, hard to start when hot(sometimes cold), the first thing that should pop in your head is cat and thats what popped in my head. but looking at the temperature it seemed to run fine and yes that cat ended up being the problem, but i listened to some fellow rx8 owners and they told me ways to tell if its bad just by looking at it and NO it was not glowing in the dark, No rotten egg smell either. Im not saying this will not occur to your car im just saying if you have the slightest hint that it might be cat just by visual check is sometimes impossible to tell so i suggest just taking it off and looking at it. also when i took the cat off little chunks started falling out of the cat itself so yeah it was pretty bad...Well thats all, hope that helps anyone else in the future.

    Also i installed a turboxs high flow and catback and its a freaking animal! love the sound. i definitely recommend it! Just hope i dont draw too many cops with that 13b coming to life again :]

    So there you go thanks to all the helped and let me know if you have a similar problem

Similar Threads

  1. loss of power?
    By tweety2300 in forum Protege5
    Replies: 11
    Last Post: 12-18-2011, 03:56 PM
  2. Loss of Power
    By roenick778 in forum Protege5
    Replies: 13
    Last Post: 08-10-2010, 12:08 PM
  3. loss of power.
    By littlemimus in forum Mazdaspeed Protege
    Replies: 14
    Last Post: 06-26-2009, 01:54 PM
  4. CAI power loss
    By coyfish in forum Mazda6 Engine & Transmission
    Replies: 1
    Last Post: 08-10-2008, 09:38 AM
  5. power loss from AEM ?
    By enigM@ in forum Mazda Protege
    Replies: 17
    Last Post: 05-08-2003, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •