Compare auto reliability with reliable results at TrueDelta.com!

Compare auto reliability with reliable results at TrueDelta.com!
Results 1 to 4 of 4

Thread: Mazda CX-7 2009, Multiple Cylinder Misfires, Cylinder One Misfire

  1. #1
    Registered Member

    Mazda CX-7, 2009 Sport

    Join Date
    Nov 2014
    Location
    United States
    Posts
    2

    Mazda CX-7 2009, Multiple Cylinder Misfires, Cylinder One Misfire

    A month ago the engine started running a bit rough, hesitation, rough idle, power surges- at a stop it would feel as if it were going to stall out- never did stall out. I took it to a mechanic, was told it needed a tune up, an ignition coil on cylinder three, set of spark plugs and a new egr valve. All checked out with my research and I decided to have it done.

    Within a day of being fixed it started to have the same issues. This time they were stating that cylinder one needed a new coil. I was tired of paying out cash at this point, decided since I was going to perform a brake job, I thought I would replace all of the coils. Pulled the plugs and despite being new they all had a very dry carbon deposit on them. Cleaned off the plugs. Changed out the three coils that had not yet been replaced. Drove the car around, and it was fine for about six hours, the engine cooled off and suddenly when starting it threw the same code. Engine was rough, power surges, stuttering. Cylinder one was still misfiring. So to trouble shoot it, I took the plug from cylinder one and put it in cylinder two, took the coil from cylinder one and swapped it with cylinder three. At the same time did a fuel system clean out, thinking maybe it could be the injector. Suddenly the car road well, all while the engine is warm, shifted normally, no power surges, no issues. Did an oil change, put 0w 20 full synthetic in, replaced filter everything.

    I'm still having the same issue- when I start the car cold it has the same issue, misfires, stutters and surges- however when the engine warms up the engine runs perfectly fine. Everything appears fine when the engine runs warm. I don't think that it can be the fuel injector at this point because the engine heating up shouldn't affect the injector.

    Has anyone else had this trouble? Or have an idea of which avenue to head down? I considered attempting to switch the plugs over to copper plugs instead of iridium, but I can't find copper plugs to switch over to.

  2. #2
    Registered Member

    Mazda CX-7, 2009 Sport

    Join Date
    Nov 2014
    Location
    United States
    Posts
    2

    Re: Update

    Still continuing as usual- when the engine runs warm, and I clear the CEL, the car won't throw a code. A cold start still causes a CEL. I have a new symptom, however, decreased MPG- I can usually get about 330 miles on a full tank, before the gas light clicks on. This past weekend however I only made it 300 before the gas light hit.

    Any thoughts?

  3. #3
    Registered Member


    Join Date
    Jun 2010
    Posts
    36
    02 sensor?

  4. #4
    Registered Member


    Join Date
    Jun 2019
    Posts
    1

    I have the same issue.

    Quote Originally Posted by jacobpmcg View Post
    Still continuing as usual- when the engine runs warm, and I clear the CEL, the car won't throw a code. A cold start still causes a CEL. I have a new symptom, however, decreased MPG- I can usually get about 330 miles on a full tank, before the gas light clicks on. This past weekend however I only made it 300 before the gas light hit.

    Any thoughts?
    Do you ever found out the problem and how to fix it?

Similar Threads

  1. P0300 random multiple cylinder misfire
    By pjdublada858 in forum Protege5
    Replies: 4
    Last Post: 11-28-2011, 10:08 AM
  2. Random/Multiple Cylinder Misfire
    By 08SPEED3Veteran in forum Mazdaspeed3
    Replies: 8
    Last Post: 01-06-2011, 01:04 PM
  3. Random multiple cylinder misfire???
    By Stieh101 in forum Mazda Protege
    Replies: 47
    Last Post: 05-24-2007, 10:04 AM
  4. "multiple cylinder misfire" code...please help!!
    By Vic Marr in forum Mazda Protege
    Replies: 4
    Last Post: 05-30-2006, 05:14 PM
  5. Multiple Cylinder Misfire
    By AnthonyO3 in forum Mazda Protege
    Replies: 5
    Last Post: 09-08-2004, 05:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •