Compare auto reliability with reliable results at TrueDelta.com!

Compare auto reliability with reliable results at TrueDelta.com!
Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17

Thread: Fog lights not working?

  1. #16
    Registered Member

    2003 mazda protege5

    Join Date
    Sep 2016
    Location
    Az
    Posts
    2
    Okay I got it fixed. The fuse box under the hoo has 2 fog lamp 15amp fuses. I missed one of them last night. I have a picture of the diagram for the wiring. But i don't know how to post pictures here. Any one who can tell me how i will post it. Thanks

  2. #17
    Registered Member

    '02 Mazda Protege5

    Join Date
    Apr 2017
    Location
    Mount Kisco NY
    Posts
    19
    I have a similar issue with my fog lights. the switch doesn't illuminate when i press it, the fuses are both fine. the bulbs are fine. no voltage at the bulbs. where is the exact location of the relay? If that doesn't work I'm just going to wire a whole new circuit to it and switch because screw electrical issues. lmao.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. dash lights not working
    By TSPOON in forum MSP Problems
    Replies: 2
    Last Post: 03-01-2013, 12:28 AM
  2. Fog lights Not working
    By Aloger in forum Protege5
    Replies: 9
    Last Post: 11-30-2008, 11:39 PM
  3. Brake lights not working - help please!
    By coldie123 in forum Protege5
    Replies: 15
    Last Post: 04-07-2006, 09:18 PM
  4. Fog Lights not working
    By Kooldino in forum Mazda How-To
    Replies: 3
    Last Post: 04-02-2004, 09:40 PM
  5. fog lights not working
    By joefufu in forum Mazdaspeed Protege
    Replies: 8
    Last Post: 06-21-2003, 05:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •