Made in USA and Free Shipping on all orders shipped inside the US.
Made in USA and Free Shipping on all orders shipped inside the US.
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: P0455 - Not the gas cap

  1. #1
    Riddle me that! slavrenz's Avatar

    2001 Mazda Protege LX 2.0

    Join Date
    Nov 2008
    Location
    Ames, IA
    Posts
    2,298

    P0455 - Not the gas cap

    Hey guys,

    The CEL came on for me a few weeks ago - P0455. Tried resetting the gas cap, reset the CEL, came back on a few days later. I then tried replacing the gas cap, same procedure, no good.

    Anyone have any tips on what emissions parts usually go bad on our cars? I'm looking at the purge solenoid valve, charcoal canister, CDCV, fuel tank, etc. Unfortunately, it seems as if you need the $5k Mazda testing machine for most of these

  2. #2
    Riddle me that! slavrenz's Avatar

    2001 Mazda Protege LX 2.0

    Join Date
    Nov 2008
    Location
    Ames, IA
    Posts
    2,298
    Anyone? Come on, guys...

  3. #3
    Registered Member dweiser's Avatar

    03' Protege5

    Join Date
    Oct 2009
    Posts
    4
    My car is currently giving me the P0442 error (small EVAP leak), similar issue to yours. Sadly this came up 3 days after i bought the car, private sale.

    First a little back story here: Maybe 200miles before I bought the car a fair amount of work was done, including replacing the fuel pump and lines, so i took it to the shop that did the work to say WTF. They came back and said the issue is there is rust on my gas tank around where the fuel pump sits, and because of this the tank is not sealed shut, which is causing this error. The fix for me according to this place, a new gas tank, quoted at $500parts +$250labor. I took the car back and I'm taking it to a shop i know and trust to look at the car before i get anything done.

    The test to check for leaks is the smoke test, its a device that attaches to the fuel system and then pressurizes it with smoke, where the smoke comes out is where the leak is.

    More likely than having a rusted out gas tank is there is a fuel line or connection thats corroded, however unless you can get under the car and see the leak the smoke test is the only reliable way to go i think. I had called the mazda dealership about the problem I'm having they want about 150 to diagnose the problem, I am also sure most shops have the capability of doing this test for you, probably for less then 150.

    With me the only bright side is that the previous owner agreed to pay for half, even though there is no lemon law saying he has to do anything.

    Good luck, hopefully its something small.
    Last edited by dweiser; 10-30-2009 at 03:43 PM.

  4. #4
    Riddle me that! slavrenz's Avatar

    2001 Mazda Protege LX 2.0

    Join Date
    Nov 2008
    Location
    Ames, IA
    Posts
    2,298
    Quote Originally Posted by dweiser View Post
    My car is currently giving me the P0442 error (small EVAP leak), similar issue to yours. Sadly this came up 3 days after i bought the car, private sale.

    First a little back story here: Maybe 200miles before I bought the car a fair amount of work was done, including replacing the fuel pump and lines, so i took it to the shop that did the work to say WTF. They came back and said the issue is there is rust on my gas tank around where the fuel pump sits, and because of this the tank is not sealed shut, which is causing this error. The fix for me according to this place, a new gas tank, quoted at $500parts +$250labor. I took the car back and I'm taking it to a shop i know and trust to look at the car before i get anything done.

    The test to check for leaks is the smoke test, its a device that attaches to the fuel system and then pressurizes it with smoke, where the smoke comes out is where the leak is.

    More likely than having a rusted out gas tank is there is a fuel line or connection thats corroded, however unless you can get under the car and see the leak the smoke test is the only reliable way to go i think. I had called the mazda dealership about the problem I'm having they want about 150 to diagnose the problem, I am also sure most shops have the capability of doing this test for you, probably for less then 150.

    With me the only bright side is that the previous owner agreed to pay for half, even though there is no lemon law saying he has to do anything.

    Good luck, hopefully its something small.
    Lol, thank god it was something small. So after inspecting my vacuum lines for the 100th time today, I finally found that the bottom hose coming out of my purge solenoid valve wasn't connected to the throttle body. Hooked 'er back up, and all should be good.

  5. #5
    Registered Member MonkeyBone's Avatar

    Silver 2007 6 Sport

    Join Date
    Apr 2007
    Location
    Trois-Rivieres, QC
    Posts
    388
    Have the same number code here! So teel me if what you've done worked!

    Pics of what was diconnected?
    3rd Mazda in 12 years!

  6. #6
    Registered Member dweiser's Avatar

    03' Protege5

    Join Date
    Oct 2009
    Posts
    4
    ohh how I envy you...

    my car is on the way to the local shop where i know the guys today. Its sad that I'm hoping that the other shop was jerking me around, but i highly doubt it, they seemed like pretty stand up people and if it was a problem with their work they would have done it for free

  7. #7
    Registered Member Wojtek's Avatar

    impreza

    Join Date
    Mar 2007
    Location
    south....ontario
    Posts
    427
    bump I have had this code also I got a new gas cap and it's still here. anyone found solution that they would like to share, also I don't smell gas outside the car and nothings dripping

    zoom zoom(redpro)(shady)

    Aftermarket partout! cdm taillights, and some custom stuff

  8. #8
    ......................... i12drivemyMP5's Avatar
    Donated: $5

    323F

    Join Date
    Apr 2005
    Location
    <---------------->
    Posts
    7,508
    Quote Originally Posted by Wojtek View Post
    bump I have had this code also I got a new gas cap and it's still here. anyone found solution that they would like to share, also I don't smell gas outside the car and nothings dripping
    Did you see post #4? If so, did you check yours?

  9. #9
    Registered Member Wojtek's Avatar

    impreza

    Join Date
    Mar 2007
    Location
    south....ontario
    Posts
    427
    yes I did, I checked, I also checked:
    purge valve-good
    catch can-good
    hoses-no leaks, at least not visible,
    gas tank-not cracked

    now I need to check charocoal canister and valves and air filter.

    I have question, If I found out that something's not good and replaced it, would the CEL go away on its own?
    Last edited by Wojtek; 05-13-2010 at 11:01 AM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  10. #10
    ......................... i12drivemyMP5's Avatar
    Donated: $5

    323F

    Join Date
    Apr 2005
    Location
    <---------------->
    Posts
    7,508
    I think that may dependent upon the type of CEL but if it doesn't then just pull the neg battery cable off and let it cycle thru limp mode.

  11. #11
    Riddle me that! slavrenz's Avatar

    2001 Mazda Protege LX 2.0

    Join Date
    Nov 2008
    Location
    Ames, IA
    Posts
    2,298
    Quote Originally Posted by Wojtek View Post
    yes I did, I checked, I also checked:
    purge valve-good
    catch can-good
    hoses-no leaks, at least not visible,
    gas tank-not cracked

    now I need to check charocoal canister and valves and air filter.

    I have question, If I found out that something's not good and replaced it, would the CEL go away on its own?
    just take it to an auto parts store and ask them to clear the code - if they give you shit, just tell them you don't feel like waiting for your car to relearn driveability settings because you disconnected the battery cable.

    As for the code, I've never heard of anyone else getting this code that didn't have a vacuum hose loose (myself included), so just check and check again all of your vacuum lines for looseness.

  12. #12
    Registered Member


    Join Date
    May 2010
    Location
    Naples FL
    Posts
    316
    Dam I got the sam thing going on, P0455. I allready check the lines, and check the gas cap but no luck. Is there n.e one here that could give suggestions? And about post4, I don't see where's there suppose to be a line from the purge to throttle body.

  13. #13
    Registered Member

    2003 P5

    Join Date
    Jan 2018
    Location
    Atlanta, GA
    Posts
    1
    I got the 442 code and found a big crack in the air intake tube. New part from RockAuto on the way $40.

    http://www.rockauto.com/en/catalog/m...take+hose,6344

    Don't know if that'll fix it yet but can't live with that crack. (quick fix with electrical tape so the wife can drive and hopefully not get the code while I wait for the part so show up)

  14. #14
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    4,166
    You've got a small EVAP leak... Your cracked intake tube has nothing to do with that (although you do want a new one)



    There's a 95% chance that you have a bad purge control valve...

    They're kinda steep at Rockauto... EBay has better prices.



    The Diagram Dude

  15. #15
    The Diagram Dude pcb's Avatar

    2002 mazda protege 5

    Join Date
    Jun 2011
    Location
    ontario, canada
    Posts
    4,166
    It's quite easy to test the valve but it's been opening and closing for more than 15 years and they eventually wear out.

    Throwing a $20 part at it isn't that big of a deal...



    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Page 1 of 2 12 LastLast

Similar Threads

  1. P0455, changed gas cap but still get code
    By rtfm17 in forum Other Mazdas
    Replies: 8
    Last Post: 10-22-2010, 10:32 AM
  2. P0455 & P0171 Codes
    By jbilliel in forum Mazdaspeed Protege
    Replies: 1
    Last Post: 08-13-2009, 06:56 PM
  3. MS6 ODBII Code P0455
    By Huascar82 in forum Mazdaspeed6
    Replies: 3
    Last Post: 05-26-2007, 11:50 AM
  4. Engine Code P0455
    By 23ways in forum Other Mazdas
    Replies: 1
    Last Post: 11-21-2003, 09:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •