CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: too lean at idle cel

  1. #1
    Registered Member

    2007 Mazdaspeed 3

    Join Date
    May 2008
    Location
    Sauk Rapids, MN
    Posts
    41

    too lean at idle cel

    i changed my dp and installed a rp in my 07 ms3. now i get a cel saying too lean at idle. does anyone know how to get rid of this?

  2. #2
    Mazda Cstmr Svc Sucks!!! AutoXRacer's Avatar


    Join Date
    Oct 2007
    Location
    Union Park, FL
    Posts
    2,251
    What kind of intake do you have?
    2008 Stage 3 Roush Mustang...

    445HP/400TQ

  3. #3
    <0 SuperStretch18's Avatar

    '07 CX-7 Sport, Black on Black; '04 Mazda3s

    Join Date
    Mar 2007
    Location
    Miramar, FL
    Posts
    1,383
    Tighten all of your intake connections...
    2007 CX-7 Sport FWD
    CPE CAI w/ ramair vent/ETS 3.25" TMIC/ED Test Pipe/AutoExe Floor Bar/Forge BPV/CS 70 Duro MM Inserts/Saikou Michi OCC/Denso ITV-22's/18x8.5 5zigen ZR+520 +47/255-55-18 Nitto 420S/Prosport Boost Gauge/MSD Dashhawk/COBB Knob/Redline Shift Boot/Mazdaspeed Oil Cap/20% Tint/Blacked Out Tails/Carbon Plate Frame/Black Badges/Alumapro Alchemy 12"/PG Amps/Infiniti Components
    The Difference Between Real Life and the Internet
    How to Behave on an Internet Forum
    DO NOT FEED THE TROLLS

  4. #4
    Registered Member

    2007 Mazdaspeed 3

    Join Date
    May 2008
    Location
    Sauk Rapids, MN
    Posts
    41
    i have the mazdaspeed cai

  5. #5
    Registered Member clos561's Avatar


    Join Date
    Nov 2006
    Location
    Palm Beach County
    Posts
    3,181
    there was a recall for this cell, lean at idle code. dealer flashes ur ecu and if that didnt work they did something else (forgot)
    7-Inch Jensen Flip Out Touch Screen, HKS SSQ, MS CAI, Prosport Premium Amber/White Boost Gauge,2nd Cat Gutted, Delrin TRZ MM,16 inch FD rims,TWM shifter Bushings,COBB Turbo Inlet, 28psi, rebuilt stock block, custom rods and piston heads/gaskets, underdrive pulleys, big cams, big oil filter, stage4 clutch, stage4 DISI injectors, Fuel Pump, 4inch Catless TBE with screamer pipe, external wastegate spring modification,Methanol direct twin port duty cycle injection. Tuned by Nator Performance

  6. #6
    Certified Mazda Nut X4 BSTD3's Avatar


    Join Date
    Nov 2006
    Location
    x
    Posts
    740
    ECU reflash and then if that didn't help, replace fuel pump...

    www.shamone.info
    Chuck Norris puts the FUN in funeral.


  7. #7
    <0 SuperStretch18's Avatar

    '07 CX-7 Sport, Black on Black; '04 Mazda3s

    Join Date
    Mar 2007
    Location
    Miramar, FL
    Posts
    1,383
    Before you go to the dealer with mods, check all of your fittings. Too lean at idle could be a case where you are just pulling in unmetered air. You would be bleeding and running rich in boost, but that wouldn't necessarily trigger a code. Some have had issues with loose connections from the dealer.

    Did you use a dashhawk to read the code? If so, have you tried to log A/F ratios?
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #8
    Registered Member

    2007 Mazdaspeed 3

    Join Date
    May 2008
    Location
    Sauk Rapids, MN
    Posts
    41
    well i just checked all the fittings on my intake. didnt find anything really loose and i reset the cel. ill let you know if it comes back

  9. #9
    Mazda Cstmr Svc Sucks!!! AutoXRacer's Avatar


    Join Date
    Oct 2007
    Location
    Union Park, FL
    Posts
    2,251
    Make sure to also check your turbo and intercooler connections.
    I found a lot of stock clamps loose...
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  10. #10
    Registered Member

    2007 Mazdaspeed 3

    Join Date
    May 2008
    Location
    Sauk Rapids, MN
    Posts
    41
    well i tightened everything down and i started the engine. the cel came on while i was setting up my ipod. i am getting really pissed off at the damn thing!!!

  11. #11
    Mazda Cstmr Svc Sucks!!! AutoXRacer's Avatar


    Join Date
    Oct 2007
    Location
    Union Park, FL
    Posts
    2,251
    Quote Originally Posted by dealler_81686 View Post
    well i tightened everything down and i started the engine. the cel came on while i was setting up my ipod. i am getting really pissed off at the damn thing!!!
    It's dealer time!!!
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  12. #12
    Registered Member

    2007 Mazdaspeed 3

    Join Date
    May 2008
    Location
    Sauk Rapids, MN
    Posts
    41
    what are they going to check? i heard about an ecu re-flash.

  13. #13
    Registered Member ericrapp's Avatar

    mazdaspeed 3 cosmic boo

    Join Date
    Dec 2007
    Location
    Fairport ny at the Erie canal
    Posts
    3,676
    Mazda is going to help and I will report. the stock stuff was often loose. but the hot side intercooler piping went soft and distorted. I cooled it down and replaced valve too. I have Mazdaspeed cai.. And I am sure there is more to this in ecu reading and responding.

  14. #14
    Mazda Cstmr Svc Sucks!!! AutoXRacer's Avatar


    Join Date
    Oct 2007
    Location
    Union Park, FL
    Posts
    2,251
    Quote Originally Posted by dealler_81686 View Post
    what are they going to check? i heard about an ecu re-flash.
    There is a reflash and a fuel pump replacement if your car falls between the affected VIN range.

    Here is the info:
    Attached Files Attached Files
    Last edited by AutoXRacer; 06-27-2008 at 07:13 PM.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  15. #15
    save me jeebus! SwampAss's Avatar

    2007 Mazdaspeed3

    Join Date
    Dec 2006
    Location
    Fredericksburg, va
    Posts
    3,496
    My AFRs were a touch lean with the MS CAI @ idle. I changed to an Xcel-intake and through a cell for rich at idle. Once I put some miles on it, I stopped getting those CELs. My AFR is back to 14.7 @ idle but it creeps slowly from 14.0.

    With the MS CAI, it seemed to race to 14.7 in a second just off idle.
    ╔╗╔═╦╗
    ║╚╣║║╚╗
    ╚═╩═╩═╝

Page 1 of 2 12 LastLast

Similar Threads

  1. idle issues
    By Tzar177 in forum Mazda MP3
    Replies: 12
    Last Post: 01-15-2008, 04:39 AM
  2. Cel Came On then went off Anybody know why????????
    By Rac3rX in forum Mazda Protege
    Replies: 6
    Last Post: 06-05-2006, 10:58 PM
  3. Idle with bigger injectors
    By kyle's protege5 in forum Mazda How-To
    Replies: 14
    Last Post: 02-25-2006, 12:39 PM
  4. Why Idle speed do not keep up?
    By quinto555 in forum Mazda Protege
    Replies: 0
    Last Post: 01-06-2006, 08:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •