Won't Accelerate

I have a 2018 CX-5 with around 49,000 miles on it that occasionally won't accelerate, has anyone else had this issue and if so what was the problem? This weekend, I was nearly hit trying to make a u-turn when my car would not accelerate. I pushed the gas pedal and the motor did not rev up, almost like it vapor locked...after a about 10-15 seconds (felt like forever), it finally took off.
 
:
2019 CX-5 GTR
since the CX-5 like most modern vehicles is drive by wire.. it reads like the input from the gas pedal is not being received properly. The only suggestion would be a battery disconnect for 30 minutes and the reconnect to see if the vehicle computer resets. The odd thing is you already said "occasionally" and the vehicle was in motion (but at a slower speed). Curious has this behavior happened above 40 MPH? Can you replicate on demand [same u turn] twice?
 
since the CX-5 like most modern vehicles is drive by wire.. it reads like the input from the gas pedal is not being received properly. The only suggestion would be a battery disconnect for 30 minutes and the reconnect to see if the vehicle computer resets. The odd thing is you already said "occasionally" and the vehicle was in motion (but at a slower speed). Curious has this behavior happened above 40 MPH? Can you replicate on demand [same u turn] twice?
It's happened while trying to accelerate to enter the freeway once and a few times while turning and/or attempting a u-turn
 
What happend if you put it into "sport" ?
I actually did put it into Sport Mode after the second time that it wouldn't accelerate and it didn't hesitate. But my thought is that I shouldn't have to put it into Sport Mode every time I attempt to enter the freeway, make a u-turn, or turn.
 
:
2019 CX-5 GTR
I think the line of questioning about Sport Mode, is that switch changes throttle input response so.. by confirming Sport Mode changes the behavior this leads down the path of troubleshooting to normal throttle operations. I'm just not sure what next steps would be.

Are you the original owner? You might check the pedal for one of these:



 

AVC

:
'17 CX-5 Select
My '17 is at the Mazda dealer now for the exact same symptom, most reproducible on a u-turn or right turn. Just a slow speed-high load scenario. Good throttle response above 40mph or so,

As I use Forscan to collect data, and happen to have a loaner '19 Mazda 3, 2.5L NA to compare it to, the issue is either the MAF is under-reporting, or there something else triggering the Miller cycle mode, which greatly reduces power until the PCM corrects. In my case the CX-5 takes 3 to 4 seconds before the PCM corrects. The low power condition is accompanied by a hollow waaah sound, which is caused, as I understand it, by the greatly advanced (early) intake valve timing.

The issue seems related to a generally lean running condition, most apparent when comparing WOT (Wide Open Throttle) readings. For everyone's reference, here's what the 2.5NA is supposed to do, under WOT from a rolling start.:

Most lines a re self-explanatory. The ones that may not be:

ECT-ACT = actual throttle plate opening, in degrees
APP = accelerator pedal apply in %
SHRTFT1 = short term fuel trim in % above/below desired. pos % = detecting lean increasing fuel. neg % = detecting rich, decreasing fuel
LONGFT1 = long term fuel trim %. pos % = detecting lean increasing fuel. neg % = detecting rich, decreasing fuel
S11_Cur = Bank 1 Sensor 1 upstream (before cat) A/F sensor current output. neg mA = rich, pos mA = lean
O2S12 = Bank 1 Sensor 2 downstream (aftercat) voltage output. 1v= rich, 0v = lean

1600706798476.png
 
Last edited:

AVC

:
'17 CX-5 Select
I just heard back from the dealer, who basically admitted that while they could sometimes duplicate the issue, it did not set a code, and it's too difficult for them to get reimbursed by Mazda unless it's a demonstrably failed part or a PID code. So they punted. At least I had their correctly running Mazda 3 to gather known good data from. That's a win.
 
I just heard back from the dealer, who basically admitted that while they could sometimes duplicate the issue, it did not set a code, and it's too difficult for them to get reimbursed by Mazda unless it's a demonstrably failed part or a PID code. So they punted. At least I had their correctly running Mazda 3 to gather known good data from. That's a win.
I have a bought-new 2019 CX-9 Touring, and I have caught it out several times when quickly changing from low-speed accel to off-throttle and back on, in tight traffic and, since you mentioned it, at least once it was with a U-turn. It would take 2-3 seconds to finally accept the open-throttle input and start accelerating. Pretty disconcerting and in one case, a bit nervous trying to pull out into moving traffic. Sounds like a "feature" of the standard-mode control system.
Next time I'll try Sport mode (if I can remember at the instant).
 
:
Ottawa, Ontario
:
17 Mazda 6 GT
I just heard back from the dealer, who basically admitted that while they could sometimes duplicate the issue, it did not set a code, and it's too difficult for them to get reimbursed by Mazda unless it's a demonstrably failed part or a PID code. So they punted. At least I had their correctly running Mazda 3 to gather known good data from. That's a win.
What a sorry excuse for a dealership. I mean, really.
They're more concerned about getting comped by Mazda than servicing their customers?
And we wonder why automotive dealerships get such a bad reputation.
I would file a complaint with Mazda Corporate about these guys, and then find another dealer to take it to.
 

AVC

:
'17 CX-5 Select
They are caught in a hard spot; they won't get reimbursed by using the parts cannon, so are conditioned to fix issues that are bad enough to set codes, or busted in half, leaking, etc. Most auto techs are also not great, or are pressured not to solving drivability problems that don't set codes. Thus, most techs don't get much pratice at this level of diagnostic, and thus never get good at it. In my case, I believe the Mazda 3 data was extremely valuable, and is pointing to an under-reporting MAF, where I may spend my own $100 to test that theory. We'll see. Cheaper than a diagnostic fee.

Oh, this is the 2nd DFW dealer to look into this issue in the last 6 months. Both were nice about it, but came up snake eyes. I know now it is NOT normal behavior, based on driving and measuring the Mazda 3 the last 4 days.
 
:
Ottawa, Ontario
:
17 Mazda 6 GT
If it's a 2018 as stated, then it should be under warranty.
The dealer/Mazda is responsible for this fix, not the owner.
Just because the dealer might not get compensated by Mazda Corp doesn't absolve them (or Mazda) of having to fix the problem.
 

yrwei52

2016 Mazda CX-5 GT AWD w/Tech Pkg
Contributor
:
Plano, Texas, USA

Oh, this is the 2nd DFW dealer to look into this issue in the last 6 months. Both were nice about it, but came up snake eyes. I know now it is NOT normal behavior, based on driving and measuring the Mazda 3 the last 4 days.
Have you tried Town North Mazda in Richardson? Does your 2017 CX-5 still have new car warranty?

I’d escalate the case to Mazda North American Operations and ask them to send a regional service manager or field engineer to diagnose the issue with your evidence at a Mazda dealership. This will happen if you still have warranty. After all this’s a dangerous problem to have, and hopefully this’s only happening in few isolated situation for certain CX-5’s.
 
:
Pueblo county CO
:
CX-5 Sport 16.5 6M
I had a similar issue with my 2007 Saturn Vue, but it only happened once. On another occasion the instrument cluster went dead. Once the rpm reading on the tach read about double. But they were all isolated occurrences and were impossible to recreate. It was probably the BCM, body control module.
 

AVC

:
'17 CX-5 Select
Yes, just got the vehicle back from Town North yesterday. Very pleasant folks, and they did drive it a fair bit, looked at basic OBD data (you wouldn't detect anything wrong from that). The senior tech said if it didn't set a code, then the drivability issue couldn't be that serious--that's bunk! I have the SKyactiv 2.5L shop manual. Unless it's a Federal Emissions issue, most other parameters have to be quite messed up before it sets a PID and CEL.

What they didn't do, which I am surprised, is a basic WOT test and log basic fuel, air and timing PIDs. Then compare it to at least one other CX-5. WOT tests are like heart stress tests; while you might have slight symptoms with light exercise that don't show clearly on an EKG, when stressed the symptoms and cause are evident in spades, When you fix that, you address al the symptoms, at rest and when stressed.
 
Last edited:
:
2018 CX-5 Sport
Once in a while I will get stuck in a gear in normal mode when hitting the gas. It takes maybe a half second to finally accelerate. It is like normal mode wants to get good gas mileage and is slow to down shift. It happens if I am driving at a certain slow speed and then hit the gas. The 10 to 15 seconds that the OP exeriences is a major issue and it sounds like a very dangerous situation.
 
:
2017 Mazda CX-5 GT, 2016 Mazda6 iGT, 2014 Mazda3 sGT hatchback
My guess is that (unless something is indeed broken), could be the AT module has been learning your mild/gentle driving style for a long time. When you push the gas pedal hard all of a sudden, it needs to wake up and ask
"Are you serious? Really? OK. I will do it." :)

To verify, drive it more aggressively for a period of time and watch if the hesitation issue still shows up.
 

AVC

:
'17 CX-5 Select
I tested that. When it decides to bog--more likely when it's 90F or more and the A/C is on-- stabbing the throttle to the floor doesn't suddenly wake it up when doing that u-turn thing, even though it does shift from 3rd to 2nd (but not 1st). Still takes 2 to 3 count to recover power. I can watch fuel trims ramp up over that time as the PCM sorts it out what *appears* to be under-reporting from the MAF for that load condition.

Although it could be several things, I am suspecting a somewhat drifted out of calibration MAF. My WOT maxes at about 139 g/s at 6000 RPM, whereas the Mazda 3 I drove maxes at 164 ~ 169 g/s at 6000 RPM. That's about 17% to 20% difference, which is not insignificant. For these higher compression Skyactiv I would expect the WOT g/s to be .85 to .90 x rated horsepower, or about 169 g/s, which is about what the Mazda 3 produced.

Don't suppose anyone else out there has WOT data for their 2014 or later CX-5?
 
:
Pueblo county CO
:
CX-5 Sport 16.5 6M
I have a 2018 CX-5 with around 49,000 miles on it that occasionally won't accelerate, has anyone else had this issue and if so what was the problem? This weekend, I was nearly hit trying to make a u-turn when my car would not accelerate. I pushed the gas pedal and the motor did not rev up, almost like it vapor locked...after a about 10-15 seconds (felt like forever), it finally took off.
If you think it felt like vapor lock could it injectors or some other fuel system component? I think vapor lock is probably pretty rare with electric fuel pumps and the pressure in fuel injection rails.
Does the problem occur in hot weather?
 
:
2017 Mazda CX-5 GT, 2016 Mazda6 iGT, 2014 Mazda3 sGT hatchback
AVC,
MAP sensor is not expensive and easy to replace. You can get one from BAM and try it out. If not, you can keep it for future time or resell it on eBay. (or use MAP sensor cleaning detergent in the market)
My co-worker had MAP sensor failed on his '14 Mazd3 2L. There was no light on the dash. It just wouldn't start even with several good cracking. A MAP sensor on the verge of failure might behave unexpectedly.
 
Top