• Welcome to Mazdas247, the 24/7 Mazda Community and Resource. Learn about the benefits of becoming a Member here.
  • We're an Amazon Associate and eBay Partner. We earn from qualifying purchases.

Startup issue, Idle issue, running issue (all related)

:
2001 Mazda Protege MP3
I bought another mp3 from someone who rebuilt the engine. Strangest thing happens, when the car is started, it continually rev's up to redline unless put into gear. After I unplugged the IAC, the car idles around 2500 with a shaky idle. I removed the egr, cleaned, and kept the solenoid off as well. I cannot for the life of me figure out the problem. Im betting its the IAC but im not sure how to test it. Also, what should the throttle position be set at for idle? as the throttle is slightly angled open when depressed
 
:
2001 Mazda Protege MP3
Just did some more work on it, IAC seems to work fine, I messed with the AAS screw and nothing changed. Also, the short term fuel trim from the second o2 sensor is 99.5% and the timing advance for cylinder #1 is up to 63.5 degrees once it reaches idle at 6-6500 RPM. There arent any vacuum leaks that I can tell. Would a mis-adjusted camshaft cause this? even if off by one tooth?
 
:
2011 mazda 3 hatchback GT
yes that sounds like either the timing is off or the throttlebody/ iac is failing but sounds more like a timing issue
 
:
2001 Mazda Protege MP3
If anyone is wondering, I finished the car. Ended up replacing the entire intake manifold, which was the wrong manifold for the ECU setup, apparently the different manifolds can cause this issue.
 
Top