• Welcome to Mazdas247. Membership is free and offers many benefits, please Click Here to learn more, thanks!
  • Mazdas247 is an Amazon Associate and earns from qualifying purchases.

Signature: Invalid! ???? Has anyone seen this?

:
2017 CX5
I have 2017 CX5 Touring with navigation. Last week I attempted to download the Mazda Toolbox but my Mac operating system couldn't be upgraded high enough to work, so I ponied-up $1500 for a new Mac and downloaded the app.

I backed-up the SD card and proceeded to download the most recent update. After about 45 minutes I was "bounced" off the website so I tried again. After another hour I was bounced off again. The third try was a charm, or so I thought. The update was confirmed so I inserted it into my CX5 and tried using navigation, but no luck. I received a pop-up message that my vehicle did not come equipped with navigation even though I've had it since June of 2017.

I went back to the computer and attempted to download the update again, but it confirmed it was already on the card. Next I did an SD Card analysis and found that the card was completely valid and including my VIN number. I then saw a button that said Check Signatures and that's where I think I found the issue.

In the thousand of files that are downloaded in the update, each one of mine says "license: valid", but it also says "Signature: Invalid!" in red letters.

I spoke to my dealership and they said they've never seen that before. They suggested I let them do a diagnostic on the card and system, but after finding out it was going to cost $400 or more I declined.

I've spoken with Mazda Connect at least 5 times today and have a case number, but it appears that no one has any idea what "Signature: Invalid" means or how to correct it (short of spending $400 for a new SD card). You would think that the company (Mazda) who designed the system would have some idea of how it works and how to correct the problem, but apparently not.

Can anyone help me out. I have a trip planned for Saturday and need the navigation working.
Thanks,
Duke
 
Last edited:

Latest posts

Weekly Poll: Interested in the MX-30?

  • Yes

    Votes: 9 31.0%
  • No

    Votes: 7 24.1%
  • I want an Electric CX-3, 30, 5, 8 or 9

    Votes: 13 44.8%
  • I want an Electric Mazda2, 3, 6 or Miata

    Votes: 1 3.4%
Top