Running hot Issue p5

Hey guys, I am experiencing some issues with my P5. Auto with 170K on it. I have a autometer water temp gauge installed on it (sender unit installed right below the intake tube). Recently driving into work while stuck in traffic I saw my water temp gauge shoot up to 250 which isnt normal. always ran between 180-210 max. I threw on the heat and it slowly went back down. Meanwhile the stock gauge on car remained normal nor did any steam or antifreeze spill out from anywhere.

I came home and check somethings and noticed my cooling fan stopped working so I replaced it. Figured i solved the problem however, its much better but the autometer gauge still shoots up to 250 after getting stuck in traffic. I work in NYC. No antifreeze or leaks are visible as well as engine steaming.

I thought i might have a bad head gasket so I went to the mechanic and he doubled checked and head gasket is good. He suggested it was the gauge sender unit going bad, however when we compared the readings with the computer and the gauge. it was slightly off but not by much. I do not currently have an CEL on. I called autometer which suggested might be a bad ground. I cleaned up the connections and switched it to a new location on the block.

I plan on flushing the system and replacing the stat next week.

any thoughts or suggestions what I should be looking at or for? Thanks!
 

pcb

The Diagram Dude
:
2002 MP5
Replacing the thermostat is a good idea.

That temperature of 250 may be normal for summer driving and stuck in traffic.

The stock temperature gauge is a dummy gauge but if it didn't move past half way then your ECU doesn't think the temperature is too hot.
 

pcb

The Diagram Dude
:
2002 MP5
If your radiator is old, it could be plugged up with corrosion and not as efficient any more.

I still think you're OK but if you ever see the stock temp. gauge move above half then you are in trouble.

I forget what temperature the stock gauge starts to move above half.
 

pcb

The Diagram Dude
:
2002 MP5
Another "trick" if you're concerned about your temperature is to turn on your AC.

It sounds counterintuitive like it would put more heat into the engine bay but when the AC is on the AC condenser fan is always running and if your temperature dial is set to warm or hot, your compressor isn't engaged all the time.
 
If your radiator is old, it could be plugged up with corrosion and not as efficient any more.

I still think you're OK but if you ever see the stock temp. gauge move above half then you are in trouble.

I forget what temperature the stock gauge starts to move above half.

i honestly think that it still is the original radiator from the car. Should I just go head and replace it to be safe?
 

pcb

The Diagram Dude
:
2002 MP5
That's up to you but I don't think you have anything to worry about if your stock temp gauge stays at half.

I would'nt put a new rad on my car but it's a rusty turd. lol

If it was my car I'd try some rad flush but that can cause problems too. (it can release big chunks of crap that plug things up)
 
:
protege5
is your coolant level low? If so, it may be something as simple as a radiator cap. it will blow coolant into the overflow reservoir while you're driving, overfill it and it will drain as you drive out the overflow tube. then when you stop and it cools, it will suck it back in. you'll never see a leak but actually losing coolant.
 
Top