NA MX-5 Radio fixed, car won't start...Help

I have a 1995 miata and when we got it, the radio wasn't working plus it had a SiriusXM attachment. Removed SiriusXM, found a blown fuse for the radio now the car will not start. Just for fun I hooked the Sirius xm back up and put the old blown fuse back in and car still won't start.

Any ideas? Any suggestions?
 

Antoine

Administrator
I'll try although I don't have a Miata or experience with this issue, hopefully fellow Members who do can chime in...Have you tried replacing the fuse and testing with and without SiriusXM?
 
I'll try although I don't have a Miata or experience with this issue, hopefully fellow Members who do can chime in...Have you tried replacing the fuse and testing with and without SiriusXM?

I have, I put all back as was with the blown fuse. I've tried several times.. Lol
 

Antoine

Administrator
So to clarify you placed a new fuse in the place of the blown one? Did you make sure it was the same exact fuse? All other fuses are ok?
 
Yes, we looked it up. I think it was a 10, maybe a 15. But I did check all 3 places for fuses. I'll really don't want to tow it to a shop. But, it's looking that way,
 

CTt3P5

TAD
Contributor
:
2008 MX-5 SE
I am by no means an electrical guru but might you have accidentally unplugged something during the SiriusXM removal? Not sure how it was installed in your car, was it a simple unplugging of a harness or did you have to get a little more involved?
 

CTt3P5

TAD
Contributor
:
2008 MX-5 SE
Hmmmm....

I know you said you re-installed as-was but by chance was there another ground wire connected in the same spot?

Have you checked the fuse boxes for any other blown fuses, specifically for the starter? When my starter started to go on my NC, it would blow the fuse when I turned the ignition over. So maybe just coincidence?
 
Ok, Y'all ready for my stupid moment? When I found the blown radio fuse a few weeks ago I replaced it to get the radio working. But, what I don't remember doing is pulling another 15 amp fuse to use temporarily. I Google the fuse box cover & realized the engine fuse was missing.... Smh... Thanks for the help!!
 

Antoine

Administrator
Ok, Y'all ready for my stupid moment? When I found the blown radio fuse a few weeks ago I replaced it to get the radio working. But, what I don't remember doing is pulling another 15 amp fuse to use temporarily. I Google the fuse box cover & realized the engine fuse was missing.... Smh... Thanks for the help!!
Awesome, thanks for the update! (y)
 

CTt3P5

TAD
Contributor
:
2008 MX-5 SE
Hey, we have all been there at some point! Just happy it was an easy fix!

This is why I keep a container of extra fuses in my trunk. This way I can grab a new one vs taking it from somewhere else and then forgetting to put it back.
 
Top