2017~2021 Radar cruise control intermittently disabled below 20mph

cdaling

Member
:
2017 CX-5 GT w/Tech
Same with me on the non-factory remote start. I get the error, shut off the car, restart and it's good. Interesting.

FYI the error detail screen for me showed no better information. "SBS Brake/MRCC Unavailable" is what I get with the error about cruise < 30kph not working.
 
:
Mississauga, CA
:
2017 CX-5 GT
I am getting the same message where the MRCC is disabled under 30km/h. I noticed that it shows this message if I start the car using the aftermarket remote starter (Idatastart). If I start the car normally using the push button I don’t get the message. Looks like there is an issue with the remote starter integration with the car electronics.
 
:
2016 CX-9 GT AWD
Make sure your windshield and sensor up front are clean. For the sensor I used Sonax Brilliant Shine Detailer as it is very hydrophobic and repels rain and dirt much better. I even wiped the rear camera lens with it so rain drops dont stay.

great idea about the backup camera. every time it rains i have to wipe it down
 

Smalltalker

Member
:
2018 CX-5 GT
I had exactly this issue: Mazda radar control error below 20mph and auto-hold not engaging after a remote start (after market, I think it's a compustar brand), everything works fine if started manually. As I spotted right after the remote starter was installed I was pestering my installer for a fix, which in turn pestered the manufacturer of the remote installer. The remote start manufacturer just released a new firmware, I got it installed today, and I'm happy to report that everything works perfect now: Remote start, unlock the door, open door, engine still running, take over by pressing brake pedal, and drive out as usual with all systems working as expected. Get in contact with your installers and hey could perhaps get it sorted.
 
:
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
Maybe Mazda should issue a warning notice during pre-purchase advising of issues with remote start & mrcc.

(hmm)
 

cdaling

Member
:
2017 CX-5 GT w/Tech
I had exactly this issue: Mazda radar control error below 20mph and auto-hold not engaging after a remote start (after market, I think it's a compustar brand), everything works fine if started manually. As I spotted right after the remote starter was installed I was pestering my installer for a fix, which in turn pestered the manufacturer of the remote installer. The remote start manufacturer just released a new firmware, I got it installed today, and I'm happy to report that everything works perfect now: Remote start, unlock the door, open door, engine still running, take over by pressing brake pedal, and drive out as usual with all systems working as expected. Get in contact with your installers and hey could perhaps get it sorted.

Awesome. Thanks for posting. I'll talk with my dealer. I have a compustar as well
 

cdaling

Member
:
2017 CX-5 GT w/Tech
I had exactly this issue: Mazda radar control error below 20mph and auto-hold not engaging after a remote start (after market, I think it's a compustar brand), everything works fine if started manually. As I spotted right after the remote starter was installed I was pestering my installer for a fix, which in turn pestered the manufacturer of the remote installer. The remote start manufacturer just released a new firmware, I got it installed today, and I'm happy to report that everything works perfect now: Remote start, unlock the door, open door, engine still running, take over by pressing brake pedal, and drive out as usual with all systems working as expected. Get in contact with your installers and hey could perhaps get it sorted.

Do you know what version/date the installer flashed your remote start to?
 
:
Mississauga, CA
:
2017 CX-5 GT
I had my remote start module flashed with the latest firmware but unfortunately it did not fix the issue. Idatastart released 3 updates since I installed the starter in Sep 2017 but none of them addressed this issue
 
:
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
Looks like both factory (aka dealer) installed and aftermarkets don't work with MRCC properly
 

Brad J

Member
:
Mazda CX-5 Sport
I purchased my 2018 CX-5 just a few weeks ago and the dealer had a 3rd party install a Compustar 2-way remote starter in it. I thought it was just an intermittent issue, but I noticed that sometimes it would display the "Mazda Radar Cruise Control Disabled under 20 MPH" error message. And then the Auto Hold function would also not work (it would just flash when I pressed the button). Weirdly, even with the error message the MRCC works fine. After reading here about the remote starters I have verified that this only happens when I remote start it, every time. I will be bringing it to the dealer and see what they can do. In the mean time, after remote starting it I get in and turn it off and restart the engine and it then works fine.
 
:
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
I purchased my 2018 CX-5 just a few weeks ago and the dealer had a 3rd party install a Compustar 2-way remote starter in it. I thought it was just an intermittent issue, but I noticed that sometimes it would display the "Mazda Radar Cruise Control Disabled under 20 MPH" error message. And then the Auto Hold function would also not work (it would just flash when I pressed the button). Weirdly, even with the error message the MRCC works fine. After reading here about the remote starters I have verified that this only happens when I remote start it, every time. I will be bringing it to the dealer and see what they can do. In the mean time, after remote starting it I get in and turn it off and restart the engine and it then works fine.

Be ware that the dealer might refer you to that third party installer.