pmartz16's new (to me) 1992 brilliant black miata

V
08.5 BM MS3, 14 MG Mazda3
Just ordered Hankook R-S3 V2 tires in 195/50/15 for the 6UL's. Is it sad that I ordered from another place over tire rack to save a dollar?
 
V
08.5 BM MS3, 14 MG Mazda3
MOTOR IS OUT! Finally! I cleaned and painted the new block and am in the process of cleaning and painting the actual engine bay so it looks a little more presentable. Just in the process now of swapping over parts. But I have pictures!


My new best friend!





 
Last edited:
V
08.5 BM MS3, 14 MG Mazda3
More parts! Clutch, clutch cover (which has been updated since the 1.6 release as it looks different and I almost shit a brick), accessory belts, comp motor mounts, water plug, PC'd intake manifold, PC'd valve cover, and random PC'd brackets and sensors.



 
V
2007 mazdaspeed 3 GT
Late to the party, just saw your post about me putting up the pic I had. Oh well. Can't wait to see this thing running!
 
V
08.5 BM MS3, 14 MG Mazda3
Got he head back together with the help of Jake and his fancy valve tool. so the head is tq'd down and on cams are on and tq'd down. just need to get the timing done then the motor will be wrapped up and put into the car. Have to install he clutch that I got too. Also I didin't notice before but the new clutch that I ordered FROM MAZDA is an Exedy clutch not Mazda

 

Lewis7789

Evan aka "Lady Hands"
Contributor
V
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Exedy is the OE supplier for a lot of companies, homie. ;)
 

Lewis7789

Evan aka "Lady Hands"
Contributor
V
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Exedy used to make the OE clutches for the Protege's. Like Luk makes the OE clutches for the MS6/MS3. Takata makes OE seat belts, etc.

Again, high five on all the progress, buddy! Looking forward to seeing her at a Menchies meet or auto-x soon!
 
V
08.5 BM MS3, 14 MG Mazda3
Going to finish up a timing job tonight then hope to get the timing belt done on the miata. Have to figure out a way to tq the exhaust cam sprocket without the cam moving. The directions are pretty vague online. I think I'm.going to have to order the timing tools from flyin miata
 
V
08.5 BM MS3, 14 MG Mazda3
I tried to do that but for some reason my wrenches don't want to stay and they slip off when I try to tq down the exhaust cam sprocket because I replaced those oil seals. But yes I would love to borrow them!
 

Lewis7789

Evan aka "Lady Hands"
Contributor
V
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
But dat wrap job doh...


le bump for more progress pics because I know it's on the verge of firing up now. :)
 
V
08.5 BM MS3, 14 MG Mazda3
Yes she is about to start up. I am having some issues with her starting up though. She will just turn over and over and over and never actually fire. I am not getting spark but I have been told that bad gas can do that. So I am going to drain the little less than 1/4 of a tank that has been in there since it blew and replacing it with some Sunoco 93. Hoping that does it and she fires up. As she turns over though she sounds pretty healthy.
But some engine bay pictures as she is all together. I did get a new top, an aftermarket unknown brand header (pictured above) and a new head unit for 150.

 

o0n8

Still have noob questions
V
74 Schwinn Varsity, 75 Camaro (Project), 04 6 Wagon
fuel pump screen or filter might be clogged from the bad gas
 
V
08.5 BM MS3, 14 MG Mazda3
I have fuel at the fuel rail. At this point I think it is a wiring issue. I am going to follow all the wiring harnesses and make sure everything is okay. The car did catch on fire so maybe something got messed up. I'm not sure I just want it fixed haha.
 
V
08.5 BM MS3, 14 MG Mazda3
Okay so I was told to throw up the details of my issues here also to see if someone here may have a solution.
So motor is in, new battery (been on tender), new plugs, and new premium fuel in take after draining old fuel out. The car will turn over strong and sounds like it should fire but I don't have any spark. I have power at the ECU so I replaced the Main 80A fuse in the engine bay to see if thats what it is. its not. All the grounds are good, after I fixed the one under the car on the frame rail thing next to the drive shaft. All the plugs have a home, correct home also.
But there are two lights that come on the dash. The charge battery light and the brake light come on. Once you put down the parking brake the brake light goes away and then just the battery charge light stays on. But they go back and forth on which light wants to be on. The check engine light never comes on the dash when I turn the key like it should. Could be burnt out but not sure. I think I am going to try and sway out the ECU with a known good one to see if that works. I have changed out the coilpack with a known good one and nothing changed. Does it matter where the CAS is tightened to on the back of the intake cam? could that be my issue? Need to mess with it like a DSM?
 

Lewis7789

Evan aka "Lady Hands"
Contributor
V
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Yeah, I thought that might be a key to your issue is that parking brake light is always on even with the key not in the accessory position. I wonder if there is a short in the wiring that isn't letting the motor get a spark as a default safety precaution.
 
Top