Please help - Replacement Stereo System Driving Me Mad - No Right Hand Side Audio

:
2014 CX5 2.2 Sport Nav
Hi, I have a 2014 2.2D Sport Nav, which came with the NB1 Mazda Tom Tom/Touch Screen System.

I have replaced with a Sony Android Auto unit, which is great. I have got the rear park camera connected fine (UK wiring seems different to some guides I've seen - only 2 wires for the camera, VID+ and Ground).

Everything is good, other than for the life of me, I cannot get sound out of the right side of the car. I have used some Connects2 fitting kits for steering wheel controls and harness adapter, which included a unit to drop the line level outputs from the stereo to pre-out levels required for the Bose system, and the left channel works fine, but right channel is dead.

I have tried bypassing this unit using RCA outputs from the stereo into the wiring harness, it's still no different, which got me thinking - is it something possibly to do with the car's factory Nav system muting the right (drivers - UK Car remember) side for a voice prompt which will never come, as there is no nav unit there any more? Has anyone come accross this before?

I need to pull the stereo again and double double check the wiring connections for the audio channels, but I can't see them being wrong.

Will pulling the battery earth off reset anything? Is it worth trying?

Any other pointers? My other thought was going directly from the RCA outputs on the stereo straight into the Bose amp, which I believe is in the drivers kick panel - is that correct?

Many Thanks for the pointers so far I have gained from the forum.
 
:
2014 CX5 Sport Nav (GT) MT 2.2D 150ps
Hi,

I also have a 2014 CX-5 Sport Nav and fitted a Sony XAV-AX100 last year. I also used the same Connects2 steering wheel adapter and connected the RCA-out connections to the Bose amplifier, so I think Ive got a very similar setup to you! Im very happy with it and having changed all of the speakers too (except the front doors) and fitting soundproofing, have an amazing-sounding and -working system in my CX-5.

In my case, everything worked flawlessly first time so I cant offer much in the way of troubleshooting tips.
Bear in mind that with the original NB1 head unit, only the front driver speaker would fade out to read Satnav instructions, so the fact youre not getting sound from any right channel indicates a problem somewhere before the amp.
Im sure youve checked already the balance/fader settings on the head unit or source (e.g phone if youre using Bluetooth).
 
:
2014 CX5 2.2 Sport Nav
Thanks for that, at least I know it's something in the wiring this side of the Mazda connector. Will pull it all out again and check what's what. I'm not 100% confident in the Connects2 plug, as the Amp switch on was in the wrong pin so don't know if anything else is wrong.

Another question, does your illumination work properly? I noticed that the dimmer isn't switching on and off when the lights are on/off.
 
:
2014 CX5 Sport Nav (GT) MT 2.2D 150ps
Thanks for that, at least I know it's something in the wiring this side of the Mazda connector. Will pull it all out again and check what's what. I'm not 100% confident in the Connects2 plug, as the Amp switch on was in the wrong pin so don't know if anything else is wrong.

Another question, does your illumination work properly? I noticed that the dimmer isn't switching on and off when the lights are on/off.

The Connects2 adapter works alright for me, what's annoying is that the steering wheel controls for the phone and voice command don't work (which would be great for CarPlay). I asked Connects2 about the possibility of them enabling these to work, as I would assume it's the same CAN commands as the other controls but they basically said no. I'm pretty sure I've read on other threads about steering wheel control adapters in the US that can interpret these buttons.
With the illumination, yes it worked straight out of the box. The only thing that I had to figure out is that the reverse and handbrake wires were reversed, that caused me some frustration!
 

Latest posts