P0134

:
mazda5 GT 2009
I have a CEL with P0134 code on my M5 2009 GT with 124K+ miles. Most likely O2 sensor needs to be replaced for the first time. I just wanted to hear about experiences/opinions of those who have replaced theirs. Did it clear the code? Dis replacement last? Did you use OEM or aftermarket (denso or ntk or other brand)? Also, does anyone know what company makes the OEM sensors for mazdas, particularly mazda 5s? Thanks.
 
:
2012 Mazda 5
This could be a dead O2 or a bad/corroded wire/connector.
If the wiring is ok, I'd just swap the sensor out. Do it on the warm engine, but not hot, just enough to warm up the sensor but not burn your hands on the exhaust.
I've not had to do it on a 5 yet, but plenty on others. I usually stick with Denso or Bosch or NTK.
I found OEM to be way over price and cheap sensor don't last or just garbage out of the box. Make sure to get one with a full harness, not just 3 wires that you need to splice.
On a mazda it is a little bit of an expensive part, even aftermarket. Check local Napa, see if they get you a good price.
 
:
mazda5 GT 2009
This could be a dead O2 or a bad/corroded wire/connector.
If the wiring is ok, I'd just swap the sensor out. Do it on the warm engine, but not hot, just enough to warm up the sensor but not burn your hands on the exhaust.
I've not had to do it on a 5 yet, but plenty on others. I usually stick with Denso or Bosch or NTK.
I found OEM to be way over price and cheap sensor don't last or just garbage out of the box. Make sure to get one with a full harness, not just 3 wires that you need to splice.
On a mazda it is a little bit of an expensive part, even aftermarket. Check local Napa, see if they get you a good price.
Thanks! I had a shop install a Denso. Code is clear now. Hoping this sensor lasts another 100k miles.
 
Top